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Introduction

 

elcome to Adobe

 

®

 

 LiveMotion

 

® 

 

2.0, a powerful application for designing and 
developing interactive content. Whether you’re a novice or an Web design 
expert, Adobe LiveMotion offers you the tools you need to get 

professional-quality results.

You’ll find that Adobe LiveMotion excels as an animation production tool, whether you 
are a designer, or a creator of Web pages or online content. LiveMotion gives you an 
unmatched level of precision and control over your Web compositions and the flexibility 
to produce anything from small designs to large, complex Web pages. It also provides a 
consistent work environment with other Adobe applications including Adobe 
Photoshop

 

®

 

, Adobe Illustrator

 

®

 

, and Adobe GoLive

 

®.

 

Registration

 

Adobe is confident you will find that its software greatly increases your productivity. 
So that Adobe can continue to provide you with the highest quality software, offer 
technical support, and inform you about new LiveMotion software developments, please 
register your application. 

When you first start the application, you’re prompted to register online. You can choose 
to submit the form directly or fax a printed copy. You can also register by filling out and 
returning the warranty registration card included with your software package. 

 

Installing Adobe LiveMotion

 

You must install LiveMotion from the Adobe LiveMotion CD onto your hard drive; 
you cannot run the program from the CD. 

Follow the on-screen installation instructions. For more detailed information, see the 

 

HowToInstall

 

 file on the CD. 

W
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Getting started

 

Adobe provides a variety of options for you to learn LiveMotion, including printed guides, 
online Help, and tool tips. Using the Adobe Online feature, you can easily access a host of 
continually updated Web resources for learning LiveMotion, from tips and tutorials to 
tech support information. Getting up to speed depends on your experience with previous 
versions of LiveMotion.

 

If you are new to LiveMotion:

 

•

 

Read through the “Overview” chapter for an introduction to the software.

 

•

 

See Chapter 1, “LiveMotion Basics” on page 9 to familiarize yourself with LiveMotion 
terminology, tools, and the work area.

 

•

 

See Chapter 2, “Drawing Objects” on page 22 to learn how to create shapes and other 
objects.

 

•

 

See Chapter 10, “Animating Objects” on page 83 to learn about animation in 
LiveMotion 2.0.

 

•

 

Use the LiveMotion tool tips feature to help identify tools, buttons, and palette controls 
as you work in LiveMotion. See “Using tool tips” on page 4.

 

•

 

Go to the Adobe.com Web site and work through some of the LiveMotion tutorials for 
hands-on lessons. See “Using Web resources” on page 4.

 

If you are an experienced LiveMotion user:

 

•

 

Scan through “Using text in compositions” on page 30 to learn about the new text 
functions.

 

•

 

See “Opening After Effects/AMX format files” on page 63 for information about 
bringing files created in After Effects 5.5 or later into LiveMotion 2.0.

 

•

 

See “Showing, hiding, and locking objects” on page 88 to learn how to control whether 
objects are displayed or editable.

 

•

 

See “Attaching behaviors and other scripts to rollovers” on page 115 to learn how to 
attach scripts to the different states of a rollover.

 

•

 

See “About scripts” on page 124 for a high-level introduction to the scripting features 
of LiveMotion 2.0.
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•

 

See “Optimizing your compositions” on page 129 to learn how to create animation files 
that load quickly and play smoothly.

 

If you are a developer:

 

•

 

See “Managing files with WebDAV” on page 64 to learn about the asset management 
features in LiveMotion.

 

•

 

See “Adding metadata to documents” on page 68 to learn how to add

 

 

 

descriptive infor-
mation about the contents of a document that can be searched and processed by a 
computer.

 

•

 

See “Saving and applying animations as styles” on page 102 to learn about the benefits 
of using styles with animations.

 

•

 

See “Working with labels” on page 110 to learn about using labels for references that 
scripts point to.

 

•

 

See “Working with script keyframes” on page 111 to learn how to add a script keyframe 
to any point in an animation.

 

•

 

See the 

 

Adobe LiveMotion 2.0 Scripting Guide 

 

to learn how to create your own scripts to 
use in LiveMotion.

 

Using the printed documentation

 

In addition to this user guide, the 

 

Adobe LiveMotion 2.0 Scripting Guide

 

 is included with 
Adobe LiveMotion 2.0. The 

 

Adobe LiveMotion 2.0 Scripting Guide

 

 contains information on 
creating and using scripts in LiveMotion 2.0. You will also find many PDF documents on 
the LiveMotion CD.

 

Using online Help

 

Adobe LiveMotion also includes complete documentation in an HTML-based help 
system. The LiveMotion help system includes all of the information in the 

 

Adobe 
LiveMotion 2.0 User Guide

 

 plus keyboard shortcuts, full-color illustrations, and more 
detailed information about some procedures. (A printable version of the Help content is 
available in PDF format on the Adobe LiveMotion CD.)
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Online Help provides three ways of locating information. The Contents and Index tabs let 
you find general information, and the Search tab lets you look up specific words or 
phrases. 

For more detailed information about using online Help, click on the Help button 
next to the Content, Index, and Search tabs.

To properly view online Help topics, you need Netscape Communicator 4.0 (or later) or 
Microsoft

 

®

 

 Internet Explorer 4.0 (or later). You must also have JavaScript active.

 

To start online Help:

 

Choose Help > LiveMotion Help, or press F1 (Windows).

 

Using tool tips

 

The tool tips feature lets you display the name of tools, or buttons and controls in palettes.

 

To identify a tool or control:

 

Position the pointer over a tool or control and pause. A tool tip appears showing the name 
and keyboard shortcut (if any) for the item.

 

Note: 

 

Tool tips are not available in most dialog boxes.

 

Using Web resources

 

If you have an Internet connection, you can use the Adobe Online feature to access 
additional resources for learning LiveMotion located on the Adobe.com Web site. 
From the Adobe.com home page, select Products. Then choose LiveMotion and go to 
Training & Events.

These resources are continually updated and include the following:

 

Tutorials and Techniques

 

Provide step-by-step instructions on using LiveMotion’s 
features or help on performing advanced techniques. These tutorials can help you go 
beyond the reference information contained in the user guide and show you how to use 
LiveMotion with other applications.
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How Tos and Backgrounders

 

Provide access to procedures for performing tasks in 
LiveMotion and to detailed reference information on a variety of topics. This information 
provides help on everything from common processes to the complex inter-application 
tasks necessary to prepare graphics for the Web.

 

Troubleshooting

 

Provides access to solutions to problems you may encounter using 
LiveMotion. You should check out troubleshooting information available through Adobe 
Online and the Adobe Web site before you call customer support.

 

To access Adobe’s home page for your region:

 

1

 

Open Adobe’s U.S. home page at www.adobe.com.

 

2

 

From the Adobe Worldwide menu, choose your geographical region. Adobe’s home 
page is customized for 20 different geographical regions.

 

About Adobe Online

 

Adobe Online provides access to the latest tutorials, quicktips, and other Web content for 
LiveMotion and other Adobe products. Using Adobe Online, you can also download and 
view the current version of the LiveMotion Top Issues document containing the latest 
LiveMotion technical support solutions. Bookmarks are also included to take you quickly 
to noteworthy Adobe—and LiveMotion—related sites. 

 

Using Adobe Online

 

Adobe Online is constantly changing, so you should refresh before you use it. Refreshing 
through Adobe Online updates bookmarks and buttons so you can quickly access the most 
current content available. You can use preferences to automatically refresh Adobe Online. 

When you set up an Internet connection to Adobe Online, Adobe can either notify you 
whenever new information is available through the Downloadables feature or automati-
cally download that information to your hard disk. If you choose not to use Adobe’s 
automatic download feature, you can still view and download new files whenever they are 
available using the Downloadables command in the Help menu. 
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To use Adobe Online:

 

1

 

In LiveMotion, choose Help > Adobe Online, or click the icon at the top of the toolbox.

 

Adobe Online icon

 

Note: 

 

You must have an Internet connection to access Adobe Online. Adobe Online will launch 
your browser using your default Internet configuration.

 

2

 

Do any of the following:

 

•

 

Click any button in the Adobe Online window to open the linked Web page.

 

•

 

Click the bookmark button  to view Adobe-suggested Web sites related to 
LiveMotion and Adobe. These bookmarks are updated as new Web sites become 
available.

 

•

 

Click Close to return to LiveMotion.

 

3

 

To ensure that you are using the most current version of Adobe Online, do any of the 
following:

 

•

 

Go to the Adobe Product Update page at www.adobe.com/adobeonline to access the 
most recent information and downloads. 

 

•

 

Set the preferences for your operating system to enable automatic update options.

 

Note:

 

 You can set Adobe Online preferences by choosing Edit > Online Settings.

 

Accessing Adobe Online through the Help menu

 

The Help menu includes options to view and download information from Adobe’s 
Web site. 

 

To view updated articles or documents:

 

Click Help and choose the topic you want to view. 

 

Other learning resources

 

Other learning resources are available but are not included with your application.
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Adobe Press

 

Offers a library of books that provide in-depth training in Adobe graphics 
and publishing software, including the acclaimed Classroom in a Book series developed 
by experts at Adobe. For information on purchasing Adobe Press titles, visit the Adobe 
Web site at www.adobe.com, or contact your local book distributor.

 

The Adobe Certification program

 

Offers users, instructors, and training centers the 
opportunity to demonstrate their product proficiency and promote their software skills as 
Adobe Certified Experts, or Adobe Certified Training Providers. Certification is available 
worldwide. Visit the Partnering with Adobe Web site at http://partners.adobe.com to learn 
how you can become certified.

 

Customer support

 

When you register your product, you may be entitled to technical support for up to 90 days 
from the date of your first call. Terms may vary depending on the country of residence. 
For more information, refer to the technical support card provided with the LiveMotion 
documentation.

 

Customer support on Adobe Online

 

Adobe Online provides access to the LiveMotion Knowledgebase, where you can find 
answers to technical questions.

 

Additional customer support resources

 

Adobe Systems provides several forms of automated technical support:

 

•

 

See the ReadMe and ReadMe First! files installed with the program for information that 
became available after this guide went to press.

 

•

 

Explore the extensive customer support information on Adobe’s World Wide Web site 
(www.adobe.com). To access Adobe’s Web site from LiveMotion, choose Help > Adobe 
Online or click the icon at the top of the toolbox. See “Using Web resources” on page 4.

 

•

 

Read the Top Issues PDF that is available from the Help menu. 
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Chapter 1: 

 

LiveMotion Basics

 

he Adobe LiveMotion work area includes the menu bar of commands at the top of 
your screen, the composition window containing artwork, and a variety of tools and 
palettes for editing and adding elements such as objects, layers, and text.

 

Understanding Adobe LiveMotion terminology

 

Understanding compositions, objects, layers, and animation will help you master Live 
Motion. With Adobe LiveMotion, you can easily design, create, and optimize Web anima-
tions, rollovers, navigation bars, and graphics. LiveMotion excels at Web animation and 
exports your work to Web animation standard formats—Flash, QuickTime, and GIF. You 
can also use LiveMotion to create and export small graphics or entire Web pages.

 

Compositions

 

Basic LiveMotion documents which you create. They contain one or more 
objects, and are displayed in the 

 

Composition window

 

. 

You can export individual objects in an image file format for placement in a Web page, or 
you can export the entire composition as a Web page in HTML format. You can also export 
compositions or individual objects as a Web-ready animation files in Flash (.swf ) or 
QuickTime formats, or as animated GIFs, or as PNG or JPEG image files.

 

Objects

 

Building blocks you create and work with in LiveMotion compositions. 
LiveMotion is an object-based application.

There are four kinds of objects:

 

•

 

Geometric objects are those you create with the drawing tools or drag from the Library 
palette. 

 

•

 

Text objects are blocks of text that you create using the type tool or the text field tool.

 

•

 

Image objects are bitmap graphics that you import into LiveMotion.

 

•

 

Sound objects are audio files that you import for animations and rollover effects. Sound 
objects do not appear in the Composition window. They appear only in the Timeline 
window.

 

Shapes

 

The visual boundaries of objects:

 

•

 

Geometric objects have either a regular path shape (rectangles, rounded rectangles, 
polygons, or ellipses, for example), or an irregular path shape.

 

•

 

Text objects are the shape of the individual characters in the text.

 

•

 

Bitmap images generally have a rectangular shape, unless they have an alpha channel 
or an active matte.

T
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•

 

EPS vector images are in the shape of the artwork itself. For example, an EPS vector 
image of a flower would be in the shape of that flower.

 

Different shape objects in LiveMotion

 

A. 

 

Geometric object

 

B.

 

 Text object

 

C. 

 

Image object (bitmap)

 

D.

 

 Image object (EPS vector) 

 

Object layers

 

The building blocks of objects. Object layers are part of an individual 
object; they are not part of the composition as a whole. An object is made up of 1–99 
layers, with each layer being the shape of that object.

When you first create an object, it has a single layer. You can add, delete, reorder, and offset 
layers at any time. For example, a layer can be added to an object and then offset to 
simulate a shadow for the object.

 

A LiveMotion object and its layers

 

A.

 

 Four-layered object as it appears in a composition

 

B.

 

 Individual layers in their stacking order

 

C. 

 

Layers shown in the Object Layers palette

A B

C D

A

B C
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Layer attributes

 

How the properties—color, gradients, distortion, and opacity—of a 
layer are defined. Attributes can be applied to any layer individually.

By applying different attributes to each layer, you can create a variety of effects and create 
complex objects. For example, to create a button out of a simple geometric object, you 
might give it three layers, and apply different effects to each layer. You could emboss the 
top layer and fill it with a texture. You could make the second layer wider and fill it with a 
color to give the effect of an outline around the button. And you could offset the third 
layer, and fill it with semitransparent gray to simulate a shadow for the button.

 

Styles

 

Collections of properties you can apply a style to any object to change the 
appearance of the object without changing its shape.For example, you can apply a style to 
a text object to give the object several layers. The text object would then have all the 
attributes of that style. There are also animation styles and Rollover styles that apply only 
to animations and rollovers. You can also save styles in the Styles palette and apply them 
to other objects.

 

Applying a style from the Styles palette

 

Animation

 

The application of changes to an object over time. You can do this for one or 
more objects simultaneously, and you can even animate changes to individual layers in an 
object. For example, you can rotate just the angle of a gradient effect applied to an object.

LiveMotion provides features that enable you to create rollovers and JavaScript actions. 
You can also update graphics and text in existing Web pages.

 

The LiveMotion file format (.liv format)

 

This file format embeds all objects and placed 
artwork in the composition, along with their modifications and their attributes, so that you 
can reedit the objects at any time.

 

Looking at the work area

 

LiveMotion gives you an efficient work area and user interface to create and edit composi-
tions for web pages. The LiveMotion work area is arranged to help you focus on your 
compositions.

 

Using tools

 

LiveMotion tools let you select, create, fill, edit, and view objects and backgrounds. The 
first time you start LiveMotion, the toolbox appears on the left side of the screen.

When you select a tool, that tool remains selected until you choose another tool. To 
change the default so that after you select a tool, it switches back to the selection tool, 
choose Edit > Preferences and select Auto-Revert to Arrow Tool.
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When you select most tools, the pointer matches the tool’s icon. For example, choosing 
the pen tool changes the pointer to a pen tip. 

 

LiveMotion toolbox

LiveMotion toolbox

 

LiveMotion includes these tools:

 

The selection tool 

 

Selects objects (see “Editing objects” on page 38).

 

The Subgroup-selection tool 

 

Selects objects and groups within groups (see “Editing 
objects” on page 38).

 

The drag-selection tool 

 

Selects objects by dragging, letting you select objects that 
are obscured by other objects (see “Editing objects” on page 38).

 

The layer-offset tool 

 

Moves the selected layer relative to the other layers in the object 
(see “Using the Layer palette” on page 72).

 

The rectangle tool 

 

Draws squares and rectangles (see “Drawing shapes” on page 21).

Layer-offset (O)

Rounded rectangle (R)

Polygon (N)

Pen selection (S)

Transform (E)

Eyedropper (I)

(U) Drag selection

Subgroup-selection (A) (V) Selection

 (M) Rectangle

(L) Ellipse

(P) Pen

HTML text (Y)(T) Type

(C) Crop

(K) Paint bucket

Zoom (Z)(H) Hand

Preview mode (Q)(Q) Edit mode

Foreground color
Background color

Color scheme
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The rounded-rectangle tool 

 

Draws squares and rectangles with rounded corners (see 
“Drawing shapes” on page 21).

 

The ellipse tool 

 

Draws circles and ellipses (see “Drawing shapes” on page 21).

 

The polygon tool 

 

Draws objects that have three to ten sides (see “Drawing shapes” on 
page 21).

 

The pen tool  

 

Creates paths, or adds or removes points from an existing path (see 
“Using the pen tool” on page 22).

 

The pen selection tool 

 

Selects and manipulates points on a path (see “Adjusting path 
segments” on page 26).

 

The type tool 

 

Creates type, and lets you enter and edit type (see “Using text in compo-
sitions” on page 30).

 

Text field tool 

 

Creates text in a container (see “Using text fields” on page 31).

 

The crop tool 

 

Adjusts the displayed portion of objects (see “Cropping objects” on 
page 53).

 

The transform tool 

 

Skews, shears, or rotates objects. Also moves the object anchor 
point (see “Transforming objects” on page 49).

 

The paint bucket tool 

 

Fills layers and objects with the current color or with a style (see 
“Copying colors and styles” on page 86).

 

The eyedropper tool 

 

Samples the color of layers and the style of objects (see “Copying 
colors and styles” on page 86).

 

The hand tool 

 

Moves the area being viewed within the composition window (see 
“Using Web resources” on page 18).

 

The zoom tool 

 

Increases and decreases the magnification in the composition window 
(see “Using Web resources” on page 18).

 

The edit mode button 

 

Activates the editing mode, LiveMotion’s default mode.

 

The preview mode button 

 

Activates the preview mode, which allows you to run 
animations and test rollovers.

 

To show or hide the toolbox:

 

Choose Window > Tools.

 

To move the toolbox:

 

Drag the toolbox by its title bar.

 

To select a tool:

 

Click its icon in the toolbox.

 

Using palettes

 

Palettes help you monitor and modify objects. By default palettes are docked in several 
groups. You can display or hide palettes as you work. The positions of all open palettes are 
saved when you exit the program. 

 

To show or hide a palette:

 

Choose the name of the palette from the Window menu. 
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A check mark next to the palette’s name in the menu indicates that the selected palette is 
at the front of its group.

 

To change the palette display:

 

To rearrange palettes to make better use of your work area, do one of the following:

 

•

 

To move a palette to the front of its group, click its tab.

 

•

 

To move an entire palette group, drag its title bar.

 

•

 

To rearrange or separate a palette group, drag a palette’s tab. Dragging a palette 
outside of an existing group creates a new group.

 

•

 

To move a palette to another group, drag the palette’s tab to that group.

 

•

 

To collapse or expand a group, click the minimize/maximize box (Windows) or the click 
the zoom box (Mac OS). You can open the palette menu from a collapsed palette.

 

•

 

To return palettes to their default settings, Choose Window > Reset to Defaults.

 

Entering values in palettes

 

Some palettes contain options that let you enter values using any combination of sliders, 
angle controls, arrow buttons, and text boxes.

 

Ways to enter values in palettes

 

A.

 

 Dial

 

B. 

 

Slider

 

C.

 

 Arrow buttons

 

D. 

 

Text box

 

To enter a value, do one of the following:

 

•

 

Drag the slider to the desired value.

 

•

 

Drag the dial to the desired value. 

 

•

 

Type a value in the text box. To apply your entry, press Enter or Return.

 

•

 

Click or press the up arrow or down arrow button in the palette to increase or decrease 
the value. 

 

•

 

(Windows) Click in the text field and then click the Up Arrow or Down Arrow key on the 
keyboard to increase or decrease the value.

You can use the Tab key to move between fields. 

 

Using palette menus

 

Palette menus are an important part of working with LiveMotion. Some commands in 
palette menus can be found in the menu bar; other commands are exclusive to palette 
menus.

A

C

D

B
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When a palette has a palette menu, a triangle icon appears at the top of the palette. THe 
exact location and appearance of the triangle icon depends on where the palette is 
located.

 

Properties palette menu

 

To use a palette menu:

1

 

Select a palette.

 

2

 

Click the triangle  in the upper right corner of the palette.

 

3

 

Choose a command from the palette menu.

 

Using context menus

 

In addition to the menus that appear at the top of your screen, Adobe LiveMotion contains 
a number of context-sensitive menus that relate to the document or selection.

 

To display a context menu:

1

 

Position the pointer over the composition or over an object in the composition.

 

2

 

Do one of the following:

 

•

 

In Windows, click the right mouse button.

 

•

 

In Mac OS, press Control and hold down the mouse button.

 

Organizing composition windows

 

Adobe LiveMotion gives you great flexibility in organizing your composition windows. 

 

To navigate in a composition:

 

If the composition window does not display the entire composition, do one of the 
following:

 

•

 

Use the composition window scroll bars.

 

•

 

Select the hand tool , and drag in the composition to move its view.

 

Dragging with hand tool to move area into view

 

To use the hand tool while another tool is selected, press and hold 

 

H

 

 or the spacebar 
as you drag in the composition.

This art is FPOThis art is FPO
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To arrange multiple compositions:

 

Do one of the following:

 

•

 

Choose Window > Stack to display composition windows overlapping from the top left 
to the bottom right of the screen.

 

•

 

Choose Window > Tile to display composition windows edge to edge vertically and 
horizontally. For example, if you have four open compositions, LiveMotion displays 
them tiled two across and two down.

 

•

 

In Windows, choose Window > Tile Vertical to display composition windows edge to 
edge vertically. For example, if you have four open compositions, LiveMotion displays 
them four across.

 

Magnifying and reducing the view

 

The zoom-in and zoom-out tools and commands let you magnify or reduce the display of 
any area in the file up to 64 times actual size, or 800%. Zooming in and out does not 
change the actual size of the file, only the magnification at which you see it.

 

Clicking with zoom tool to magnify view

 

To zoom in:

 

Do one of the following:

 

•

 

Select the zoom tool . The pointer becomes a magnifying glass containing a plus sign. 
Click at the center of the area you want to magnify. Each click magnifies the view to the 
next preset percentage. When the file has reached its maximum magnification level, 
the magnifying glass appears blank.

 

•

 

Choose View > Zoom. Each click magnifies the view to the next preset percentage. 
When the file has reached its maximum magnification level, the command is dimmed.

 

To zoom out:

 

Do one of the following:

 

• Select the zoom tool, then hold down Alt (Windows) or Option (Mac OS). The pointer 
becomes a magnifying glass containing a minus sign. Click the center of the area you 
want to reduce. Each click reduces the view to the previous preset percentage. When 
the file has reached its maximum reduction level, the magnifying glass appears blank.

• Choose View > Zoom Out. Each click reduces the view to the previous preset 
percentage. When the file has reached its maximum reduction level, the command is 
dimmed.

To magnify by dragging:

1 Select the zoom tool .

This art is FPOThis art is FPO
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2 Drag a dotted rectangle, called a marquee, around the area you want to magnify. To 
move the marquee around the artwork, begin dragging a marquee and then hold down 
the spacebar while dragging the marquee to a new location.

To display art work at 100%:

Do one of the following:

• Choose View > Actual Size.

• Double-click the zoom tool .

• Double-click the hand tool .

Using the Timeline window
The Timeline window displays all objects in the composition. Because selecting objects in 
one window selects them in the other, selecting objects in the Timeline window is equiv-
alent to selecting objects in the composition window. Selecting objects in the Timeline 
window is particularly useful if the composition window is crowded or if objects are 
hidden.

To view the Timeline window:

Choose Window > Timeline to show or hide the Timeline window.

Working with compositions
LiveMotion gives you tools and commands to create new compositions, edit your compo-
sitions, and then save or export your finished work. 

Creating and opening compositions
The New Composition command creates a blank, untitled LiveMotion composition. 

The Open command opens native LiveMotion files. Once opened, you can create, place, 
import, and modify objects in the composition. You can also use the Open command to 
open LiveMotion 1.0 files.

To create a new LiveMotion composition:

1 Choose File > New Composition.

2 Accept the default settings, or enter changes as necessary, and click OK.

By default, the work area for a new composition is 550 pixels wide by 500 pixels high and 
has a white background. The maximum size is 1024 by 1024 pixels.

To open an existing LiveMotion file: 

1 Choose File > Open.

2 Select the name of the file you want to open, and click Open.

Changing composition settings
The Composition Settings command lets you increase or decrease the size of the compo-
sition area and set the frame rate for your animations.

To change the composition settings: 

1 Choose Edit > Composition Settings.
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2 Enter the desired height, width, and frame rate. 

Note: Lower frame rates create smaller exported files, but choppy animation. Higher 
frame rates create smoother animation but larger exported files. Also, if the computer or 
Internet connection is not fast enough, animation with high frame rates may not run 
smoothly.

3 Click OK.

For more information on exporting files, see “About exporting” on page 140.

Editing compositions
You can edit individual objects or multiple objects at the same time. You can transform 
objects by skewing, rotating, and resizing them, regardless of the object type or the layer 
attributes. You can edit objects or individual layer attributes or entire styles at any time, 
regardless of the transformations you have made to the object.

Text objects are fully editable. You can rewrite the text in a text object, as well as change its 
font properties and layer attributes at any time.

Editing is nondestructive—that is, the underlying object can be recovered unaltered. For 
instance, you can shrink an imported image, skew it, apply a style to it, and still return the 
image to the way it looked when you first imported it—even if you’ve saved and closed 
the composition multiple times.

Undoing changes
Changes to your composition can be undone. You can even undo or redo an operation 
after you choose the Save command, as long as you haven’t closed the file. If an operation 
can’t be undone or redone, the command is dimmed and replaced by Can’t Undo or Can’t 
Redo. You cannot undo save and export commands. You can also undo multiple previous 
steps, although available memory may limit your ability to use this option.

If you want to undo all of the operations that you have performed since you last saved the 
file, use the Revert command rather than the Undo command. When you choose Revert, 
you lose all changes made to the composition since the last time it was saved.

Note: The Revert command cannot be undone.

To undo or redo previous operations:

Do one of the following:

• Choose Edit > Undo (operation) one or more times to move backward through the 
previous changes.

• Choose Edit > Undo > Undo (operation) followed by the name of the operation. This 
undoes all changes made after and including the operation.

• Choose Edit > Redo (operation) one or more times to move forward through the 
changes you undid.

• Choose Edit > Undo > Redo (operation) to redo all changes made after and including 
the operation.

• Choose File > Revert, and click OK (Windows) or Revert (Mac OS) to revert to the last-
saved version of the file.
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Saving compositions
A composition saved in the LiveMotion format (.liv) can be reopened and edited in 
LiveMotion. LiveMotion files use the extension .liv in Windows. The Windows and Mac OS 
LiveMotion file formats are completely compatible.

When you are ready to use your artwork on a Web page, you must export it in Flash (.swf ) 
format, as an animated GIF, or as a PNG or JPEG image file. See “About exporting” on 
page 140.

To save a composition in LiveMotion format:

Choose File > Save.

To save a composition with a different filename:

1 Choose File > Save As.

2 Enter a filename, choose a location for the file, and click Save.

Exporting Compositions
When you are ready to use you compositions on the Web, you must export them, rather 
than save them. LiveMotion supports several image and animation export formats and 
has a variety of tools for exporting individual objects for placement in Web pages. With 
the AutoLayout option, you can export your composition as image slices, with rollovers 
and remote rollovers intact. 

For information on exporting and file formats available in LiveMotion, see “About 
exporting” on page 140.

Printing compositions
LiveMotion compositions are intended for use on the Web, but you can also print them. 
LiveMotion resamples the composition to match the resolution of your printer.

Before you print a composition, use the Print Setup (Windows) or Page Setup (Mac OS) 
dialog box to select general printing options. The exact appearance of this dialog box 
depends on your hardware and software.

To select page setup options:

1 Choose File > Print Setup.

The exact appearance of this dialog box depends on your hardware and software. See 
your printer documentation for more information on these options.

2 Select the required page options, and click OK.

To print a composition: 

1 Choose File > Print.

2 Select the required printing options, and click OK (Windows) or Print (Mac OS).

See your printer documentation for more information on these options.

Setting Preferences
Several program settings are stored in the Preferences file. Preference settings are saved 
each time you exit Adobe LiveMotion.
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To specify preferences:

1 Choose Edit > Preferences.

2 Choose the desired preference:

• Auto-Revert to Arrow Tool to switch the active tool to the selection tool after any single 
use of another tool.

• Gridline Every to set the distance between gridlines.

• Subdivisions to set the number of subdivisions between gridlines.

• (Mac OS) Append File Extension to add a .liv extension to the file name (important if you 
will be sharing your files with Windows users).

3 Click OK.

Using Web resources
If you have an Internet connection and a Web browser installed on your system, you can 
use the Adobe Online feature to access the Adobe Systems home page on the World Wide 
Web. Adobe’s home page provides access to a host of resources you can use to get more 
out of LiveMotion. 

How To Provides access to procedures for performing tasks in LiveMotion. These proce-
dures provide help on everything from completing common processes, such as printing, 
to complex interapplication tasks, such as converting raster images to vector.

Tutorials Provide step-by-step instructions on using LiveMotion features or help on 
performing advanced techniques. These tutorials can help you go beyond the reference 
information contained in the user guide. Tutorials are constantly updated to provide help 
on new features or complex techniques. 

Quicktips Provide short, time-saving procedures to help you use LiveMotion more effec-
tively. Tips can be shortcuts for using new features, or instructions on using existing 
features more effectively.

Backgrounders Provide detailed reference information on drawing and illustration 
concepts.

Troubleshooting Provides access to solutions to problems you may encounter using 
LiveMotion. You should check out this section before you call technical support. Also, you 
can find FAQs (Frequently Asked Questions) that may help with technical problems. See 
“Customer Support on Adobe Online” on page 19.

About Adobe Online
Adobe Online provides access to the latest tutorials, quicktips, and other Web content for 
LiveMotion. You can also download and view the current version of the LiveMotion Top 
Issues document containing the latest LiveMotion technical support solutions. Bookmarks 
are also included to take you quickly to noteworthy Adobe- and LiveMotion-related sites. 

Using Adobe Online
Adobe Online is constantly changing, so you should refresh Adobe Online before you use 
it. Refreshing Adobe Online updates bookmarks and buttons so you can quickly access the 
most current content available. You can use preferences to automatically refresh Adobe 
Online daily, weekly, or monthly. 
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When you set up Adobe Online to connect to your Web browser, Adobe can either notify 
you whenever new information is available or automatically download that information to 
your hard disk. If you choose not to use Adobe’s automatic download feature, you can still 
view and download new files whenever they are available by using the Downloadables 
command in the Help menu. 

To use Adobe Online:

1 In LiveMotion, choose Help > Adobe Online, or click the icon at the top of the toolbox.

Note: You must have an Internet connection and an Internet browser installed. Adobe 
Online will launch your browser using your default Internet configuration.

2 Do any of the following:

• Click Refresh to make sure you have the latest version of the Adobe Online window and 
its buttons, as well as the latest bookmarks. It is important to refresh the screen so that 
the current options are available for you to choose from. 

• Set Adobe Online preferences by choosing Edit > Online Settings.

• Click any button in the Adobe Online window to open the Web page to which the 
button is linked.

• Click the bookmark button  to view Adobe- suggested Web sites related to 
LiveMotion and Adobe. These bookmarks are automatically updated as new Web sites 
become available.

• Click Close to return to LiveMotion.

Accessing Adobe Online through the Help menu
The Help menu includes options to view and download information from Adobe’s Web 
site. 

To view updated articles or documents:

From the Help menu choose the topic you want to view. 

Customer Support
When you register your product, you may be entitled to technical support for up to 90 
days from the date of your first call. Terms may vary depending on the country of 
residence. For more information, refer to the technical support card provided with the 
LiveMotion documentation.

Customer Support on Adobe Online
Adobe Online provides access to FAQs (Frequently Asked Questions) and technical guides, 
which can provide information on techniques not covered in the user guide or online 
Help. You can also access troubleshooting information that provides solutions to common 
problems.

Additional customer support resources
Adobe Systems provides several forms of automated technical support:

• See the ReadMe and ReadMe First! files installed with the program for information that 
became available after this guide went to press.
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• Explore the extensive customer support information on Adobe’s World Wide Web site 
(www.adobe.com). To access Adobe’s Web site from LiveMotion, choose Help > Adobe 
Online.

Read the Top Issues PDF that is available from the Help menu. 
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Chapter 2: Drawing Objects
here are several tools you can use to draw geometric objects in LiveMotion. You can 
create different effects with the drawing tools by customizing the options for each 
tool. 

About LiveMotion objects
Objects are the basic building blocks you use to design and build compositions for a Web 
page. You create geometric objects using shapes. Objects in a composition can be 
selected, moved, and modified individually or they can be grouped (see “Grouping 
objects” on page 47).

The stacking order of LiveMotion objects in a composition is based on their creation order. 
Newer objects are drawn in front of older objects. You can change the stacking order by 
moving objects in front of or behind one another. (See “Stacking objects” on page 39).

Drawing shapes
LiveMotion shape tools allow you to easily create different shapes. 

• The rectangle tool draws rectangles and squares.

• The rounded-rectangle tool draws rectangles and squares with rounded corners.

• The polygon tool draws objects with three to ten straight sides, each side being 
equidistant from the center of the object.

• The ellipse tool draws ellipses and circles.

To create a rectangle, rounded rectangle, polygon, or ellipse: 

1 Select the rectangle tool , the rounded-rectangle tool , the polygon tool , or the 
ellipse tool .

2 Drag diagonally until the shape is the desired size.

Shift-drag to draw shapes of equal height and width—for instance, to draw squares with 
the rectangle tool or circles with the ellipse tool. Hold down Alt / Option as you drag to 
draw the object from the center out.

Changing shape tool properties
To change the way a shape looks—for example, to change the width of the outline of a 
shape, you can use the shape options in the Properties palette (see “Modifying the 
properties of geometric shapes” on page 52).

T

bbaeck



Using Help | Contents | Index Back 22  

Help Drawing Objects 

Using Help | Contents | Index Back 22  

Using the pen tool
The pen tool lets you create straight lines and smooth, flowing curves with great precision. 
The pen tool creates freeform paths made up of one or more straight or curved segments. 
The beginning and end of each segment are marked by control points, which work like 
pins holding wire in place. You change the shape of a path by editing its control points 
using the pen selection tool . 

A path is either open, like an arc, or closed, like a circle. For an open path, the starting and 
ending control points for the path are called endpoints. You can control curves by 
dragging the direction points at the end of direction lines that appear at control points that 
form curves. 

Path segments
A. Selected endpoint B. Selected control point C. Curved path segment
D. Direction line E. Direction point

Paths can have two kinds of control points—corner points and smooth points. At a corner 
point, a path abruptly changes direction. At a smooth point, path segments are connected 
as a continuous curve. You can draw a path using any combination of corner and smooth 
points. If you draw the wrong kind of point, you can always change it.

Corner and smooth points
A. Four corner points B. Same point positions using smooth points
C. Same point positions combining corner and smooth points

A

B

D

E

C

A B C



Using Help | Contents | Index Back 23  

Help Drawing Objects 

Using Help | Contents | Index Back 23  

A corner point can connect any two straight or curved segments, while a smooth point 
always connects two curved segments.

A corner point connecting both straight segments and curved segments.

Drawing straight segments
You can draw a straight line by clicking (not dragging) the pen tool to create two control 
points. By continuing to click, you create a path made of straight line segments connected 
by corner points.

To draw straight segments with the pen tool: 

1 Select the pen tool .

2 Position the tip of the pen point where you want the straight segment to begin, and 
click to define the first anchor point (do not drag). The control point remains selected 
(solid) until you click to add the next point. 

Note: The first segment you draw will not be visible until you click a second control point. 
Also, if direction lines appear, you’ve accidentally dragged the pen tool; choose Edit > 
Undo, and click again.

3 Click again where you want the segment to end. (Shift-click to constrain the segment’s 
angle to multiples of 45 degrees.) This creates another control point. 

4 Continue clicking the pen tool to create additional straight segments.

The last control point you add appears as a solid square, indicating that it is selected. 
Existing control points become deselected as you add more control points.

5 Complete the path by doing one of the following:

• To close a path, position the pen pointer over the first (hollow) control point. A small 
loop appears next to the pen tool  when it is positioned correctly. Click to close the 
path.

• To leave the path open, Ctrl-click (Windows) or Command-click (Mac OS) anywhere 
away from all objects, or choose Edit > Deselect All, or select a different tool in the 
toolbox.
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About direction lines and direction points
Before you draw and modify curved segments with the pen tool, it’s important to under-
stand two elements that are associated with control points on curves. When you select a 
control point connecting curved segments, the segments display direction lines which end 
in direction points. The angle and length of the direction lines determine the shape and 
size of the curved segments. Moving the direction points reshapes the curves. Direction 
lines are for your reference and don’t appear on your Web page.

After selecting a control point (left), direction lines appear on any curved segments connected to it 
(right).

A smooth point always has two direction lines that move together as a single, straight unit. 
When you drag the direction point of either direction line on a smooth point, both 
direction lines move simultaneously, maintaining a continuous curve at that control point.

In comparison, a corner point has no direction lines. The angles of corner points are 
changed by dragging the corner point directly.

Adjusting direction lines on a smooth point (left) and a corner point (right)

Direction lines are always tangent to (perpendicular to the radius of ) the curve at the 
control points. The angle of each direction line determines the slope of the curve, and the 
length of each direction line determines the height, or depth, of the curve.

Moving and resizing direction lines changes the slopes of curves.
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Drawing curved segments
You create curves by using the pen tool to add control points where a curve changes 
direction, and to drag the direction points that shape the curves.

Curves are easier to edit and your system can display them faster if you draw them using 
as few control points as possible. Using too many points can also introduce unwanted 
bumps in a curve. Instead, draw widely spaced control points, and practice shaping curves 
by adjusting the length and angles of the direction lines. 

To draw a curved segment:

1 Select the pen tool .

2 Position the pen tip where you want the curve to begin, and drag to set the slope of the 
curve segment you’re creating. In general, extend the direction line about one third of the 
distance to the next control point you plan to draw. 

Drawing a curved segment
A. Positioning pen tool B. Starting to drag to create direction lines
C. Dragging to extend direction lines

3 Release the mouse button.

4 Position the pen tool where you want the curve segment to end, and do one of the 
following:

• To create a “C”-shaped curve, drag in a direction opposite to the previous direction line.

Drawing an C-shaped curve 
A. Starting to drag second smooth point to create direction lines B. Dragging away from previous 
direction line to create a “C” curve C. Result after releasing mouse button

A B C

A B C
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• To create an “S”-shaped curve, drag in the same direction as the previous direction line.

Drawing an S-shaped curve
A. Starting to drag new smooth point to create direction lines B. Dragging in same direction as 
previous direction line to create an “S” curve C. Result after releasing mouse button

5 Continue dragging the pen tool from different locations to create additional smooth 
points.

6 Complete the path by doing one of the following:

• To close the path, position the pen tool over the first (hollow) control point. A small loop 
appears next to the pen tip when it is positioned correctly. Click or drag to close the 
path.

• To leave the path open, Ctrl-click (Windows) or Command-click (Mac OS) anywhere 
away from all objects, or choose Edit > Deselect All, or select a different tool in the 
toolbox.

Adjusting path segments
You can change the shape of a path by adding, deleting, or moving the path’s control 
points. To adjust a curved segment, you move one or more of its control points or 
direction points. You can also adjust a path by converting smooth points to corner points 
and vice versa.

Adding, deleting, and converting control points 
You can add or delete control points on any path. Additional control points can give you 
more control over the path or extend an open path. Similarly, you can delete control 
points to change the shape of a path or to simplify the path. It’s a good idea to delete any 
unnecessary points to reduce the complexity of the path.

To add or delete a control point: 

1 Using the pen selection tool , select the path you want to edit.

2 Select the pen tool .

3 Do one of the following:

• To add a control point, position the pointer over a path segment and click. The angled 
slash next to the pointer becomes a plus  when it’s positioned over a path segment.

• To delete a control point, position the pointer over a control point and click. The angled 
slash next to the pointer becomes a minus  when it’s precisely positioned over a 
control point.

A B C
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To delete a starting control point:

Select the starting control point with the pen selection tool  and press the Delete key.

To extend an open path:

1 Using the pen selection tool , click the path you want to extend.

2 Position the pointer over the endpoint of the open path you want to extend.

3 Click the endpoint. If you want to lengthen the end line segment, drag the pointer.

4 Select the pen tool. 

5 Do one of the following:

• To create a corner point, position the pen tool where you want to end the new segment, 
and click. If you are extending a path that ends at a smooth point, the new segment will 
be curved by the existing direction line.

• To create a smooth point, position the pen tool where you want to end the new curved 
segment, and drag.

To switch between smooth points and corner points:

1 Using the pen selection tool, click the path you want to modify.

2 Position the pointer over the control point you want to convert, and press Alt 
(Windows) or Option (Mac OS). The pointer changes to a hollow arrowhead. 

• To convert a corner point to a smooth point, click the point and drag through 45 
degrees away from the required curve direction.

Dragging direction point out of a corner point to create a smooth point
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• To convert a smooth point to a corner point, click a smooth point, and drag through 180 
degrees towards the required curve direction.

Clicking a smooth point to create a corner point

Dragging to convert a smooth point to a corner point.

Adjusting straight and curved segments
You can modify the shape of a path by moving any of its control points or by moving the 
direction points of direction lines attached to a curve segment. Editing existing segments 
is slightly different from drawing them. Keep the following guidelines in mind as you 
adjust existing segments:

• If a control point connects two segments, moving that control point changes both 
segments.

• When drawing with the pen tool, you can temporarily activate the pen selection tool by 
holding down Ctrl (Windows) or Command (Mac OS) so that you can adjust segments 
you’ve already drawn.

• When you draw a smooth point with the pen tool, dragging the direction point 
changes the length of the direction line on both sides of the point. However, when you 
edit an existing smooth point with the pen selection tool, you change the length of the 
direction line only on the side you’re dragging.

To adjust a straight segment:

With the pen selection tool , drag the control point on either end of a segment. 

To adjust a curved segment: 

1 Using the pen selection tool , select the control point on either end of a curved 
segment. Direction lines appear on the control point.

2 Do one of the following:

• Drag the control point. 
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• Drag a direction point. If you’re adjusting a smooth point’s direction lines, both 
direction lines revolve around the control point. 

 To split the direction lines of a smooth point, position the pen selection tool over a 
direction line, then hold Alt/Option. The pointer changes to a hollow arrow point and 

you can move the direction lines separately. 
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Chapter 3: Creating Text Objects
iveMotion lets you add text to compositions with flexibility and precision. You can 
create and edit text directly on-screen and quickly change the font, style, size, and 
color of the text. 

Using text in compositions
LiveMotion offers two ways of adding text—by clicking once in the composition window 
and entering text (Point text), and by dragging in the composition window to create a 
bounding box into which you enter text (Paragraph text).

Adding point text
Point text will appear in a bounding box after it is entered. This bounding box is deter-
mined by the size of the text in it. Line breaks will be added only when you press Enter or 
Return. 

To enter point text:

1 Select the type tool .

2 Click in the composition to set an insertion point for the text. The small line through the 
I-beam marks the position of the text baseline. 

3 Enter your required text. Press Enter or Return to begin a new line.

Adding paragraph text
Paragraph text wraps automatically to fit in the bounding box. The size of the text object is 
determined by the bounding box. You can use paragraph text in your Web pages to add 
text in a specific, constrained area, for example, in a banner.

To enter paragraph text:

1 Select the type tool .

2 Drag in the composition to create a bounding box.

3 Enter text in the bounding box.

If the amount of text is too large to fit in the bounding box, a text overflow handle will 
appear in the lower right corner of the box. You can drag one of the handles of the 
bounding box to resize it so all the text is visible.

Once you have entered text, you can apply different format options. See “Formatting text” 
on page 32

Editing text in a composition
You can insert new text and change existing text using the type tool.

To edit text:

1 Select the type tool . 

L
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2 Click to select the text flow that you want to edit. 

3 Do one of the following:

• Select the characters you want to edit.

• Click in the text flow to add text.

Using text fields
You can use the text field tool  to create text fields for Flash output. When you add text 
field, the field is assigned a variable that you control through scripting. The text field 
options in the Properties palette determine the behavior of the text in the text field, as 
well as how the text field acts on export. Text entered in text fields is created and edited 
the same way as point and paragraph text. 

Adding text fields
Text fields are added by creating a bounding box with the text field tool.

To add a text field:

1 Select the text field tool .

2 Click and drag to create the bounding box of the text field.

3 Begin typing in the text field to add text.

Setting text field options
The Properties palette contains several options you can set to define the behavior of the 
text field. The following options are set in the Properties palette:

Allow Input Allows users to enter text in the text field in the exported SWF file.

Export Text Field as HTML Interprets text in a text field as HTML code.

Variable Contains the variable name for a text field. For more information, see the Adobe 
LiveMotion 2.0 Scripting Guide.

Read HTML <<ICON>> Select to hard-code HTML into a text field. Any text in the text 
field will be interpreted as HTML.

Limit <<ICON>> Enter a value to limit the number of characters a user can enter into a 
text field in an exported SWF file. 

Make Text Selectable Allows users to select the text in the text field in an exported SWF 
file.

The following options are set in the Properties palette menu. To turn the options on or off, 
select them in the Properties palette menu.

Show Border/Background Select to add a black border around a white text field.

Single Line Sets text field to a single-line field; text will not wrap in the field.

Multi-Line Sets text field to a multi-line field; text wraps to fit the text field.

Password Masks text characters with dots to keep passwords entered in Web pages 
secure.
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Formatting text
Adobe LiveMotion gives you precise control over text attributes, including font, text size, 
leading, tracking, alignment, and rotation. Selected attributes can be applied to the entire 
text object. 

To apply most text attribute changes to a text, you must first select the text. You can apply 
the following text attributes:

Font A font is a complete set of characters, letters, and symbols of a particular typeface 
design. In addition to choosing a font, you can choose a type style (for example, Regular, 
Bold, or Italic) if that style is included in the font family. The range of available type styles 
varies with each font.

Size The size determines how large the text appears in the image. The default text size is 
48 points, where one point is equal to 1/72 of an inch in a 72-ppi image.

Outlining Outlining lets you display text as an outlined, rather than filled, object. The 
Outline option works only with vector (TrueType® or PostScript®) fonts, not bitmap (screen) 
fonts. If you select a bitmap font, this option is disabled.

Leading Leading specifies the spacing between adjacent baselines and is measured as a 
percentage of the point size.

Tracking Tracking applies uniform spacing between characters in the text object.

Positive tracking values move characters apart; negative values move characters together. 
Tracking values are measured in units that are 1/100 of an em space. The width of an em 
space is equal to the width of the lowercase letter m in the current font and text size. 

20-point text set to default

20-point text with 200% leading and a tracking value of 40

Alignment Alignment controls the orientation of characters and lines of text. Horizontal 
orients characters next to each other, with each new line below the previous one.
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Baseline Shift Baseline Shift an either raise type (superscript) or lower type (subscript) 
from the baseline.

Kerning Kerning sets the space between specific letter pairs. You can adjust this to 
increase or reduce the space between selected letters.

Faux Bold Faux Bold creates a simulation of bold font styles when a chosen font does not 
have a bold style option. 

Faux Italic Faux Italic creates a simulation of italic font styles when a chosen font does 
not have a italic style option.

Anti-Alias Anti-aliasing produces smooth-edged text by partially filling the edge pixels.

Selecting text for formatting
Before you can format individual characters, you must select them. You can select one 
character, a range of characters, or all characters in a text layer. 

To select characters:

1 Select the type tool . 

2 Click in the text flow to select it.

3 Position the insertion point in the text, and drag to select one or more characters.

Applying text formatting
The formatting options help you customize text objects in your composition.

To set text attributes:

1 Select the text and choose Window > Properties to display the Properties palette.

2 Specify type attributes in Properties palette:

• For Font, choose a font family. Choose a type style from the menu to the right of the 
Font menu.

• For Size, enter a value for the font’s size.

• To create outlined type select Outline and enter a value in 1/4 pixel units for the stroke 
(outline) width.

• For Leading, enter a value. <<limits? Still TBD as of 8/31>>

• For Tracking, enter a value. <<limits? Still TBD as of 8/31>>

• Select a horizontal or vertical alignment option. The left or top alignment option begins 
each line of text at the left or top edge of the bounding box. The center alignment 
option centers the text in the bounding box. The right or bottom alignment option 
ends each line with the right or bottom edge of the bounding box.
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Choosing a font and font style
When you select a font, you select the font family and its type style independently. The font 
family is a collection of fonts sharing an overall typeface design; for example, Times. A type 
style is a variant version of an individual font in the font family, for example, Regular, Bold, 
or Italic. The range of available type styles varies with each font. If a font doesn’t include 
the style you want, you can apply faux (fake) versions of bold and italic.

Note: A faux font is a computer-generated version of a font that approximates an alter-
native typeface design, used only if no corresponding font for a given faux treatment is 
available.

To choose a font and style:

1 Select one or more characters whose font you want to change. 

2 In the Properties palette, choose a font from the font pop-up menu. 

3 Choose a font style from the Font Style pop-up menu.

If the font you chose does not include a bold of italic style, choose Faux Bold or Faux Italic, 
or both, from the Properties palette pop-up menu.

To choose a font size:

1 Select one or more characters whose size you want to change. 

2 In the Properties palette, enter or select a new value for Size.

The type size determines how large the text appears in the image. The default unit of 
measurement for text is points, which is approximately 1/72 of an inch in a 72-ppi image. 
The physical size of the font depends on the resolution of the image. 72-point text is 
approximately 1-inch high in an image that is 72 dpi.

The default text size is 48 points.

To adjust the font size by dragging:

1 <<You're going to need to put a note about how to adjust the size if you're animating 
the size changes--do it one way and it makes a huge file, another way and it makes a small 
file. cross ref to my section in exporting on optimizing. See page 148 of the manual for 
what I mean>>

2 Select the text in the Composition window.

3 Do either of the following:

• Drag any handle except the side handles and the top right handle to change the font 
size of the text.

• Shift-drag any of the corner handles except the top right one to constrain the text to 
the aspect ratio of the original font.

Changing the text color
The text you enter gets its color from the current foreground color; however, you can 
change the text color after you enter text using the Color palette.

To change the text color:

1 Select one or more characters whose color you want to change. 

2 Choose Window > Color to view the Color palette.
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3 Use the selection tool to click a color in the Color palette to select it.

The selected color is applied to the text.

Aligning text
You can align text to change its relationship to the initial cursor position (where you 
clicked when you first entered the text). Alignment affects all text in a text flow—you 
cannot align some characters, but not others.

To specify alignment:

1 Select the text flow.

2 In the Properties palette, choose an alignment option by clicking an alignment button.

Anti-aliased text
Text in Adobe LiveMotion is automatically anti-aliased. Anti-aliasing produces smooth-
edged text by partially filling the edge pixels. As a result, the edges of the text blend into 
the background. Anti-aliasing can make small text sizes appear more readable when 
viewed online.

When creating text for online use, consider using larger text than you would for 
printed works. Because the resolution of monitors is low, larger text can be easier to 

view online.

To turn anti-aliasing off:

Choose Anti-Aliasing from the Properties palette pop-up menu.

Converting text objects 
Adobe LiveMotion lets you create text objects and separate the individual characters into 
distinct text objects while retaining their alignment and kerning. You can then work with 
them like any other object, and animate them individually. The characters remain fully 
editable. 

At some point, you may want to convert a text object into a vector shape. When you 
convert text into a shape object, the text is no longer editable using the text tools.

To convert text objects into characters:

1 Create a multicharacter text object using the text tool . 

2 Select the text object.

3 Choose Object > Convert Into> Objects.

To convert text objects into shape objects:

1 Select the text object.

2 Choose Object > Convert Into > Path.
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Setting options for Chinese, Japanese, and Korean (CJK) 
fonts 
LiveMotion provides several options for working with Asian fonts, which are often referred 
to as double-byte fonts or CJK fonts. The Properties palette helps you use Asian font 
options.

Properties palette menu

Adjusting tsume
Tsume reduces the space around a character by a specified percentage value. The 
character itself is not stretched or squeezed, rather the space around the character is 
compressed. When tsume is added to a character, spacing around both sides of the 
character is reduced by an equal percentage.

To reduce spacing between characters:

1 Select the characters you want to adjust.

2 Enter or select a percentage for Tsume in the Properties palette, and click OK. 

The greater the percentage, the less space between characters. At 100% (the maximum 
value), there is no space between the character’s bounding box and its em box. (An em 
box is a space whose height and width roughly correspond to the width of the letter “M,” 
also called a mutton.)

Using tate-chuu-yoko
Tate-chuu-yoko (also called kumimoji or renmoji) is a block of horizontal text laid out within 
a vertical text line. Tate-chuu-yoko is useful for displaying non-Asian characters in the 
correct orientation in a text flow.

Apply tate-chuu-yoko to correct the orientation of non-Asian characters.

To turn tate-chuu-yoko on or off:

1 Select the characters that you want to rotate.
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2 Select Tate-Chuu-Yoko from the Properties palette menu.

Note: Using tate-chuu-yoko does not prevent you from editing and formatting text; you 
can edit and apply formatting options to rotated characters as you do to other characters.

Using mojikumi
Mojikumi determines spacing between punctuation, symbols, numbers, and other 
character classes in Japanese text. When mojikumi is off, full-width spacing is applied to 
these characters. When mojikumi is on, half-width spacing is applied to these characters.

Mojikumi on, and Mojikumi off

To turn mojikumi on or off:

1 Select the characters you want to work with.

2 Select a set from the Mojikumi menu in the Properties palette.

Using Kinsoku Shori
Kinsoku Shori determines line breaks in Japanese type. Characters that cannot begin a line 
or end a line are known as kinsoku characters. There are three different methods for 
keeping kinsoku characters from beginning or ending a line:

Oidashi Moves kinsoku characters down to the next line.

Oikomi Moves kinsoku characters up to the previous line.

Burasagari Allows single-byte periods, double-byte periods, single-byte commas, and 
double-byte commas to fall outside the paragraph bounding box to make room for 
adjustments made for kinsoku characters.

To turn Oidashi, Oikomi, or Burasagari on or off:

1 Select the characters you want to work with.

2 Select Oidashi, Oikomi, or Burasagari from the Properties palette menu.
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Chapter 4: Working with Objects
diting, arranging, and grouping objects is easy in Adobe LiveMotion. LiveMotion 
tools let you accurately measure, align, arrange, and move objects.

Editing objects
Before you can edit an object, you need to select it LiveMotion offers several selection 
tools:

• The selection tool  lets you select entire objects by clicking anywhere on the object. 

• The drag-selection tool  lets you drag to select and move objects that are hidden by 
other objects. You also use this tool to select objects that are in front of other objects 
you don’t want to select.

• The subgroup-selection tool  lets you select individual objects within a group, or sub-
groups of objects within a group. Each additional click selects the next lower subgroup 
or object in the grouping. (See “Grouping objects” on page 47.)

Selection handles appear on objects as they are selected. Once you have selected an 
object, you can select a specific layer of that object to modify. For information on selecting 
layers, see “Using the Object Layers palette” on page 69.

To select an object:

1 Choose the selection tool , drag-selection tool , or subgroup-selection tool .

2 Do one of the following:

• Click the object with the selection or group-selection tool.

• Drag a rectangle, called a marquee, around the entire bounding box of the object you 
want to select. 

To select multiple objects:

Do one of the following:

1 Choose the selection tool , subgroup-selection tool , or drag-selection tool .

2 Do one of the following:

• Click to select an object. Shift-click to select additional objects.

• Drag a marquee over the entire bounding box of an objec.t. Shift-drag to select 
additional objects.

To select all objects in a composition:

Choose Edit > Select All to select all objects.

To select an object or objects hidden behind another object:

1 Select the drag-selection tool .
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2 Drag a marquee over the entire bounding box of the object or objects you want to 
select.

Drag the drag-selection tool to select and move an object that is under another object.

To or deselect all objects in a composition:

To deselect all objects in a composition, do one of the following:

• Choose Edit > Deselect All.

• Click in any empty area of the composition.

Stacking objects
Adobe LiveMotion stacks objects, beginning with the first object created, opened, or 
imported. The stacking order (z-order) determines how objects are displayed when they 
overlap. 

Grouped objects inherit the stacking order of the foremost object in the group (see 
“Grouping objects” on page 47) You can change the stacking order of objects in your 
composition at any time.

To change the stacking order:

1 Select the object you want to move.

2 Do one of the following:

• To make an object the frontmost object, choose Object > Arrange > Bring to Front. 

• To make an object the backmost object, choose Object > Arrange > Send to Back. 

• To move an object one level to the front, choose Object > Arrange > Bring Forward.
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• To move an object one level to the back, choose Object > Arrange > Send Backward.

Selected object is at bottom of stack. Bring to Front command moves object to front of stack.

Note: If an object is obscured by the object above it, use the drag-selection tool . to 
select the hidden object.

Moving objects
You move objects by dragging them, using the arrow keys, or using the Transform palette. 
For information about the Transform palette, see “Transforming objects” on page 49.

To move an object by dragging:

1 Select the object. Shift-click to select additional objects.

2 Drag the object to its new location. Shift-drag to constrain the movement to multiples 
of 45 degrees.

To move an object using the arrow keys:

1 Select the object.

2 Press the arrow key for the direction in which you want to move the object. Press the 
Shift key to move the objects 10 pixels with each press of the arrow key.

To move an object using the Transform palette:

1 Choose Window > Transform.

2 Select the object in the composition.

3 Do any of the following in the Transform palette:

• To move the object horizontally (along the x axis), enter a value for x. A lower number 
moves the object to the left; a higher number moves it to the right; entering 0 places it 
against the left edge of the work area.

• To move the object vertically (along the y axis), enter a value for y. A lower number 
moves the object up; a higher number moves it down; entering 0 places it against the 
top edge of the work area.
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Duplicating objects
Duplicating an object in a composition creates an exact copy of the object.

To duplicate an object:

1 Select the object to be duplicated.

2 Do one of the following:

• Choose Edit > Duplicate to create a duplicate on top of the original, and move the new 
object as desired.

• Alt-drag (Windows) or Option-drag (Mac OS) the object to duplicate and place the new 
object in one step.

Creating object aliases
When you duplicate an object, you create a copy of the object and the copy becomes an 
independent object. Changing the original object has no effect on the copy. When you 
duplicate an object by creating an alias, however, any change to the original object is 
reflected in the copy also. When you make an alias to an object, both objects become 
aliases to each other. Duplicating objects by creating aliases is particularly useful. 

You can edit or modify an alias independently of the original by unlinking the alias from its 
parent. 

To create an alias of an object:

1 Select the object for which you want to create an alias.

2 Do one of the following:

• Choose Edit > Make Alias.

• Shift+Alt-drag (Windows) or Shift+Option-drag (Mac OS) the object.

Original with duplicate and after modifying original. When the original is modified, a duplicate 
object remains unchanged.

Original with alias and after modifying original. When the original is modified, the alias is modified 
automatically.
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To unlink an alias:

1 Select the alias you want to unlink.

2 Choose Edit > Break Alias.

Because an alias is a reference to the original object, using aliases can speed up 
redrawing of objects, minimize the file size of a composition, and save time when 

updating Web pages.

Cutting, copying, and pasting objects
The Cut command removes an object that can then be pasted elsewhere. The Delete 
command removes the object permanently. You can also use the Copy and Paste 
commands to copy and paste objects between Adobe applications.

For more information on alternative ways to copy, see “Copying and pasting images and 
other selections” on page 60.

To cut and paste an object:

1 Select the object you want to cut and paste.

2 Choose Edit > Cut.

3 Do one of the following:

• To paste a cut or copied object in the same composition or into another LiveMotion 
composition, choose Edit > Paste.

• To paste a bitmap image of a cut or copied object into another Adobe application, open 
the destination application and document. Then choose Edit > Paste.

For more information on exporting objects into other applications see “About exporting” 
on page 140. 

To copy an object:

1 Select the object you want to copy. Shift-click to select additional objects.

2 Choose Edit > Copy to copy of the object. 

Note: If no objects are selected, the entire composition is copied.

Copying and pasting object attributes
The Paste Special commands let you copy various attributes from one object to another. 

To copy and paste an object’s attributes:

1 Select and copy the object whose style or attributes you want to apply to another 
object.

2 Select the object or object layer to which you want to apply the style or attributes.

3 Choose one of the following from the Edit menu:
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Paste Style Applies the style of the copied or cut object to the selected object.

Style attributes of the first object copied and pasted to the second object.

Paste Object Animation Applies animation to the selected object.

Paste Scripts Pastes a script into the composition. See the Adobe LiveMotion 2.0 
Scripting Guide for information on scripts.

Paste Special> Paste Active Matte Applies the shape of the copied or cut object to the 
selected image object. 

Note: This command works only on image objects.

Before and after active matte pasted from first object

Paste Special > Paste Image Crops and scales the copied image or object to the selected 
object’s bounding box. If no object is selected, the image is pasted as a new object.

Before and after image pasted from first object

Paste Special > Paste Texture Applies the copied or cut object as a texture to the 
selected object. If no object is selected, the texture is applied to the background.

Before and after texture pasted from first object
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Paste Special > Layer Applies the attributes of the selected layer of the copied or cut 
object to the selected object.

Before and after layer attributes pasted from first object

Paste Special > Transformations Applies the rotation and skew of the copied or cut 
object to the selected object.

Before and after transformations pasted from first object

Paste Special > Fill Applies the fill color, image, texture, or background, as well as the 
gradient, and tint of the copied or cut layer to the selected layer.

Before and after fill color pasted from first object

Paste Special > Effects Applies the 3-D and Distort palette settings used with the copied 
or cut layer to the selected layer. 

Before and after effects pasted from first object
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Paste Special > Properties Applies the Properties palette settings of the copied or cut 
object to the selected object.

Before and after properties pasted from first object

Undoing and redoing changes
You use the Undo command to undo many types of editing commands in LiveMotion. If 
an operation cannot be undone, the Undo command is dimmed. In this case, you can use 
the File > Revert command to revert to the version that was last saved (but not if you 
closed and then reopened the file).

You can also use the History command to undo or redo a series of changes you’ve made to 
a composition. By selecting an action in the History menu, the composition will revert 
back to its previous state.

To undo or redo an operation:

Choose Edit > Undo, or Edit > Redo.

To undo or redo operations using the History command:

Choose Edit > History, and select the state you want to revert back to. 

Using rulers
LiveMotion displays one ruler along the top and one ruler along the left side of the 
composition window. You use these rulers to accurately place and measure objects in a 
composition. As you move around the composition, the rulers adjust accordingly. 

The point where 0 appears on each ruler is called the ruler origin. You can change the 
origin for the rulers at any time. When you change the ruler setting, the new setting 
becomes the default for the file whenever that file is opened. 

To show or hide rulers: 

Choose View > Show Rulers.

To snap the ruler origin to guidelines or gridlines:

1 Choose View > Show Guides or View > Show Grid.

2 Choose View > Snap to Guides or View > Snap to Grid.

To reset the ruler origin to its default value:

Double-click the origin box in the upper left corner of the window.
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Using guides and grids
When displayed, guides appear as lines that float over the entire composition in front of 
objects. You use guides to help in positioning objects in the composition; guides neither 
print nor export. You can move or delete a guide. You can also lock a guide to avoid 
accidentally moving it. 

Guides and grids behave similarly:

• Objects snap to a guide or the grid when dragged within 8 pixels. Guides also snap to 
the grid when moved. You can turn this feature on and off. 

• Guide spacing, guide, and grid visibility, and snapping behavior are specific to a file. 

• Grid spacing, guide, and grid color and style are the same for all files. 

To show or hide guides or the grid:

Choose View > Show Guides or Show Grid. 

To place a guide: 

With the rulers displayed, do one of the following:

• Drag from the horizontal ruler to create a horizontal guide.

• Drag from the vertical ruler to create a vertical guide.

To move a guide:

Select the guide, and drag the guide to its new position. 

To lock all guides:

Choose View > Lock Guides. 

To delete a guide from the composition: 

Select the guide while holding down Ctrl (Windows) or Command (Mac OS), and drag the 
guide out of the composition area and back to the ruler.

To clear all guides:

Select View > Clear Guides.

To turn snap to guide or snap to grid behavior on or off:

Choose View > Snap to Guides or Snap to Grid.

To set grid preferences:

1 Choose Edit > Preferences.

2 Set the gridline spacing and subdivisions using the Grid sliders or by entering values 
directly in the text boxes.

Aligning and distributing objects
The Align commands let you align selected objects along the axis you specify. The 
Distribute commands let you spread objects evenly along the horizontal axis or vertical 
axis.
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To align or distribute objects:

1 Select the objects to align or distribute.

2 Do one of the following:

• Choose Object > Align > Left, Right, Top, or Bottom to align the selected objects along 
the left, right, top, or bottom edge of the selected object. For example, the Align > Left 
command aligns all objects along the left edge of the far left selected object.

• Choose Object> Align > Horizontal or Vertical Centers to align centers of selected 
objects midway between the left edge of the left most object and the right edge of the 
right most object (Horizontal), or the top edge of the topmost object and the bottom 
edge of the bottommost object (Vertical).

• Align > Centers aligns the objects at the center of all selected objects. 

• Distribute > Horizontal or Vertical spreads selected objects evenly along the horizontal 
or vertical axis so their centers are equidistant.

Grouping objects
You can group any number of objects so that the objects are treated as a single unit. You 
can then move or transform the objects without affecting their positions relative to one 
another or their attributes. For example, you might group the objects in a navigator bar 
design so that you can move and scale the navigator bar as one unit.

Groups have these properties:

• Groups can be nested—that is, they can be grouped within other objects or groups to 
form larger groups.

• New groups are at the top of the stacking order.

To group or ungroup objects: 

1 Select the objects to be grouped or ungrouped. For information on how to select 
groups, see “Editing objects” on page 38.

2 Choose Object > Group or Object > Ungroup.

To select objects within a group:

1 Select the subgroup-selection tool , and click the subgroup, or object you want to 
select. 

2 Click the same place again to select successive subgroups until the subgroup or 
individual object you want is selected.

Selection handles appear on subgroups and objects as they are selected. A thick border 
appears around the group or subgroup to which the selected subgroup or object belongs.
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Maintaining grouped text formatting
The Maintain Alignment command maintains the alignment of text with other objects to 
which it is grouped. When the text is changed, or its size, tracking, font, or style is changed, 
the text is realigned within the group or the objects in the group are resized as needed. 
For example, you could group a text object with a button. As you add text, the size of the 
grouped button would automatically be increased as necessary to accommodate the text. 
If there are aliases of the button, the size of the aliases will be increased by the same 
amount.

To maintain the alignment of grouped text:

With the group selected, choose Object > Maintain Alignment.

Converting into objects, sequences, and paths
Placed files often contain layers, including Illustrator and Photoshop files. Using the 
Convert Into commands, you can convert the layers into native LiveMotion objects, or 
sequences. You can also convert Illustrator EPS and AI files, PDF objects, and native and 
non-native text objects into paths.

To convert into an object, sequence, or path:

1 Select the component you want to work with.

2 Choose one of the following from the Edit > Convert Into menu:

Object Converts each individual layer of a placed file into a separate object. You can 
perform this operation more than once if each layer in the placed file has a sub-layer 
included in it. This command will also convert each character of a LiveMotion text object 
into separate objects.

Group of Objects Converts each individual layer, then groups the objects.

Sequence Converts each object of a layered file into one frame in an animated sequence.

Sequence with Background Converts a layered file into individual frames, but keeps the 
existing background in each frame.

Path Converts text objects into paths. Once the text objects have been converted, you 
can no longer edit them using the text tools. This command will convert imported text 
objects into paths as well as native LiveMotion text objects. Converted placed vector files 
(Illustrator EPS, and PDF) will no longer be editable using the Edit Original command.
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Chapter 5: Transforming and 
Combining Objects

ou can easily modify an object’s size, orientation, or shape using Adobe LiveMotion 
tools and commands. With the Combine commands, you can combine multiple 
objects to create a single complex object.

Transforming objects
You can transform objects by selecting one or more objects and then applying various 
transformations to them. Objects are transformed around an anchor point. Using the 
transform tool or the selection tool will change the position or placement of an object. 
Using the Shape Transform command will change the shape of the object.

There are several ways to transform objects:

• With the selection tools, you can move, rotate, skew, and resize objects by dragging. 

• With the Transform palette, you can move, rotate, and resize objects precisely by 
entering numerical values for the x,y coordinates.

• With the Flip Horizontal and Flip Vertical commands, you can flip objects to their mirror 
images.

• With the transform tool , you can view the transformations you make to your object 
as you make them. The transform tool also lets you change the control points of 
objects.

Defining an object’s anchor point
All transformation actions are performed in relation to a fixed point, called an anchor 
point, on or around the object. The default anchor point is the object’s center point. You 
can set a new anchor point, and you can also drag an existing anchor point to a new 
position. Anchor points will automatically snap to the center of bounding box, though you 
can temporarily disable snapping.

To change an object’s anchor point:

1 Select the object.

2 Do one of the following:

• Select the transform tool, then drag the anchor point. 

• Drag the anchor point near a handle of a bounding box to snap the anchor point to the 
center of the bounding box.

• Press Ctrl (Windows) or Command (Mac OS) and select the anchor point. Drag the 
anchor point.

To reset the anchor point:

Choose Object > Transform > Reset Anchor Point.
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To temporarily disable anchor point snapping:

Press Option key while dragging the anchor point.

Rotating objects
Rotating an object turns it around its anchor point. When you add effects to an object 
before rotating it, the effects are also rotated. For example, if you rotate an object with a 
shadow, the shadow rotates with the object. You can keep the orientation of offset layers if 
you use the Shape Rotate command.

To rotate an object using the transform tool or the selection tool:

1 Select the transform tool  or the selection tool .

2 Select the object you want to rotate.

3 Move the pointer over a handle of the object’s bounding box until the pointer changes 
to a circle .

4 Drag a handle of the bounding box until the selection is at the desired angle of rotation. 
If you are using the transform tool, Shift-drag a handle to rotate in 15 degree increments.

Dragging with transform tool

To rotate an object using the Shape Transform command:

1 Select the object you want to rotate.

2 Choose Object > Transform > Shape Transform.

3 Move the pointer over a handle of the object’s bounding box. The pointer changes to a 
circle .

4 Drag a handle of the bounding box until the selection is at the desired angle of rotation. 
Shift-drag a handle to rotate in 15 degree increments.

To rotate an object using the Transform palette:

1 Select the object you want to rotate.

2 Choose Window > Transform.

3 Do one of the following:

• Drag the dial in the circle.
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• Enter the angle you want to rotate the object. To rotate an object more than 360 
degrees for an animation, enter a positive number greater than 360. 

Transform palette
A. Location on the x axis B. Location on the y axis C. Angle of rotation D. Width
E. Height F. Number of pixels by which the object is skewed along the x axis
G. Number of pixels by which the object is skewed along the y axis

To flip an object:

1 Select the object you want to flip.

2 Do one of the following:

• Choose Object > Transform > Flip Horizontal to flip the object left to right.

• Choose Object > Transform > Flip Vertical to flip the object top to bottom.

Resizing objects
You can resize—that is, enlarge or reduce—an object relative to its anchor point.

To resize an object using the bounding box:

1 With the selection tool, select the object or objects to scale.

2 Drag a handle of the bounding box until the selection is the desired size. Shift-drag the 
handle to preserve the proportion of the object.

To resize an object using the Transform palette:

1 Select the object you want to scale.

2 Choose Window > Transform.

3 Do one of the following:

• Enter a value in the width text box  and press Enter or Return.

• Enter a value in the height text box , and press Enter or Return.

Skewing objects
Skewing slants an object along the axis you specify. An object cannot be skewed vertically 
and horizontally at the same time.

To skew with the transform tool:

1 Select the transform tool .

2 Select the object you want to skew.

3 Position the pointer over one of side handles of the bounding box. The pointer changes 
to a skewed rectangle .

4 Drag the handle to skew the object.

A
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To skew an object using the Transform palette:

1 Select the object you want to rotate.

2 Choose Window > Transform.

3 Do one of the following:

• To skew the object horizontally, enter a value between -75 and 75 degrees in the 
horizontal Skew text box . Entering a positive angle skews the top of the object to the 
right and the bottom to the left; entering a negative angle skews the bottom to the 
right and the top to the left.

• To skew the object vertically, enter a value between -75 and 75 degrees in the vertical 
Skew text box . Entering a positive angle skews the right side of the object up and the 
left side down; entering a negative angle skews the left side up and the right side 
down.

Undoing transformations
When LiveMotion transforms images, it keeps a copy of the original image in the file, along 
with any changes applied to it. This means you can restore an image to its original look, 
even after saving changes. 

To undo all transformations applied to an object:

With the object selected, choose Object > Transform > Clear Transformations to undo all 
transformation applied since the last Save.

Modifying the properties of geometric shapes
The Properties palette lets you modify objects created with the rectangle, rounded-
rectangle, ellipse, and polygon tools, even if they have a style applied to them. For 
example, you can convert an ellipse to a polygon, specify the number of sides, and choose 
whether to make it a solid shape or have an open center.

To modify the properties of a geometrically shaped object:

1 Select the object.

2 Choose Window > Properties.

3 Select a shape: rectangle, rounded rectangle, ellipse, polygon:

• For Rounded Rectangle, enter a value between 0 and 200 to specify the corners’ radius 
in 1/4-pixel units. (The corner radius value represents the radius of a hypothetical circle 
drawn in the corner of the rectangle or square. A corner radius of zero creates square 
corners.)

• For Polygon, enter a value between 3 and 10 to specify the number of sides to the 
polygon.

• Choose whether the shape is solid or an outline. If you choose Outline to hollow out the 
object’s shape, enter a value between 1 and 200 to specify the outline’s width in 1/4 
pixels. The higher the value entered, the wider the line will appear.

Note: Although a computer monitor does not display objects in 1/4-pixel resolution, this 
pixel value helps determine how anti-aliasing is applied to the object, to give the 
appearance of finer or heavier lines.



Using Help | Contents | Index Back 53  

Help Transforming and Combining Objects 

Using Help | Contents | Index Back 53  

Cropping objects
Cropping is the process of selecting and reducing the visible portion of an object using 
the crop tool . The crop tool also lets you move a bitmap image within a matte.

An object that has been cropped can be uncropped at any time, even after the file has 
been closed and reopened, by using the crop tool to extend the visible area back to its 
original boundaries.

Note: Any object that has been cropped with the Crop tool will become a bitmap when 
exported to the SWF file format. To maintain objects as vector, use a matte instead of the 
crop tool to reduce the visible area of the object.

To crop an object and move an image within a matte using the crop tool:

1 Select the object you want to crop. 

2 Select the crop tool .

3 Position the pointer over one of the handles on the selected object. The pointer 
changes to a set of direction arrows. Do one of the following:

• Drag to resize the visible part of the object.

Dragging crop tool over selected object and result

• Use the hand tool  to move the visible part of the image within the crop area. 

Applying mattes
A matte is a transparent shape that defines the visible area of an a separate image. Any 
part of the image that is within the matte’s area is visible; any part that is outside the matte 
is invisible. A matte that is currently applied to an image object is called the active matte. 
You can use the Properties palette to apply a matte to an imported image object, cropping 
the image object to the shape of the matte. 

To crop an image object using a matte:

1 Select the image object.

2 Choose Window > Properties.

3 Select Active Matte to use a shape to mask the image. 
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You can add an active matte by using the Matte option in the Library palette or by 
dragging a shape from the Library palette or an EPS file from a folder onto the Active 
Matte display in the Properties palette. The active matte’s shape is scaled to the size of the 
image. 

Image object, matte, and matte applied to image object

Note: If the image has a native alpha channel, the alpha channel and the active matte are 
combined to create a matte.

Using alpha channels
Depending on the format and how the image was created, an image may contain an alpha 
channel. An alpha channel is a grayscale image that is added to the color channels (such as 
the red, green, and blue channels in an RGB image) that make up the image.

You can use an alpha channel to create and store a matte. As with a matte, an alpha 
channel enables you to define a shape for the image object. For example, an image of a 
flower displayed without an alpha channel might be shown in a white rectangle, which 
would show up against a colored background. By using an alpha channel in the shape of 
that flower, only the flower is visible.

Original image with alpha channel (left) and without (right). 

To use alpha channels:

1 Select the image object.

2 Choose Window > Properties.

3 Select one of the following:

• No Alpha if you want the image to retain its original shape out to the edges of the 
selection border. If the image is not rectangular, the remaining area out to the edges of 
the selection border is filled with white.

• Use Alpha Channel to use the image’s alpha channel as a matte, if the image was 
imported with one.

• Build Alpha From Image to create an alpha channel using the luminosity of the color in 
the image. With color images, the effect is equivalent to converting the color to 
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grayscale, and using the grayscale as the alpha channel. However, this option is most 
useful for removing the white background from simple, black-and-white line drawings 
and for using a grayscale drawing as a shape.

Making group masks
A group mask creates a mask shape from the top object of a group. Any area of the other 
grouped objects that is covered by the top object becomes visible when the mask is 
applied; all other areas of the group become invisible. You can use this effect in anima-
tions, for example, to make it look as though objects are moving under or behind the 
background. 

To create a group mask:

1 Select the objects you want to group. Make sure that the object that you want to use as 
a mask is at the top of the group’s stacking order.

2 Choose Object > Group.

3 Choose Object > Top Object Is Mask.

Grouped objects, and with the top object as the group mask

Combining objects
A combined object consists of two or more overlapping objects merged into a single 
image object. The Combine commands enables you to create objects that have trans-
parent interior spaces where the original objects overlapped (for example, a window 
frame or a donut shape). This method lets you create objects more complex than you 
could easily create using the drawing tools.

A combined object has these properties:

• The objects created by the Unite, Minus Front, Intersect, and Exclude commands have 
the same style attributes as the bottommost object being combined.

• If a text object is part of the combined object, the text can still be edited. If more than 
one text object is part of the combined object, only the topmost text object can be 
edited.

• You can uncombine objects in a LiveMotion file at any time, even after the file has been 
closed and reopened. The separate objects retain their separate style attributes.

To create a combined object:

1 Make sure the objects you want to see through are in front of the background object in 
the stacking order. 

2 Select all of the objects you want to include in the combined object.
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3 Choose Object > Combine.

4 Choose one of the following Combine commands:

Unite Creates a single image object from two or more objects, retaining the style of the 
backmost object. It traces the outline of all selected objects as if they were a single, 
merged object.

Unite with Color Creates a single image object from two or more objects, retaining the 
styles of the separate objects. It traces the outline of all selected objects as if they were a 
single, merged object.

Minus Front Creates a single image object by subtracting the front most objects from 
the backmost object. You can use this command to delete areas of the objects by 
adjusting the stacking order.

Intersect Creates a single image object from the common area shared by the selected 
objects. It traces the outline of all overlapping shapes in the selected objects, ignoring any 
nonoverlapping areas.

Exclude Creates a single image object by knocking out the area where one shape 
overlaps another. It traces all nonoverlapping areas of the selected objects, making 
overlapping areas transparent. In the areas where an even number of objects overlap, the 
overlap is made transparent; anywhere an odd number of objects overlap, the overlap is 
filled.

Combine options
A. Original B. Unite C. Unite with Color D. Minus Front E. Intersect F. Exclude

To uncombine a combined object:

1 Select the combined object.

2 Choose Object > Uncombine.

A B

C D

E F
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Chapter 6: Placing Images and 
Other Objects

 can easily place artwork created in an image-editing or illustration application, 
such as Adobe Photoshop or Adobe Illustrator, into Adobe LiveMotion. Once 
placed in a composition, you can modify placed artwork just as you would objects 

created in Adobe LiveMotion. 

You can place images created in other applications in various ways: 

• The Place command lets you place images into an existing composition. 

• The Replace command lets you replace a previously placed graphic with a new graphic.

• The Paste command lets you transfer artwork to a composition using the Clipboard. 

• The drag-and-drop feature lets you drag images from your desktop or other open 
Adobe applications into Adobe LiveMotion. You can drag and drop any file that can be 
placed with the Place command or pasted with the Paste command.

About placing images
Note the following when placing images: 

• LiveMotion keeps placed images in their native format (or an equivalent lossless repre-
sentation) in the LiveMotion file.

• Vector graphics remain vectors and can be scaled without losing quality.

• LiveMotion can place images in Encapsulated PostScript (EPS) format (up to Language 
Level 3), PDF format, and Adobe Illustrator (version 7 through 10). 

• To place an Illustrator 9 or Illustrator 10 file, it must be saved using the “Preserve PDF 
Data” option.

• Some vector graphics, such as gradient meshes, gradients with more than 8 colors, and 
live effects including drop shadows, can’t be represented by native Flash objects, and 
so will export to SWF as bitmap images. (See “Optimizing your compositions” on 
page 143.)

• Bitmap images are converted to pixel-based image objects. 

• Bitmap images in GIF, JPEG, PNG, BMP and DIB (Windows), PICT (Mac OS), and 
Photoshop formats can be placed.

• Compressed bitmap image files retain their compression—thus reducing file and 
memory size. 

• Uncompressed formats give you the best output. This is true regardless of the export 
format. The higher the quality of the source image, the better the quality of the 
exported image. 

• There is no limit on the resolution images placed in LiveMotion. However, you should 
be aware of the size, in pixels, of the images you place into LiveMotion. While it is 
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important to place high quality images into LiveMotion, placing excessively large 
image files will degrade LiveMotion’s performance.

• If you are using a file as a source for a LiveMotion composition, save that file with 
compatibility in mind. EPS and PDF files should have any fonts and images embedded 
in the file, and files in other formats should have similar compatibility or exchange 
settings turned on. 

• When you place an EPS file that contains fonts not installed on your system, Adobe 
LiveMotion substitutes fonts on your system for the missing fonts. 

• If the dimensions of a placed image are larger than the LiveMotion composition, the 
image is scaled to fit. You can change the image to its native size with the Clear Trans-
formations command. However, this increases the size of the exported file.

Opening LiveMotion 1.0 Files
You can open Adobe LiveMotion 1.0 files. However, if the LiveMotion 1.0 files contain 
image objects that have Photoshop filters applied, the filters’ effect will be removed. You 
can use the Edit Original command in LiveMotion to edit the original image in Photoshop 
and apply the filters you want there. for more information, see “Using plug-ins to place 
artwork” on page 60. Additionally, Adobe Illustrator 9 and later can apply non-
destructive filter-like effects that LiveMotion can place and export to the SWF file format. 
As with Photoshop, you can re-edit the Illustrator effects by using the Edit Original 
command.

Placing image files
The Place command places files created with other applications as new image objects in 
an Adobe LiveMotion composition You can also use it to place other LiveMotion composi-
tions.

You can place both vector and bitmap graphics files in an Adobe LiveMotion composition, 
including EPS, GIF, JPEG, PNG, BMP (Windows), PICT (Mac OS) files, PDF, and Photoshop 2.5 
or later (RGB, grayscale, and CMYK). Third-party plug-ins may support other formats as 
well.

Note: To place an image as a texture, see “Applying textures to layers” on page 74.

To place files created in other applications:

1 Choose File > Place.

2 Select the file you want to place. 

Note: Only files saved in file formats supported by Adobe LiveMotion will be displayed in 
the Place dialog box.

3 Click Open to add the file to the active Adobe LiveMotion window as a new image 
object.
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Placing image files as an animated sequence
The Place Sequence command lets you place a numbered set of image files as an 
animated series. The following rules apply:

• When LiveMotion places a sequence, each image file is converted into one frame of an 
animation. 

• Frames are placed sequentially, with the image file numbered first in the set as the first 
frame in the animated sequence.

• In the Timeline window, each new image in the sequence is represented by a separate 
Replace Object property keyframe.

• An initial Shape Resize property keyframe is added, with additional keyframes each 
time a different-sized image appears in the sequence. 

• Frames are interpolated between the keyframes. 

• The length of the animation is the total of the number of frames divided by the frame 
rate specified in the Composition Settings dialog box. For example, if you specify a 
frame rate of 30 frames per second and place a file with 30 frames, the animation will be 
one second long. 

To place files as a sequence:

1 Prepare a folder containing the numbered image files. The files should match these 
conditions:

• All files must be in the same folder.

• Filenames must contain sequential numbers as part of their name (such as “Bird1.jpg,” 
“Bird2.jpg,” … “Bird37.jpg”). 

• The numbers can appear anywhere in the file as long as it's in a consistent location. 

• The rest of the name must be identical in the named sequence. 

• The numbers need not be contiguous—that is, you can skip numbers. 

• Do not use decimals in the numbers.

2 Move the current-time indicator to the frame you want to begin the sequence with.

3 Choose File > Place Sequence. 

4 Select one file from the sequence you are placing. This file doesn’t need to be the first 
file of the sequence—LiveMotion automatically looks for the first file and places that as 
the first file in the animation sequence.

5 Click Open. 

To change the length of the animation after placing a file sequence:

Alt-drag (Windows) or Option-drag (Mac OS) the end point of the duration bar to the 
desired length. The frames will be reinterpolated to match the new animation length. 

To display a single image in the sequence:

Move the current-time indicator to the frame for that image.
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Replacing objects
The Replace command places a file from another application within the bounding box of a 
selected object, and maintains the style and transformation information of the original 
object.

For example, you could animate an image, then use the Replace command to swap the 
original image with other images over time. This would crete a series of images that 
retained all of the transformations and multilayer effects you applied to the original image

To replace an object with a placed file:

1 Select the object or objects you want to replace. 

2 Choose File > Replace.

3 Locate and select the file you want to use to replace the selected object.

4 Click Open.

Adobe LiveMotion scales the replacement image to match the selected object as closely 
as possible, crops the object along the shortest dimension if needed, and then reapplies 
any transformations or effects you previously applied to the image. 

Using plug-ins to place artwork
Plug-ins are software programs developed by Adobe Systems, and by other software 
developers in conjunction with Adobe Systems, to expand the placing capabilities of 
Adobe LiveMotion. 

Plug-ins for opening and placing multiple file formats come with your program and are 
automatically installed in the Plug-ins folder. In addition, LiveMotion can use plug-in 
modules created by third-party sources. Once installed, plug-in modules appear as file 
formats in the Place dialog box. 

To install a third party plug-in:

1 Do one of the following:

• Follow the installation instructions that came with the third-party plug-in.

• If an installer is provided, use it to install the plug-in. 

• Drag a copy of the plug-in to the Plug-ins folder inside the Adobe LiveMotion folder.

2 Restart LiveMotion.

Copying and pasting images and other selections
You can use the  Cut, Copy, and Paste commands to do the following:

• Copy objects within Adobe LiveMotion. You can paste the copies as new objects, 
replace existing objects with the copied objects, or apply certain aspects of the copied 
objects to existing objects.

• Copy objects between Adobe LiveMotion and other applications.
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• Copy images and text into Adobe LiveMotion—including EPS, DIB (Windows), PICT 
(Mac OS), and ASCII and RTF file formats.

Note: When copying and pasting styled text from RTF format, some formatting character-
istics may be lost.

The cut or copied selection remains on the Clipboard until you cut or copy another 
selection.

To copy and paste selections:

1 Select what you want to copy.

2 Choose Edit > Copy or Edit > Cut.

3 Select the application or composition into which you want to paste the selection.

4 Choose Edit > Paste.

Dragging and dropping to copy between applications
The drag-and-drop feature lets you move selections from another application into Adobe 
LiveMotion, or from LiveMotion to other applications such as Adobe Photoshop and 
Adobe Illustrator, to bitmap graphics applications, and to word-processing applications.

You can drag and drop into LiveMotion any image file that can be placed. Depending on 
where you drop the image, LiveMotion does the following: 

• Dropping an image onto a LiveMotion object replaces the object with the image.

• Dropping an image onto the Composition window creates a new image object. 

• Dropping an image onto an object layer fills that layer with a texture based on the 
image. See “Applying textures to layers” on page 74.

• In Windows 2000/NT, dropping an image into the gray application window area places 
the image in a new composition.

• Dropping text from another application onto the LiveMotion composition creates a 
new text object.

• Dropping a LiveMotion file into a Composition window adds the entire contents, as a 
group, to the composition. See “Grouping objects” on page 47.

• Dragging an object from one LiveMotion composition to another creates a copy of the 
selection in the new composition.

To drag and drop artwork from LiveMotion to the desktop:

1 Select the artwork you want to copy.

2 Drag the selection onto the desktop. 

In Windows, the selection is copied to the desktop as a Scrap file (Metafile). In Mac OS, the 
selection is copied as a picture clipping (PICT). Later you can drag and drop these files into 
another file.

To drag and drop LiveMotion artwork into a Photoshop or image editor window:

1 Select the artwork you want to copy.

2 Open the Photoshop image into which you want to copy the selection.

3 Drag the selection to the Photoshop image and release the mouse button. 
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Copying and pasting keyframes between AfterEffects and 
LiveMotion
The Copy and Paste commands let you copy one or more keyframes from Adobe After 
Effects and apply them to an object in a LiveMotion composition (and vice versa). Note 
that keyframes created in After Effects may contain functions not supported by 
LiveMotion. 

To copy and paste frames between After Effects and LiveMotion:

1 Select the keyframes (not the objects) that you want to copy.

2 Choose Edit > Copy.

3 Select the object in the Timeline window to which you want to apply the keyframes.

4 Choose Edit > Paste.

Placing layered objects
When you place an Illustrator EPS file, PDF file, or Photoshop file that has multiple layers 
into LiveMotion, it is placed into your composition as a single, one-layered object. You can 
then animate it and apply effects as you would any object created in LiveMotion, 
including adding new object layers.

Keep the following in mind when placing layered objects:

• Illustrator and Photoshop layered objects can also be converted so that they retain their 
original layers.

• Layer effects and masks are supported. 

• Vector objects and text export to SWF as vectors and native text. 

• Adjustment layers and blending modes other than alpha are preserved when placed in 
layer sets which are not themselves converted to objects (that is, these layers and 
modes will affect other objects in those layer sets as long as they function as a single 
unit in LiveMotion). 

• Effects and transparency in Illustrator layers is preserved.

• You can make layers into individual objects, a group of objects, or a sequence. 

• Layers can be edited in Illustrator or Photoshop after conversion. 

• Adobe LiveMotion can convert layers into a sequence of animation frames that can be 
viewed and displayed in the same way as separate files that have been placed in a 
sequence. For more information on placing animation sequences, see “Placing image 
files” on page 58.

• When using third-party plug-ins to place layered objects, see the plug-in manufac-
turer’s documentation for any restrictions in how the object is placed.

• If you want to display a different layer of a converted, multi-layered object, you can use 
the Index option in the Properties palette. See “Editing converted placed objects” on 
page 64.

To convert a placed, layered object in LiveMotion:

1 Place a layered object. 
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2 With the object selected, do one of the following:

• Choose Object > Convert Into > Objects to convert the layers into individual objects. If 
the layers contained sublayers or multiple objects, each of those can be converted into 
individual objects as well.

• Choose Object > Convert Into > Group of Objects to convert the layers into a group of 
objects.

• Choose Object > Convert Into > Sequence to convert the layers into frames in an 
animation. 

• Choose Object > Convert Into > Sequence With Background to convert the layers into 
frames in an animation with their background intact. The layers will be converted to an 
animation as described earlier, but the first layer will be visible throughout the 
animation sequence. 

If the individual objects in turn consist of sub-objects, you can apply the Convert Into 
commands to those as well. For example, an Adobe Illustrator file might consist of three 
layers. The Convert Into > Objects command would convert it into three objects. However, 
each of those could in turn may be made out of several sub-objects. You can apply the 
Convert Into commands until objects contain no sub-objects.

Opening After Effects/AMX format files
You can open files saved in Adobe Motion eXchange (AMX) format. This enables you to 
bring files created in After Effects 5.5 or later into LiveMotion.

To open an After Effects/AMX file in LiveMotion:

1 Export the file in Adobe Motion eXchange (AMX) format. (Read the After Effects or 
other manufacturer’s documentation for options when saving files in this format.)

2 In LiveMotion, choose Open, select the AMX file, and click Open.

Editing placed objects
Objects placed from Adobe Illustrator and Adobe Photoshop can be edited in those 
programs while remaining in their LiveMotion composition. (In fact, you can use Illustrator 
to edit any vector object and Photoshop to edit any bitmap object.) You can take 
advantage of the full range of Illustrator’s and Photoshop’s editing features, while leaving 
your LiveMotion composition intact. You do not need to re-place objects that you edit in 
their original applications. The changes you make are applied to LiveMotion’s copy of the 
object, not to the source file itself. 

Note the following when editing placed images:

• Using the Edit Original command on bitmap images in formats such as non-animated 
GIF, JPEG, PNG, PICT, and BMP (Windows) opens Photoshop.

• If you’ve converted a layered file to objects, don’t change the number of layers or their 
stacking order, since this could cause problems when the file is updated in LiveMotion.

• You can also edit placed or pasted vector artwork by using the Edit > Convert Into > 
Path command. However, once converted to a path, you cannot edit the artwork with 
the Edit Original command. For more information, see “Converting text objects” on 
page 35 and “Converting into objects, sequences, and paths” on page 48.
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• When using complex Illustrator artwork, it may be necessary to reduce the object to 
shapes several times first.

To edit placed objects:

1 Select the object.

2 Choose Edit > Edit Original.

3 Edit the object in Illustrator or Photoshop as needed.

The copy of the object is updated automatically in your LiveMotion composition.

Editing converted placed objects
The Index option in the Properties palette lets you specify which layer to show of a 
converted, placed, layered object. This is useful, for example, if using the Edit Original 
command changes the order of layers in a multilayer object.

To specify the top layer of a converted layered file:

1 Select the multi-layered object.

2 Choose Window > Properties.

3 Enter a number in the Index option to move that layer to the top. Entering a 0 displays 
all of the layers, other numbers display just that layer.

Moving objects and layers in a converted placed file up or 
down a level
The Parent button and Child button in the Properties palette lets you change the relation 
of objects and sublayers to layers. For example, suppose an Adobe Illustrator file has three 
layers that each contain several objects. You could select and move any layer or object up 
a level (with the Parent button) or down a level (with the Child button) in the layer 
hierarchy.

To move an object or layer in a converted layered file up or down a level:

1 Select the object or layer whose level you want to change in the converted, multi-
layered object.

2 Choose Window > Properties.

3 In the Properties palette, choose whether to move up or down a level:

• Click the Parent button  to move the object or layer up a level.

4 Click the Child button  to move the object or layer down a level.

Managing files with WebDAV
LiveMotion supports the Web Distributed Authoring and Versioning (WebDAV) server 
technology. Using this technology, you can connect to a WebDAV server, download and 
upload (save) files, lock files so others cannot work on them at the same time as you, and 
add (save) additional files (called assets) to the server. Use a WebDAV server to work in a 
collaborative environment without fear that files will be accidentally overwritten or 
updates lost.
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About workgroup management
When working in a collaborative environment, users must share files. The process of 
passing files from one collaborator to another involves working with a workgroup. 
Controlling the hand-off—so that only one person can edit a file at any given time—is 
called workgroup management. 

A WebDAV server provides workgroup management via the Web. When a file is managed 
by a WebDAV server, multiple users can download copies of the file, but only one user at a 
time can check out the file. The user who checks out the file can share his or her work with 
other users by updating the file on the server; however, other users can’t make changes to 
the managed file until it is checked in. This check out/check in system allows multiple 
users to access the same file but prevents users from overwriting each other’s work. 

Getting started with workgroup management
To use the workgroup management features in Livemotion, you must be able to connect 
to a WebDAV server. You can find detailed information and the latest news about WebDAV 
at www.webdav.org.

Important: Firewall software can interfere with the process of connecting to a WebDAV 
server. Check with your system administrator or refer to your firewall software documen-
tation for information about setting options to access outside servers.

Different WebDAV servers have different authentication requirements. Some servers 
require you to enter a user name and password for every transaction; other servers require 
authentication only the first time you check out a managed file. When the Authentication 
dialog box appears, enter your user name and password, and click OK.

When adding a new server to the workgroup, you will need to provide a unique server 
nickname (this will appear in the Manage Servers list) and a URL for the server.

To set up a server for use with Livemotion:

1 Choose File > Workflow > Manage Servers.

2 Specify a folder in which you want to store local copies of managed files. To change the 
default location, click Choose, and specify a different folder.

Note: The path you choose here is used for all servers you want to add. Changing this path 
does not change the location of files on existing servers. 

3 Specify the WebDAV servers you want to use, or do one of the following:

• To add a new server to the list, click New Server, specify a server nickname and URL, and 
click OK.

• To remove a server from the list, click Remove, and then click OK to the warning 
message.

4 Click OK, or click Advanced Options to specify additional information about the server.

5 In the Advanced Options dialog box, select Use a Custom Workgroup Files Location for 
This Server to set up a custom workgroup file repository for this collection of files; then 
click Choose or Select and specify a folder.

Note: This option is only available for adding a new server, not for existing servers. 

6 To specify additional URLs by which you can access this server, type the alternate URL 
under Alternate Server URLs for This Server, and click Add. Currently, Livemotion stores the 
URL information, but does not use it to locate files.
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7 To remove previously entered alternate URLs, select the URL and click Remove.

8 Click OK.

Opening managed files
To view a managed file, open a copy of the file from a WebDAV server. The File > 
Workflow > Open command creates a local copy of the file on your hard drive.

After you have a local copy of a file, you can update it with changes from the managed file 
on the server by using the Revert command (for checked out files or the Update command 
(for non-checked out files).

To open a managed file:

1 Choose File > Workflow > Open.

2 Select a server, a directory, and the file you want to open.

3 Do one of the following:

• Click Check Out if you want to open and check out at the same time. (See “Checking 
files out and in” on page 66.)

• Click Open if you want to open a local copy without checking it out.

To update or revert a local file to the version on the server:

1 Open your local copy of the file.

2 Do one of the following:

• If the file is checked out, choose File > Workflow > Revert. 

• If the file is not checked out, choose File > Workflow > Update.

Checking files out and in
Checking out a file prevents other users from making changes to it on the WebDAV server. 
When you’re finished making edits, check in the file to update your changes to the server 
and release your lock on the managed file. 

You can save changes to managed files that you have checked out. To save changes to 
managed files that you have not checked out, use the Save As command and add that 
new file to the workgroup server.

To check out a file:

Do one of the following:

• To check out the file that you already have open, choose File > Workflow > Check Out.

• To open and check out a file at the same time, choose File > Workflow > Open. Then, 
locate and select the file and click Check Out. (See “Opening managed files” on 
page 66.)

To check in a file:

Do one of the following:

• To check in the file and update changes to the server, choose File > Workflow > Check 
In.

• To check in the file without updating changes to the server, choose File > Workflow > 
Cancel Check Out.
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Placing managed files
Use the File > Workflow > Place, Place Sequence, Place as Texture, and Replace commands 
to place or replace a single, managed file as a link in a checked out managed file. You can 
place/replace documents from the current workgroup server only. 

To place a managed file:

1 Make sure you are connected to the network and have access to the managed server.

2 Open the checked out version of a managed file. 

3 Choose one of the following:

• File > Workflow > Place to place the document.

• File > Workflow > Place Sequence to place a sequentially numbered set of image files as 
an animated series of frames. (See “Placing image files as an animated sequence” on 
page 59.)

• File > Workflow > Place as Texture to place a texture to the selected layer. If no object is 
selected, the texture is applied to the background. (See “Applying textures to layers” on 
page 74.)

• File > Workflow > Replace to place a file from another application within the bounding 
box of a selected object, and maintains the style and transformation information of the 
original object. (See “Replacing objects” on page 60.)

4 Select a file and click Open. 

Adding files to the server
Adding a file to a WebDAV server initiates workgroup management for the file; in other 
words, you create a managed file by adding it to a server. You can add files to a server 
using the File > Workflow > Save or Save As commands. The Save command adds to the 
server a managed file that has been altered; the Save As command adds a previously 
unmanaged file to the server. 

To add a file to a WebDAV server:

1 Open the file you want to add to the server.

2 Do one of the following:

• To add a managed, but currently checked out file to the server, choose File > Workflow 
> Save.

• To add a file to a managed workgroup, choose File > Workflow > Save As.

3 Choose a server from the pop-up menu; then locate the directory to which you want to 
save the file. 

4 Type in a file name in the Name text box, and choose a format from the Format pop-up 
menu.

Note: Be sure to specify a file extension if the file will be downloaded to a computer 
running a Windows operating system.

5 To check out the file, select Keep This File Checked Out for Editing.

6 Click Save.
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Working offline
Working offline lets you work disconnected from the network. This is useful when you are 
working away from your office, for example. You can edit a managed file that has been 
checked out before you went offline. 

You can perform operations that don’t change the workgroup state (that is, operations 
that don’t check in or check out files) while offline. If you attempt to do something that is 
an online operation (such as Check In) you are reminded that you are offline and asked if 
you want to connect to continue.

To work offline:

Choose File > Workflow > Work Offline.

Adding metadata to documents
Metadata, or file information, is descriptive information that can be searched and 
processed by a computer. Use it to provide information about the contents of a document 
and to preserve information about a document that will be opened in other Adobe appli-
cations.

You can add metadata to AI, PDF, or SVG file formats.

To add metadata to a document:

1 Choose File > File Info.

2 To load an existing file click Load, choose the file, and click Open.

3 Select a category from the list on the left side of the dialog box and enter the desired 
information. 

• General specifies information about the document, such as title, author, and 
description. To specify copyright information, select Yes from the Copyrighted pop-up 
menu. Then enter the copyright notice string and the URL of the person or company 
who owns the copyright. 

• Keywords specifies words that can be used to search for the document. To add a word 
to the list, enter text in the Keyword text box and click Add. To edit or replace a word in 
the list, select the word, change the text in the Keyword text box, and click Replace.To 
delete a word from the list, select the word and click Delete.

• Summary specifies status information for the document, including its creation data, 
modification data, and location. If the document is a managed file, the server location 
and checkout status also appears. You cannot edit Summary metadata.

4 Do one of the following:

• To save the information, click OK.

• To save the information as a separate file, click Save, enter the name you want to save it 
as, and click Save in the Save dialog box.

• To append the information to an existing file, click Append, enter the name you want to 
save it as, and click Open in the Open dialog box.
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Chapter 7: Object Layers
dobe LiveMotion object layers help you customize your compositions, and also 
make adding image effects easier.

About object layers
The power of layers is that they allow you to work on one object of your composition 
without disturbing the others. This means you can experiment freely with different objects 
without making changes to your overall composition. In addition, special features let you 
create special elements for your Web page design, such as arrows that have an embossed 
shape on the top layer and a drop shadow on the bottom layer of an object.

Using the Object Layers palette
The Object Layers palette lists all layers in an object, starting with the topmost layer. A 
small preview of each layer appears in the palette and is updated as you edit. The Object 
Layers palette enables you to select, create, hide, display, copy, move, and delete layers. 
(Additional commands appear in the Layer menu.) 

The Shapes, Styles, Properties, and Transform palettes affect all layers in a selected object. 
The Layer, Color, Opacity, Adjust, Distort, 3-D, Gradient, and Textures palettes affect only 
the selected layer of a selected object.

Object layers palette
A. Show/Hide button B. Thumbnail C. Duplicate Layer button D. New Layer button
E. Trash button F. Highlighted layer is selected.

To display the Object Layers palette:

Choose Window > Object Layers.

Selecting layers
If your composition has multiple layers, you must select what layer you want to work on. 
Any changes you make to the composition affect only the active layer. Only one layer can 
be active at a time.
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If you don’t see the desired results when using a tool or applying a command, you may not 
have the correct layer selected. Check the Object Layers palette to make sure that you’re 
working on the desired layer.

To select a layer:

In the Object Layers palette, click a layer to make it active.

Viewing layers
With the Object Layers palette, you can control whether a layer is visible. Visible layers 
display a preview or thumbnail of its contents. Only visible layers are exported and printed.

To show or hide a layer:

Do one of the following:

• In the Object Layers palette, click the Show/Hide button  next to a layer to hide that 
layer and its thumbnail. Click in the column again to redisplay the layer. 

• Alt-click (Windows) or Option-click (Mac OS) the Show/Hide button for a layer to display 
just that layer and its thumbnail. Alt/Option-click in the Show/Hide column again to 
redisplay all the layers and thumbnails. 

Note: You can make the selected layer invisible. Keep in mind, however, that changes still 
affect the hidden, selected layer.

Changing the stacking order of layers
The order of layers in the palette is the same as the stacking order in the composition, with 
the top most layer in the palette being the front layer in the composition.

To change the order of layers with the Layers menu:

1 In the Object Layers palette, select the layer that you want to move.

2 Choose Layer > Arrange, and choose an option from the submenu to arrange the layer:

• Bring to Front to make the layer the top most layer.

• Bring Forward to move the layer up one level in the stacking order.

• Send Backward to move the layer down one level in the stacking order.

• Send to Back to make the layer the bottommost layer in the composition.

To change the order of layers by dragging:

1 In the Object Layers palette, select the layer that you want to move. 
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2 Drag the layer up or down in the palette. When the outline of the layer you are dragging 
appears in the position you want, release the mouse button.

Changing layer order by dragging

Creating a layered composition
LiveMotion lets you create up to 99 layers in an composition. However, the amount of 
memory in your system may put a lower limit on the number of layers possible in a single 
composition.

Adding layers
Newly added layers appear below the selected layer in the Object Layers palette. 

To add a new layer:

Do one of the following:

• Choose Layer > New Layer.

• Click the New Layer button  in the Object Layers palette.

The layer is named according to its order in the layer stack.

To name or rename a layer:

1 In the Object Layers palette, double-click the layer.

2 Enter the name you want to give the layer, and click OK.

Duplicating layers
You can duplicate any layer within the same object. The new layer appears below the 
original and is automatically selected. 

To duplicate a layer:

1 In the Object Layers palette, select the layer you want to duplicate. 

2 Do one of the following:

• Choose Layer > Duplicate Layer.

• Click the Duplicate Layer button  the Object Layers palette.

To delete a layer:

1 Select the layer in the Object Layers palette.

2 Do one of the following:

• Choose Layer > Delete Layer.
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• Click the Trash button  in the Object Layers palette.

Removing layer attributes
The Clear Layer Attributes command removes any gradient, opacity, color adjustment, 
texture, image, 3-D effect, distortion, offset, or softness attributes applied to the layer. The 
resulting layer is filled with the current color.

To remove the attributes of a layer:

1 Select the layer in the Object Layers palette.

2 Choose Layer > Clear Layer Attributes.

Using the Layer palette
While the Object Layers palette lets you add, remove, select, reorder, and delete a specific 
layer of an object, the Layer palette lets you specify several basic properties for the 
selected layer:

• Fill specifies whether the layer is filled with a color, texture, image, or the background.

• X Offset and Y Offset specify how far to move the layer from the object’s center. You can 
use these values, for example, to create a drop shadow.

• Width specifies how much to widen or narrow a layer. You can use this option to widen 
the bottom layer, creating an outline, or stroke, around the object.

• Softness specifies how much Gaussian blur to add to the layer. You can use this feature 
to create shadows with soft edges, for example

To specify a color fill for a layer:

1 Select the layer in the Object Layers palette.

2 Choose Window > Layer.

3 In the Layer palette, choose Color to fill the layer with the current color, opacity, and 
gradient specified in the Color, Opacity, and Gradient palettes.

To specify an Image fill for a layer:

1 Select the layer in the Object Layers palette.

2 Choose Window > Layer.

3 In the Layer palette, choose Image to fill the selected layer with a specified image. For 
instance, if you select an image of a boat, the layer is filled with the boat image. Choosing 
this option for a geometric object or text object fills the layer with the current color. If you 
want to apply an image to a layer of an object, drag the image file onto the layer in the 
Object Layers palette. Keep in mind that you can’t add a different image to each object 
layer.

To specify a background fill for a layer:

1 Select the layer in the Object Layers palette.

2 Choose Window > Layer.

3 In the Layer palette, choose Background to fill the layer with whatever is beneath the 
object, whether it’s another object or the background. For more information, see “About 
foreground, background, and layer colors” on page 85.
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To specify a texture fill for a layer:

1 Select the layer in the Object Layers palette.

2 Choose Window > Layer.

3 In the Layer palette, choose Texture to fill the layer with any texture applied to it. If no 
texture is currently applied, the shape remains filled with the current color, opacity, and 
gradient. For information, see “Applying textures to layers” on page 74.

Top layer filled with A. Color, B. Image, C. Background, and D. Texture

To specify the softness of a layer:

1 Select the layer in the Object Layers palette.

2 Choose Window > Layer.

3 In the Layer palette, for Softness, drag the Softness slider or enter a value between 0 
and 10 in the text box to specify the amount of Gaussian blur. A higher value increases the 
amount by which the edge of the layer fades into transparency.

To offset a layer with the Layer palette:

1 Select the layer in the Object Layers palette.

2 Choose Window > Layer.

3 In the Layer palette, offset the layer from the center of the object by a specific number 
of pixels:

• To move the object horizontally from the center, drag the X Offset slider or enter a value 
between -50 and 50 pixels in the text box. A negative value moves the layer to the left; a 
positive value moves it to the right.

• To move the object vertically from the center, enter a Y Offset value between -50 and 50 
pixels. A negative value moves the layer up; a positive value moves it down.

To offset a layer by dragging:

1 Select the layer.

2 Do one of the following:

A B
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• Select the layer-offset tool , and drag.

• Press Ctrl (Windows) or Command (Mac OS), and drag over the center of the object.

To enlarge or shrink a layer:

1 Select the layer.

2 Choose Window > Layer.

3 For Width, enter a value between -10 and 10 pixels. A negative value narrows the layer; 
a positive value widens it.

Applying textures to layers
The Textures palette lets you apply a repeating—or tiled—texture or pattern to any layer 
of an object or to the background. Because textures are image files and can be in any file 
format that LiveMotion can import, you can add your own textures to the palette as well 
as use the ones provided. You can display a subset of textures in the palette, depending on 
what types of textures you are interested in. 

You can also directly apply a bitmap image as a texture to an object or the background.

For information on layers, see “Using the Layer palette” on page 72; for information on 
acceptable file formats, see “Placing image files” on page 58; for information on copying 
and pasting a bitmap image or texture from one object to another, see “Copying and 
pasting object attributes” on page 42.

You can use the same texture in the background of your LiveMotion composition as 
you do in your Web page. This shows you what your compositions will look like when 

they are place on the Web. And because LiveMotion automatically sets the transparency 
and edges of the exported objects to blend with the background texture, it can also make 
objects you export in GIF format look better against the background of your Web page. 
Because different Web browsers offset individual imported images differently against the 
background, this works best if you export a composition as an entire page rather than as 
separate images.

To display the Textures palette:

1 Select the background in the toolbox, or select the object in the Composition window 
and the layer in the Object Layers palette, to which you want to apply the texture.

2 Choose Window > Textures.

3 Choose a display option from the Textures palette menu:

• Swatches View to display a grid of thumbnail examples of textures.

• Preview View to display a named list of textures along with a large thumbnail for the 
currently selected texture.

• Name View to display a named list of textures with a small thumbnail example of each.

To display a subset of textures:

1 Choose Window > Textures.

2 Select one or more texture attribute:

• Small textures  are less than 500 pixels in width or height and generally must be tiled 
to fill a background.
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• Large textures  are more than 500 pixels in width or height and generally fill a 
background without tiling.

To apply a texture using the Textures palette:

1 Select the background (by clicking the background color box in the toolbox or Color 
palette) or select the object in the Composition window and the layer in the Object Layers 
palette.

2 Apply the texture from the Textures palette:

• Select the texture from the list (you can type a texture’s name to select it). Then click the 
Apply button  in the palette, or press Enter or Return.

• Double-click the texture from the list.

• Drag the texture onto an existing object to apply the texture to the selected layer. The 
existing object displays selection handles when it is selected.

• Drag the texture onto a layer in the Object Layers palette to apply the texture to the 
selected layer.

• Drag the texture onto the background to apply the texture to the background.

To apply a texture to a layer by dragging an image file from a folder or directory:

1 Open the folder or directory containing the bitmap image file you want to apply as a 
texture.

2 In LiveMotion, select the object to which you want to apply the texture.

3 Drag the image file from the folder or directory onto the layer in the Object Layers 
palette to which you want to apply the texture.

To place an image file as a texture:

1 Select the background or object and layer to which you want to apply the texture.

2 Choose File > Place as Texture.

3 Locate the image file you want to place as a texture.

4 Select Preview (Mac OS only) to display a small preview of the file. (In Windows, files are 
automatically previewed when possible.)

5 Click Open.

To add a texture to the Textures palette by dragging:

1 Select the object in the Composition window and the layer in the Object Layers palette 
that contains the texture you want to add to the Textures palette.

2 Do one of the following:

• Drag the object from the Composition window onto the Textures palette.

• Drag the layer from the Object Layers palette onto the Textures palette.

3 Name the texture, and click OK.

The texture is placed in alphabetical order in the list of available textures.

To apply an image object as a texture to an object, save the image as a texture first. 
You can do this by dragging the image object onto the Textures palette.
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To add a texture to the palette by dragging a bitmap image file:

1 Open the folder or directory containing the bitmap image file.

2 In LiveMotion, Drag the image file onto the Textures palette.

3 Name the texture, and click OK.

A copy of the bitmap image file is saved as a texture and placed in alphabetical order in 
the list of available textures.

To add a texture to the palette by specifying an image file:

1 Click the New button  on the Textures palette.

2 Locate the image file of the texture you want to add to the Textures palette, and click 
Open.

3 Name the texture, and click OK.

The texture is placed in alphabetical order in the list of available textures.

To add a texture to the Textures palette by placing it in the Textures folder:

1 If needed, rename an image file in Explorer (Windows) or the Finder (Mac OS) to give it 
the name you want to appear in the Textures palette. In Windows, the image file must 
have the correct image extension. 

2 Place the image file into the Textures folder located in the LiveMotion folder.

The image is placed in alphabetical order in the list of available textures the next time you 
start LiveMotion.

To replace a texture:

Add a texture, and give it the same name as an existing texture.

To delete a texture from the Textures palette:

1 In the Textures palette, select the texture you want to delete.

2 Click the Trash button .

3 Click Delete.

Applying color adjustments to layers
The Adjust palette lets you adjust color attributes on any layer of an object or the 
background. You can change the brightness, contrast, saturation, or tint of colors. In 
addition, you can limit the number of colors for a posterized effect, and invert colors.

Depending on what you choose in the Layer palette, a layer can be filled with color, an 
image, a texture, or the background. For more information, see “Using the Object Layers 
palette” on page 69. 

The effect of the Adjust palette varies, based on the layer’s fill:

• If the layer is filled with a color, it is generally simpler to choose a different color from 
the Color palette than adjust it with the Adjust palette. Otherwise, the color is just 
shifted to another color you could have picked from the Color palette.
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• If the layer is filled with an image or texture, the Adjust palette alters the entire range of 
colors in the texture or image. The Adjust palette options are most useful on these 
kinds of fills.

• If the layer is filled with the background, the Adjust palette lets you easily change the 
color of anything seen through that layer, creating an effect similar to looking through 
a colored lens.

About color adjustment
Adjusting colors is similar to mixing white or black paint into colored paint; it alters the 
appearance of the color without altering the actual hue. In the Adjust palette, colors can 
be adjusted in the following ways:

• Brightness makes a layer lighter or darker. Enter a value between -255 and 255. A 
negative value darkens the layer; a positive value lightens it.

• Contrast increases or decreases the difference between colors. Enter a value between -
128 and 128. A negative value decreases the contrast on the layer; a positive value 
increases it. This effect is most noticeable if the layer is filled with an image, texture, or 
background.

• Saturation adjusts the strength of the color. Enter a value between -128 and 128. A 
negative value increases the amount of gray in proportion to the hue; a positive value 
decreases the amount of gray in proportion to the hue.

• Tint blends the current foreground color in the Color palette with the current fill for the 
selected layer. Enter a value between 0 and 255. A higher number increases the amount 
of tint added to the fill. This option is not available if the layer is filled with a color from 
the Color palette.

• Posterize sets the number of colors in the image. Entering 0 leaves a full range of colors 
in the layer. Entering 1 leaves one color in the layer; entering 30 leaves 30 colors. For 
example, using just a few colors for a bitmap image can change a continuous-tone 
image such as a photograph into areas of flat color, making the photo look like a 
painted poster. 

• Invert changes the colors in an image to their opposites. You might use this command 
to make a positive black-and-white image negative or to make a positive from a 
scanned black-and-white negative. The normal, noninverted color is displayed in the 
foreground color box and background color box in the toolbox and Color palette, 
because it is this color that is currently inverted.

Note: Because negative color film contains an orange mask in its base, the Invert 
command cannot make positives from scanned color negatives.

When you invert a color, the brightness value of each component of that color is 
converted to the inverse value on the color range slider (it shifts colors to their opposite on 
the color wheel). For example, the inverse of a color whose red is 255 is 0.

To adjust colors using the Adjust palette:

1 Select the object in the Composition window and the layer in the Object Layers palette.

2 Choose Window > Adjust.

3 Choose a color adjustment.
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Applying 3-D effects to layers
Adobe LiveMotion includes four automated 3-D effects that you can apply to any layer of 
an object. These effects are cutout, emboss, bevel, and ripple. Adding 3-D effects can 
increase the file size of your compositions.

3-D effects
A. Original B. Cutout C. Emboss D. Bevel E. Ripple

To apply a 3-D effect to a layer:

1 Select the object in the Composition window, and select the layer in the Object Layers 
palette.

2 Choose Window > 3-D.

3 For Effect, choose one of the following: None, Cutout, Emboss, Bevel, or Ripple.

4 Specify the intensity of the effect:

• For Depth, enter a value between 0 (for no distance) and 40 to specify the distance in 
pixels between the edge of the layer and where the effect is greatest. A higher value 
increases distance and creates a greater apparent depth.

• For Softness, enter a value between 0 (for no blur) and 10 to specify the amount of 
Gaussian blur to apply to the layer. A higher value increases the apparent smoothness 
of the effect. The high value of softness is useful for preventing jagged edges from 
appearing on bevels, and to round over the top of a bevel.

• For Lighting, enter a value between 0 (for no difference) and 200 to specify the 
difference between the light and dark areas of the object. A value of 100 uses all the 
lighting information in the object; lower and higher values have an effect similar to 
underexposing and overexposing the object.

A
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5 Choose an Edge setting to specify the type of edge: Straight, Button, Plateau, or Ripple.

Note: The Edge settings are unavailable when you use the Cutout option.

6 Choose a Light setting:

• Normal to apply neutral lighting, highlights, and shadows to the object.

• Light Only to apply just neutral lighting and highlights to the object.

• Dark Only to apply just neutral lighting and shadows to the object.

7 In the angle area , enter the rotation angle in degrees to indicate the source of the 
light. An angle of 0° lights the object from the right, 90° lights it from the top, 180° lights it 
from the left, and 270° lights it from the bottom.

Applying distortion effects to layers
The Distort palette provides a variety of distortion effects that let you alter the fill on any 
object layer. The results of the distortion effect depends on the layer’s fill. Applying a 
distortion to a layer filled with a solid color has no visible effect. However, you can distort a 
layer filled with a gradient. Applying a distortion to a layer filled with a texture distorts the 
texture. Applying a distortion to a layer filled with an image distorts the image.

Distortion effects will increase the file size of bitmap images.

None Applies no effect.

Displace Shifts the fill. This option works best with shapes that are filled with the 
background and have a 3-D effect applied, because Displace bases its distortion on the 
apparent “depth” of the shape. Increasing the Distance value moves the fill further in the 
direction of the angle you specify.

Lens Magnifies or shrinks the fill. Increasing the Magnification value enlarges the fill, 
decreasing shrinks it. Entering an Angle value rotates the fill in the direction you specify.

Twirl Rotates the fill more sharply at the center than at the edges. A positive Turn value 
rotates the view clockwise; a negative value rotates the view counterclockwise. A value of 
100 creates one complete turn.

Increasing the Band Size value splits the image into increasingly larger concentric bands. 
Within each band the pixels are rotated the same amount.

Spherize Wraps the fill around a sphere, creating an effect similar to a fisheye lens. 
Increasing the Magnification value enlarges the fill, decreasing shrinks it. A positive Sphere 
value increases the size of the fill at the center; a negative value shrinks it.

Quantize Breaks up the fill into tiles or blocks. The Size value determines the size of the 
tiles in pixels. 
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Radial Quantize Breaks up the fill into circular bands radiating from the center of the 
shape. The Size value determines the width of the band in pixels.Applying a distortion to a 
layer filled with the background distorts areas below the object, creating a lens-like effect.

Distortion effects
A. Original B. Displace C. Lens D. Twirl E. Spherize F. Quantize G. Radial Quantize

To distort a layer:

1 Select the object in the Composition window, and select the layer in the Object Layers 
palette.

2 If needed, specify the fill for the shape on that layer: the background, an image, or a 
texture. (A solid color is not recommended.)

3 Choose Window > Distort.

4 Choose a distortion effect. 
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Chapter 8: Color, Gradients, and 
Opacity

ayers can be filled with colors specified in the Color palette, or with colors sampled 
from other objects using the eyedropper tool. Once you’ve specified a color, you can 
adjust its opacity, create gradients, or make further color adjustments.

About color management
The colors you choose for your graphics affect the look and feel of your Web pages. 
LiveMotion provides a full range of color palette options to create and modify colors. 
LiveMotion also includes Web-safe colors that will display properly in Web browsers. 

Using the Color palette
The Color palette displays the color values for the current foreground and background 
colors. Using the sliders in the Color palette, you can edit the foreground and background 
colors according to several different color models. You can also choose a color from the 
spectrum of colors displayed in the color bar.

Color palette
A. Foreground color B. Background color C. Set Web-safe colors D. Slider E. Color bar F. Color 
palette menu

About color models
Color models provide different ways of creating colors. Each one is based on a different 
aspect of color or a different way of viewing color. LiveMotion has several color models 
with which you can work.

Designing for the Web presents a unique challenge when choosing colors. Color monitors 
cannot display every color, and Web browsers display fewer still, so you need to choose 
colors that will work on the Web. LiveMotion has features to help you choose Web-safe 
colors.
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Saturation View Sometimes called chroma, saturation is the strength or purity of the 
color. Saturation represents the amount of gray in proportion to the hue, measured as a 
percentage from 0% (gray) to 100% (fully saturated). On the standard color wheel, 
saturation increases from the center to the edge.

Standard color wheel
A. Green B. Yellow C. Red D. Magenta E. Blue F. Cyan

Value View Represents the relative lightness or darkness of the color, usually measured 
as a percentage from 0% (black) to 100% (white).

Hue View Represents the color reflected from or transmitted through an object. It is 
measured as a location on the standard color wheel, expressed as a degree between 0° 
and 360°. In common use, hue is identified by the name of the color such as red, orange, or 
green. 

HSB View Consists of hue (color) values from 0° to 360°, saturation (the strength or purity 
of the color), brightness (lightness or darkness of the color) values from 0% to 100%. The 
angle for hue is defined as an angle relative to pure red on the color wheel.

RGB View Assigns an intensity value to colors ranging from 0 (black) to 255 (white) for 
each of the red, green, and blue (RGB) components in a color image.

CIE L View Represents a subset of all visible colors that can also be displayed by color 
monitors. The palette has a range of saturation. As the saturation changes, the range of 
visible colors within the limit of that saturation changes. Colors within a range that cannot 
be displayed by color monitors are represented as white space.

Web Safe Is the set of 216 colors most often used by Web browsers. This set is a subset of 
the Windows and Mac OS system palettes. Only Web-Safe colors are shown in the Color 
palette when you click the Set Web Safe Colors option.

Note: Applying distortion or 3-D effects, tints, or gradients may produce colors that are 
not Web-safe.

To specify a color using the Color palette: 

1 Select the object you want to edit, or the foreground or background.

2 Choose Window > Color if the Color palette is not open.

3 Choose a color model from the Color palette menu at the top right of the palette. If you 
want only Web Safe colors shown, click the Set Web Safe Colors option in the Color palette.

4 Specify a new color:

• Drag the color sliders.

• Enter values next to the color sliders. 

E

C

BA

F

D



Using Help | Contents | Index Back 83  

Help Color, Gradients, and Opacity 

Using Help | Contents | Index Back 83  

• Click the color bar.

• To specify a new Hue, Saturation, Value, or CIE L color, use the color slider and the color 
field to select a color. The vertical color slider displays the range of color levels available 
for the selected color (for example, Hue). The color field displays the range for the 
remaining two components—one on the horizontal axis, one on the vertical (in this 
example, Saturation and Value).

Using the Color Scheme palette
The Color Scheme palette creates a color scheme based on the color you select. You can 
then apply the colors of the scheme to the objects in your composition.

Color schemes are based on the relative positions of colors on the color wheel. Analogous 
colors are next to each other on the color wheel. These colors are similar and create tonal 
color schemes made up of, for example, all warm colors such as reds. Complementary 
colors are across from each other on the color wheel. These colors are opposites and 
create dynamic color schemes made up of distinct colors that stand out from one another.

Color scheme palette
A. The base color B. Lock color scheme C. Number of colors in the scheme
D. Equidistant Colors scheme E. Complementary Colors scheme F. Split Complementary scheme

The Color Scheme palette will display up to six colors in a set, according to the number of 
colors and color scheme option you choose: 

• Split Complementary: The base color and its complement’s analogous colors .

• Complementary Analogous: The base color, its analogous color, and their complements 
.

• Tetrad: The base color and its three equidistant colors .

• Triad: The base color and its two equidistant colors .

• Sextet: The base color and its five equidistant colors .

Here are some guidelines to note when using the Color Scheme palette:

• Some colors are not available in Web browsers. If you have selected the Web-safe color 
option in the color palette, only Web-safe colors will be displayed in the color scheme.

• The base color is indicated by a larger black circle.

• Choosing a highlighted complement as the new base color will not necessarily yield the 
same set of colors as the original base color.

To create a color scheme using the Color Scheme palette:

1 Select a color to use as the base color, using either the eyedropper tool , the Color 
palette, the Color Scheme tiles on the toolbox, or by selecting an object. 
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2 Choose Window > Color Scheme. 

3 Choose how to display the base and complementary colors using the Color Scheme 
palette menu at the top right of the palette:

• Triangles displays the colors as overlapping triangles.

• Honey Comb displays the colors as interlocking honeycomb shapes.

Select the background button to display the background color of the composition in the 
color scheme preview box.

Choose a color scheme from the menu at the bottom of the palette.

4 Deselect Lock Colors, which is selected by default.

5 Select the number of colors for the scheme using the up and down arrows. 

6 Select the object to which you want to apply a color from the Color Scheme palette. 

7 Click the color in the palette or the Color Scheme tile in the toolbox. Lock Colors will be 
selected to prevent the colors in the Color Scheme palette from changing when you select 
a new color.

To save a color scheme and use it in other LiveMotion compositions, open a new 
Composition window, create a number of basic objects, and apply each of the 

scheme’s colors to an object. Then save the composition. You can later open the compo-
sition and use the eyedropper tool to apply the colors from the saved composition to the 
objects of another composition. 

Using the Opacity palette
The Opacity palette lets you specify the opacity of any object or layer. That is, you can use 
the palette to control the transparency of objects or layers. An object can have a single 
opacity for all its layers, or each layer can have its own opacity along with the overall 
opacity of the object. Opacity can be very useful for controlling how textures and images 
are rendered. Applying a colored layer with 30% opacity over a layer with a texture, for 
example, will change the color of the texture and make it look softer but will still allow it to 
show through.

The opacity can be applied evenly, or as a gradient. For example, you can set the starting 
opacity to 100% and have the fill gradually blend into an ending opacity of 50%.

The gradient options in the Opacity palette let you select the starting and ending opacity, 
as well as the relative distance from the edges of the object where the starting opacity 
begins blending to the ending opacity.
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In the opacity gradient bar, black represents an opacity of 100% (fully opaque) white an 
opacity of 0% (fully transparent), and gray an opacity between 0 and 100% (semitrans-
parent). The bar at the bottom of the palette lets you preview the effects of the opacity 
gradient. For more information on creating opacity gradients, see “Creating gradients” on 
page 87. 

Opacity palette
A. Object opacity B. Object layer opacity C. Gradient selection

To specify opacity:

1 Select the object or object and layer.

2 Choose Window > Opacity if the Opacity palette is not open.

3 Adjust the opacity of the object or layer:

• To adjust the opacity of the entire object, enter a value between 0 and 100 for Object 
Opacity. 

• To adjust the opacity of the selected layer, enter a value between 0 and 100 for Opacity. 

A value of 0 makes the layer or object completely transparent; a value of 100 makes it 
completely opaque.

About foreground, background, and layer colors
The foreground color is the color that fills the currently selected object layer, and is used to 
fill any newly created objects; the background color fills the background, or canvas, against 
which the object appears. The layer color is the color of the currently selected object layer. 
You can specify a color for the foreground, background, or layer with the Color palette or 
the eyedropper tool, or even apply a texture with the Textures palette. For information on 
textures, see “Applying textures to layers” on page 74.

The current foreground color and background color are the colors that will be used in any 
composition until you choose different ones.
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The current foreground color appears in the top color selection box, the background color 
in the lower box in both the toolbox and the Color palette. The default foreground color is 
black, and the default background color is white. Any color changes you make in the 
composition are reflected in the color selection boxes. Because changing the color of a 
selected layer also changes the foreground color, and vice versa, you can change them 
simultaneously.

Color palette color selection box
A. Foreground color B. Background color

To change the foreground, background, or layer color:

1 Choose the foreground, background, or layer:

• Click the foreground color box, or select an object and layer you want to color. Deselect 
any selected objects to change the foreground color without applying it to any object. 
Then make sure the foreground color box is selected in the toolbox or Color palette.

• Click the background color box. This action selects the background and deselects any 
object currently selected.

• Select the object and layer to apply the color directly to a layer.

2 Choose a color, gradient, or texture to apply to the foreground, layer, or background:

• Sample a color, as explained in “Copying colors and styles” on page 86.

• Make a gradient, as explained in “Creating gradients” on page 87.

• Choose a texture, as explained in “Applying textures to layers” on page 74.

Copying colors and styles 
You can sample the color of any object or the background in your composition, or from 
another application entirely. You can then use the paint bucket tool to apply the current 
color to the top layer of an object. 

You can also use these tools to copy and apply styles from within the Composition 
window. For information on copying attributes such as the style or current fill using the 
Paste commands, see “Copying and pasting object attributes” on page 42.

To sample a color or style using the eyedropper tool:

1 Choose where you want to apply the sampled color or style: an object layer, the 
foreground, or the background.

2 Select the eyedropper tool .

3 Sample a color or style:

• Click in the Composition window where you want to sample a color from an object or 
the background.

• Drag the eyedropper tool to continuously sample colors from inside or outside the 
Composition window. (To sample colors from outside the Composition window, begin 
dragging from inside the window.) Release the mouse button to select the color.
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• Shift-click to sample the style of an object. A white bar appears across the eyedropper 
tool. For more information on styles, see “Using the Styles palette” on page 90.

• Shift-drag to continuously sample the style of objects. Release the mouse button to 
select the new style.

As you use the eyedropper tool, the color in the foreground or background color box, 
Color palette, and any selected object changes dynamically. 

Note: Sampled colors in your composition are taken from the actual color of the objects 
and background, not the color displayed if you are viewing them in Active Preview. 

To apply a sampled color or style: 

1 Select the paint bucket tool .

2 Apply the color or style:

• Click an object or the background to select it and paint it with the current color in the 
Color palette. If you select an object, the top layer is painted.

• Shift-click an object to select it and apply the last style sampled with the eyedropper 
tool. A vertical gray bar appears at the lip of the paint bucket tool.

Creating gradients
The Gradient palette lets you create a gradual blend between two colors in a layer. The 
Opacity palette creates gradients that are a gradual blend of opacity. The gradient is 
applied to the entire active layer of the selected object. Gradients can be created in several 
patterns for more complex blending. The five basic gradients are:

No Gradient Applies no gradient.

Linear Shades in a straight line from one edge of the object to the other.

Burst Shades using symmetrical linear gradients on either side of the center.

Double Burst Shades using two symmetrical burst gradients, at right angles to each 
other, each moving from the center to the edge of the object. Double burst gradients 
affect the exported file size because they change vector graphics to bit map.

Radial Shades from the center to the edge in a circular pattern.

Gradient options
A. No Gradient B. Linear C. Burst D. Double Burst E. Radial
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The Gradient palette lets you select the starting and ending colors. You can also adjust the 
relative distance from the edges of the object to where the starting color begins blending 
into the ending color. You can also specify if the gradient will rotate with the object using 
the Relative option. In order to switch between the relative and nonrelative settings, you 
must turn on the Shape Transform option in the Object menu.

Gradient palette gradient
A. Starting color stop B. Blending occurs between starting and ending color stops C. Ending color 
stop D. Resulting gradient

The Opacity palette lets you select the starting and ending opacity.

Opacity palette gradient
A. Starting opacity stop B. Blending occurs between starting and ending opacity stops C. Ending 
opacity stop D. Resulting gradient

To apply and edit a gradient: 

1 Select the background, or an object and layer.

2 Choose Window > Gradient.

3 Select the kind of gradient you want.

4 Click the left color stop under the gradient bar to define the starting color of the 
gradient. (This color is the object color by default.) The square below the stop is outlined, 
indicating that the starting color is being edited.

5 Change the color by doing one of the following:

• Use the eyedropper tool to sample and apply a color.

• Use the Color palette to specify a color.

6 Define the ending color. Click the right color stop under the gradient bar. (This color is 
black by default.) Then choose a color as described in the previous step.

7 Drag the corresponding color stop left or right to adjust the location of the starting 
point or ending point of the gradient. 

8 Choose Object > Transform > Shape Transform. Select Relative to rotate the gradient 
when you rotate the object.

DCA B

DCA B
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9 Enter a value between 0° and 359° to specify the angle at which to apply the gradient. A 
preview of the gradient is displayed in the gradient angle indicator.

To apply an opacity gradient:

1 Specify the starting opacity in the Opacity palette (see “Using the Opacity palette” on 
page 84).

2 Choose the kind of gradient you want. For a description of the gradient types, see 
“Creating gradients” on page 87.

3 Click the left gradient stop under the gradient bar to define the starting opacity of the 
gradient. The square below the stop is outlined, indicating that the starting color is being 
edited.

4 Enter an opacity value for the starting opacity.

5 Click the right gradient stop under the gradient bar to define the ending opacity. Then 
choose an opacity as described in the previous step.

6 Drag the corresponding opacity stop left or right to adjust the location of the starting 
point or ending point. 

7 Select Relative to rotate the gradient when you rotate the object.

8 Enter a value between 0° and 359° to specify the angle of the gradient. The preview of 
the gradient is displayed in the gradient angle indicator.
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Chapter 9: Styles and the Library
ou can combine a wide array of attributes—effects, colors, animations—to create 
unique objects. You can save these styles and objects in the Styles and Library 
palettes so that you can quickly access them for use in any composition. The Styles 

palette and Library also have predefined styles and objects ready for you to use.

Using the Styles palette
 The Styles palette lets you save and apply styles to any object. A style is the set of 
attributes of an object. Object attributes include settings from various palettes, including 
the animation timeline and the Rollover palette. Styles do not include the type of object 
(geometric, text, or image), its shape, and any settings from the Transform palette or the 
Web palette applied to the style. 

Consider the following guidelines when applying styles:

• Styles can be applied to any object in LiveMotion—geometric, type, and image.

• Rollovers can be saved and applied as styles (see “About rollovers” on page 125 and 
“Saving and applying rollover styles” on page 128).

• Animations can be saved and applied as styles (see “Creating custom styles” on 
page 91).

• A style can have up to 99 object layers that adopt the shape and type of object to which 
you apply the style.

• Each layer in a style has any combination of color, background fill, texture, 3-D effect, 
distortion effect, gradient, opacity, and any attributes set in the Filter and Layer 
palettes.

• You can copy and paste styles and individual style attributes (see “Cutting, copying, and 
pasting objects” on page 42).

• In addition to applying entire styles, you can create and modify the attributes individ-
ually. 

To display the Styles palette:

1 Choose Window > Styles if the Styles palette is not open.

2 Choose a view for the sample Styles:

• Swatches View to display a grid of thumbnail examples of styles.

• Preview View to display a named list of styles along with a large thumbnail for the 
currently selected style.

Y
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• Name View to display a named list of styles with a small thumbnail example of each.

Styles palette
A. Animation B. Rollover C. Object Layers D. Apply E New style F. Trash

To display a subset of styles in the palette:

1 Choose Window > Styles.

2 Select one or more style attributes:

• Animation  to display styles that only include animation. 

• Rollover  to display styles with rollovers or animated Object or Layer attributes.

• Object Layers  to display styles with any number of layers. 

• Script  to display styles that include scripting.

Applying styles
The Styles palette enables you to apply styles to one or more objects.

To apply a style to an object:

1 Select the object to which you want to apply the style.

2 Select the style you want from the list.

3 Do one of the following:

• Double-click the style from the list.

• Click the Apply button in the palette

• Select a style and then press the Enter or Return key.

• Drag the style onto an existing selected object. 

Creating custom styles
You can create custom styles by giving an object a set of attributes, and then saving it in 
the Styles palette. This saves the object attributes as a new style without saving the object 
itself.

To add a style to the palette:

1 Select an object whose style you want to save.

2 Do one of the following:

• Click the New button  in the Styles palette.

• Drag the object onto the Styles palette.

3 In the Name dialog box, type a name for the style.

A B C D E F G
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4 To keep the style layers intact, select Layers.

5 Select which aspects of the object you want to save as part of the style:

• Layers saves any layers or layer effects as part of the style.

• Ignore Color of First Layer prevents the fill attribute of the first object layer from being 
saved as part of the style. If checked, you will be able to apply this style to other objects 
without overriding their current color, for instance.

• Layer Animation/States keeps any layer-based animations or rollovers in the style. For 
more information on animation, see “Understanding animation terminology” on 
page 95. For information on rollovers, see “About rollovers” on page 125.

• Object Scripts keeps scripts assigned to objects in the style.

• Keyframe Scripts/Labels keeps scripts assigned to keyframes in the style.

• Object Animation/States saves any object-based animations or rollovers as part of the 
style.

6 Click OK.

The style is placed in alphabetical order in the list of available styles.

Note: Sounds are not saved as part of an object’s style. If you want to save a sound or 
apply it to an object, see “Working with sound” on page 114.

To add a style to the palette by placing it in the Styles folder:

1 Rename the LiveMotion style file in Explorer (Windows) or the Finder (Mac OS) to give it 
the name you want to appear in the Styles palette. To be recognized in Windows, the 
filename must end in the .liv extension.

2 Place the file into the Styles folder located in the LiveMotion folder.

The style is placed in alphabetical order in the list of available styles the next time you start 
LiveMotion.

To share styles with other users, create the style and provide them with a copy of the 
file from the Styles folder.

To replace a style in the palette:

Add a style, and give it the same name as an existing style.

To delete a style from the palette:

1 In the Styles palette, select the style you want to delete.

2 Click the Trash button .

Note: Deleting a style erases it from your hard drive. This action cannot be undone.

About the Library palette
While styles store the attributes of an object to be applied to other objects, the Library 
palette stores an actual object or group of objects along with all its attributes, including 
animation and rollovers. The Library palette is a good place to store graphic elements, 
such as logos or navigation bars, that you will use in multiple compositions. 



Using Help | Contents | Index Back 93  

Help Styles and the Library 

Using Help | Contents | Index Back 93  

Viewing Library objects
Library objects can be displayed several ways in the Library palette,. You can choose 
subsets of objects to view, depending on which object formats you want to use. 

To display the Library objects:

1 Choose Window > Library if the Library palette is not open.

2 Choose a view for the sample objects:

• Swatches View to display a grid of thumbnail examples of objects.

• Preview View to display a named list of objects along with a large thumbnail for the 
currently selected object.

• Name View to display a named list of objects with a small thumbnail example of each.

To display a subset of objects in the palette:

1 Choose Window > Library.

Library palette
A. LiveMotion B. EPS and PDF C. Bitmap D. Replace E. Make Active Matte F. Place Object G. New 
Object H. Delete Object

2 Select one or more object formats:

• LiveMotion  to display native LiveMotion objects you have created.

• EPS  to display Encapsulated PostScript vector objects or PDF to display Portable 
Document Format objects. 

• Bitmap  to display bitmap objects.

Using Library objects
Library objects can be placed into a composition as a new object, or they can replace 
existing objects in a composition. They can also be used as mattes so that their shape is 
transferred to an object in the composition. See “Applying mattes” on page 53.

To place a Library object in a composition:

1 Select the object in the Library palette that you want to place.

2 Place the object in the composition by doing one of the following: 

• Click the Place button.

• Drag the object onto the composition.

To replace an object with a Library object:

1 Select the object you want to replace.

A B C G HD E F
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2 In the Library palette, select the Library object you want to use as the replacement, and 
do one of the following:

• Click the Replace button.

• Drag the Library object from the palette onto the object you are replacing.

• Press the enter or return key

To use a Library object as a matte:

1 Select the bitmap image to which you want to apply a matte.

2 In the Library palette, select the object whose shape you want to use as a matte and do 
one of the following:

• Click the Make Active Matte button.

• Drag the Library object from the Library palette onto the Active Matte display in the 
Properties palette.

Adding and deleting Library objects
Any object you create in LiveMotion can be saved as a Library object with all of its 
attributes intact. When you place a saved Library object into a composition, it can be 
modified like any other LiveMotion object.

To save an object in the Library:

1 Select the object you want to save

2 Drag the object onto the Library palette, and name the object. The object is placed in 
alphabetical order in the list of available objects.

To add an object to the palette by placing it in the Library folder:

1 Rename the Library object file with Explorer (Windows) or the Finder (Mac OS) to give it 
the name you want to appear in the Library palette. To be recognized in Windows, the file 
must end in the .liv extension.

2 Place the file into the Library folder located within the LiveMotion folder.

The object is placed in alphabetical order in the list of available objects the next time you 
start LiveMotion.

To replace an object in the palette:

Add an object, and give it the same name as an existing object.

To delete an object from the palette:

1 In the Library palette, select the object you want to delete.

2 Click the Trash button .
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Chapter 10: Animating Objects
nimation brings your LiveMotion objects to life. You can animate every aspect of an 
object in LiveMotion, including motion, color, and size, and incorporate sound and 
interactivity. All objects and groups in a composition can be animated. Each object 

is named in the timeline, and can be animated independently or as a group. 

Understanding animation terminology
All objects in a LiveMotion composition have certain object properties, such as position, 
rotation, scale, and color, that can be changed over time to create animation. For example, 
an object may move, rotate, appear, disappear, change size, change color, or interact with 
other objects or with users over time. Here are some basic concepts to help you under-
stand how objects are animated with LiveMotion.

Timeline window The Timeline window displays all the objects in a composition and the 
animation events associated with each object in terms of time. (The Composition window 
displays all objects in terms of space.)

Duration bar A representation an object’s lifespan, or duration. For example, the 
duration bar for the composition specifies how long the entire composition lasts as an 
animation. In addition, each object in a composition has its own duration bar. The length 
of the duration bar represents how long the object will last, while the start point and end 
point of the bar signal when the object appears in and disappears from the animation. By 
default the duration of all newly created objects matches the duration of the composition.

Animation Frames An animation frame (often simply called a “frame”) represents a point 
in time. For example, if an animation is set to display at a rate of 10 frames per second, 
frame 20 would be two seconds into the animation.

Keyframes A keyframe marks the point in time where you specify a value for an object 
property or for a behavior to occur. Typical animations (those that don’t use scripts and 
event handlers) using keyframes require at least two keyframes. LiveMotion creates 
animation between these two keyframes by interpolating transition frames using interme-
diate values based on the changing property values from one keyframe to the next. A 
keyframe contains information on the type and speed of change between the adjacent 
intermediate values. The closer the keyframes are, the faster the change will occur.

You can change properties with or without setting keyframes. However, if you do not set 
keyframes, or if you set only one keyframe, changes you make to the property value 
remain in effect for the duration of the animation.

Stopwatch Each object property has an associated Stopwatch button  that you click to 
begin the animation process. Once the stopwatch is active for a specific property, 
LiveMotion automatically sets new keyframes whenever you change the current time and 
property value. When the stopwatch is inactive, no keyframes are present. If you type a 
value for a property while the stopwatch is inactive, the value remains in effect for the 
duration of the object.

A
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Behaviors A behavior is an instruction to the animation to do something other than 
change an object property; that is, it’s an instruction to interact with the animation, other 
objects, or user actions. For example, a behavior can play or stop an animation, jump to a 
different point in the animation, change the state of an object, load a URL, or even execute 
JavaScript code. Unlike in LiveMotion 1.0, LiveMotion 2.0 behaviors are accessible as 
scripts. For information on behaviors, see “Working with behaviors” on page 134.

Movie clips A movie clip is an animation that plays independently of the main 
animation. For example, you can create a logo that revolves continuously, even when the 
main animation stops. The ability to nest smaller, self-contained animations within larger 
animations is one of the most powerful and flexible animation features within LiveMotion. 
Each movie clip has its own duration bar.

Creating simple animations
There are different ways to create an animation—for example, you can start with existing 
art or import Illustrator layers as artwork, or you can attach scripts, create rollovers, and 
work with movie clip groups. In general, however, creating an animation usually involves a 
number of common steps.

To create a simple animation:

1 Open the Composition window, and choose a size and frame rate for the animation. 
(See “Working with compositions” on page 15.)

2 Open the Timeline window. (See “Using the Timeline window” on page 97.)

3 If your composition needs to be a specific duration, drag the composition timeline’s 
end handle to the desired length. If you don’t know how long your composition will be, 
skip this step, and the composition’s length automatically adjusts to accommodate all 
objects within it. (For more information on both of these concepts, see “Setting the 
composition’s duration” on page 102.) 

4 Move the current-time marker to where you want the object to begin in the animation 
(often 0 seconds).

5 In the Composition window, Create or add the object you want to animate.

6 In the Timeline window, drag the start and end points of the object’s duration bar if you 
want to adjust when the object will begin and end in the animation. (See “Changing 
objects’ durations: explicit and implicit duration” on page 110.)

7 Move the current-time marker to the point from which you want to begin animating a 
change in the object’s property, then click the stopwatch to set an initial keyframe for that 
property. (See “Working with keyframes” on page 102.)

8 Move the current-time marker to the point at which you want to specify what the 
property is changing to, then change that property. (See “Creating keyframes” on 
page 103.)

9 In the Composition window, add any further objects, and make any additional changes.

10 Optimize the file, and choose export settings if, needed. (See “Optimizing your 
compositions” on page 143.)

11 Preview the file on a Web browser. (See “Previewing your compositions” on page 147.) 

12 Save the file. (See “Saving compositions” on page 17.)
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13 Export the file in SWF format for use on Web browsers. (See “Using the Export palette” 
on page 149.) 

Optimizing exported animations
A variety of factors affect the final file size of your exported animation, including the 
number of keyframes, the frame rate, and the types of changes applied to objects. For 
example, if you add a second layer to a vector object, LiveMotion converts the object to a 
bitmap when you export the file. For a one-inch square vector drawing, that would 
increase the object from a 52-byte vector object to an 807-byte bitmap object—an 
increase of over 1,500 percent.

For information on minimizing file size in your animations, see “Optimizing your composi-
tions” on page 143.

Using the Timeline window
You animate objects in a composition using the features available in the Timeline window. 
While the Composition window shows how the composition looks at any particular frame 
in the animation, the Timeline window lets you move the Composition window through 
time, displaying what the composition will look like at different points in the animation. 
Although you may have multiple compositions open, there is only one Timeline window, 
which reflects the currently active document.

To open the Timeline window:

Choose Timeline > New Timeline Window.

Timeline Window
A. Current time display B. Time interval C. Current-time marker  D. Duration bar  E. Object  
F. Object properties  G. Timeline window

The timeline window contains these major elements:

Current-time display. At the top left of the Timeline window is the current-time display. 
This indicates the location of the current-time marker in hours, minutes, seconds, and 
frames.

Timeline. Most of the Timeline window is taken up by the timeline itself. The timeline 
shows the lifetime of the animation, starting at 0 seconds on the left and continuing to the 
end on the right.

A B C
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Time intervals. Tick marks under the current-time marker represent seconds and frames 
in the animation. 

Current-time marker. At the top of the Timeline window is the current-time marker (the 
triangular marker with the red vertical line running through the timeline display). You can 
drag the current-time marker left or right to move the animation backward or forward in 
time. You must move the current-time marker to the desired point in time before adding a 
keyframe for an object property.

Time track Below the time interval tick marks is the time track, which displays the 
duration of objects (when they start and end in the animation) as well as key frames at 
which changes in the animation occur.

Objects and object properties. The left side of the timeline displays one row for each 
object or object property visible in the object hierarchy. Object rows contain the object’s 
duration bar. Property rows display keyframes that you have added for that property.

Using the timeline navigator
The timeline navigator displays the name of the highest-level timeline displayed in the 
Timeline window. Usually, this is the composition’s timeline. However, if you double-click a 
movie clip object or movie clip group’s timeline to display and work within that timeline, 
its name is displayed in the timeline navigator. You can use the navigator to move back up 
in the hierarchy to the composition’s timeline.

The timeline navigator and Step Out button

To move up using the timeline navigatior:

1 Do one of the following:

• From the pop-up menu, choose the higher-level timeline you want to move to.

• Click the Step Out button  next to the timeline’s name to move up one level in the 
movie clip hierarchy.

Using the object and property hierarchy list
The left side of the Timeline window contains a hierarchical listing of all objects in the 
current timeline, along with their properties. Objects are listed in their stacking order in 
the composition, with topmost objects listed first. If needed, you can resize the width of 
the object hierarchy panel.
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When you create or add an object in the Composition window, it is added to the Timeline 
window with a descriptive name, such as “medium blue ellipse.” This name changes if you 
change the color or shape of the object. You can rename objects at any time, in which case 
the name will no longer change. (See “Selecting objects with the Timeline window” on 
page 99.)

Object and property hierarchy list

You can expand or collapse the hierarchical listing to reveal or hide objects and their 
properties. There are three kinds of object properties:

• Transform includes transformation properties such as position, rotation, and scale. 
These properties are available for all objects.

• Object Attributes include additional properties specific to the selected object type 
(such as Font for a text object, for example).

• Layer lets you animate the properties of each layer in an object separately. These 
include layer-specific properties such as color, 3D effects, and distortions.

To expand or collapse the object and property hierarchy:

Click the triangle next to a timeline’s name or a property. 

To adjust the width of the object hierarchy panel:

Drag the resize bar located to the right of the Hide column , the Lock column  and the 
Shy column .

Selecting objects with the Timeline window
The Timeline window is particularly useful for selecting objects that are overlapping, small, 
or otherwise hard to select. For information on the other ways to select objects, see 
“Editing objects” on page 38.

To select objects with the Timeline window:

1 Do any of the following:

• Click the object’s name. 

• Shift-click object names to add or remove objects from the selection.

• Drag to select multiple object names.

• Click the object’s duration bar.
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• Click the gray track to the left or right of the duration bar.

Renaming objects in the Timeline window
Whenever an object is added to a composition, it is automatically added to and named in 
the Timeline window with a descriptive name, such as “light red rectangle.” This name 
changes if you change the color or shape of the object. You can rename objects at any 
time. In this case, the name will no longer change.

To rename an object in the Timeline window:

1 Click on the object name in the object hierarchy panel of the Timeline window.

2 Do one of the following:

• Press Enter.

• Choose Object > Edit Name.

3 Type a new name, and click OK.

Changing the stacking order of objects with the Timeline window
The stacking order refers to the front-to-back order of objects in the composition. New 
objects are created in front of older objects. The order of objects in the object hierarchy 
panel of the Timeline window reflects the stacking order of the objects in the compo-
sition. You can change the stacking order of objects by dragging them to a new level in 
the object hierarchy panel.

You can also change the stacking order of objects by using the Arrange commands (see 
“Stacking objects” on page 39). 

To change the stacking order of timelines by dragging:

In the Timeline window, drag the object’s name to another level. (You can move objects 
that are hidden or shy; you cannot move objects that are locked.

An indicator bar shows where the dragged object will be placed in relation to other 
objects in the Timeline window.

Showing, hiding, and locking objects
The Timeline window lets you control whether objects are displayed or editable:

• Hide lets you hide selected objects in the Composition window, while still displaying 
them in the Timeline window. It also turns off soundtracks and sounds associated with 
hidden objects. Hiding objects is useful when the composition is complex or objects 
are overlapping. It also speeds up processing for complex animations. 

Note: Hidden objects and sounds do not export. 

• Shy lets you hide selected objects in the Timeline window, while still displaying them in 
the Composition window. When an object is set to Shy and Shy is turned on, the object 
does not appear in the timeline. Shy is useful when you want the Timeline window to 
show only those objects you want to adjust. Shy objects still appear in the Composition 
window and can be edited there.

• Lock makes objects unselectable and uneditable in the Composition window and in the 
Timeline window. Lock is useful for protecting object from being accidentally edited, 
particularly in a crowded composition. 
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To hide or show objects:

1 Click in the Eye column  next to the timeline for that object. The icon changes from an 
eye icon (object is visible) to a blank square (object is invisible). 

To mark objects as shy:

Click the Shy button  next to the timeline for that object.

To hide or show all shy objects:

Click the Hide Shy Objects button  to the right of the sound button  at the top of the 
Timeline window.

To lock or unlock objects:

Click in the Lock column  next to the timeline for that object. The icon changes from an 
blank button (object is unlocked) to a locked button (object is locked).

Understanding the Keyframe column
To the right of the object hierarchy is a column displaying keyframe information for object 
properties. When you activate an object property, this column contains the following:

• A checkbox that allows you to set or remove a keyframe for the property. 

• Arrows that let you jump to the previous or next keyframe for that property. 

• A Scripts button  for attaching scripts to points in the timeline.

• A Labels button  for attaching labels to points in the timeline.

Using the playback and sound controls
The top left of the Timeline window contains playback and sound buttons for previewing 
your animation. In addition, sound objects have an associated sound icon in the keyframe 
column that lets you specify whether an individual sound plays. 

To use the controls:

Do any of the following:

• Click the Play/Pause button  to toggle between playing and pausing the animation.

• Click the Forward One Frame button  or the Backward One Frame button  to move by 
a single frame in the animation.

• Click the Beginning button  or the End button  to go to the beginning or end of the 
animation.

• Click the Sound button  to turn the sound on or off for all sounds in the animation.

• Click the Sound icon  in the eye column to turn a particular sound on or off.

Understanding the current-time display
The counter at the top left of the Timeline window shows the location of the current-time 
marker in hours, minutes, seconds, and frames. This is the convention used by the Society 
of Motion Picture & Television Engineers (SMPTE). For example, a display of 00:01:51:15 
indicates a point 1 minute 51 seconds and 15 frames into the animation. With a frame rate 
of 30 frames per second (fps), this would be 1 minute and 51.5 seconds. 
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The current-time display counts frames in single increments until it reaches a new second, 
then starts over at 0. Thus, if your frame rate is set to 12 frames per second, the current-
time display would advance from 00:00:00:11 to 00:00:01:00.

Zooming into and out of the timeline
You can zoom in and out of your timeline just as you can zoom in and out of your compo-
sition. When you zoom in to the timeline, you view a shorter duration in the window, 
making it easier to work with keyframes that are very close together. Zooming out allows 
you to see more of the timeline and is especially useful for an overview of object 
durations. 

Note: Although an object may look pixellated when zoomed above 100%, it may 
export to SWF as a vector. To see whether the object will export as a vector or a bitmap, use 
the Preview Export Compression command (see “Previewing your compositions” on 
page 147.) 

To magnify and reduce your view of the timeline:

Do any of the following:

• Click the zoom buttons ,  to zoom out or in, respectively. 

• Drag the zoom slider  to change the magnification.

Setting the composition’s duration
The length of the composition’s duration bar specifies how long the composition lasts as 
an animation, as opposed to how long the individual objects within it last. The start point 
of the composition’s duration bar, and thus of an animation, is at frame 0. Its duration is 
determined by the end point of the composition’s duration bar. 

To set the composition’s end point:

In the Timeline window, drag the end point of the composition’s duration bar to specify 
the time at which the composition ends.

Working with keyframes
Animation generally requires at least two keyframes. Change begins at the first keyframe 
and continues until it reaches the second keyframe. LiveMotion adjusts the values of a 
property at each regular animation frame to create a smooth transition from one keyframe 
to the next. 

However, scripts let you create animation by writing a script attached to a single keyframe, 
in response to a user’s or a server’s interaction. Animation can also be created using a 
single keyframe, an OnEnterFrame handler, and a label. (See the LiveMotion 2.0 Scripting 
Guide.)

A keyframe contains the following information:

• Which object property is changing.

• When the change occurs.

• The value of the object property being changed.

• The type of change (for example, smooth or abrupt) between the values at the 
previous, selected, and next keyframes. 
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You can create, move, copy, delete, and modify keyframes.

Creating keyframes
You can create keyframes for any property of any object at any point on the timeline. By 
changing one or more properties over time, you create an animated effect. For example, 
you can change the position, anchor point, and color independently at different points in 
the animation, by creating keyframes with different values for each of these properties. 

Once you’ve created a keyframe for a specific property, you can move the current-time 
marker and change the value of that property to create a new keyframe at the current-
time marker. If the current-time marker is at an existing keyframe for a property, changing 
the property alters the value for that keyframe.

To set the first keyframe for an object property using the stopwatch button: 

1 Expand the object hierarchy until you can see the property that you want to animate.

2 Move the current-time marker where you want to add a keyframe.

3 Click the stopwatch button  next to a property to activate it. An initial keyframe is set at 
the current-time marker.

4 Specify the value you want that property to have at that time. (Most of these properties 
are associated with palettes listed under the Window menu.)

For information on animating object properties, see “Animating object and layer 
properties” on page 107.

An object property keyframe

To add additional keyframes for an object property:

1 Expand the object hierarchy until you see the property that you want to animate.

2 Move the current-time marker to where you want to add a new keyframe.

3 Do one of the following:

• Change the value for the object property you are animating. A keyframe is automati-
cally added.
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• Click the empty checkbox in the keyframe column. This adds a keyframe without 
changing the value of the property, keeping the property the same between the two 
keyframes.

The keyframe box adds keyframes without changing property values.

To create keyframes using the New Keyframe commands:

1 Select the object for which you want to create a keyframe. (You can select multiple 
objects and create a new keyframe for each at the same time.)

2 Select the Timeline window. 

3 Choose Timeline > New Keyframe, followed by one of these commands, depending on 
the type of new keyframe you want to create:

• New Position Keyframe.

• New Rotation Keyframe.

• New Scale Keyframe.

• New Opacity Keyframe.

• New Anchor Point Keyframe.

Changing keyframe interpolation
Keyframe interpolation determines how values change from one keyframe to the next. 
You can apply one or more interpolation methods to any keyframe for most object 
properties. Some interpolation methods create abrupt changes or sharp angles in motion, 
while others provide a smooth transition and rounded curves. For example, by applying 
different interpolation settings to position keyframes, you can make an object decelerate 
as it drifts from the first keyframe to the second, and then make it quickly bounce off a 
third keyframe as it rounds a curve and speeds toward the final keyframe. 

To change the interpolation of a keyframe:

1 In the Timeline window, select one or more keyframes for a single object property. 

2 From the Timeline menu, choose one of more interpolation methods:

• Linear to change property values equally from one keyframe to the next. Linear 
keyframes create angled turns for position- based transformations and sharp transi-
tions for time-based transformations. For example, you might use this to show a ball 
bouncing of a wall.

• Auto Bezier (the default) to adjust property values to create curved motion or smooth 
transition from one keyframe to the next. This is useful for animating smooth 
movements, such as objects following a path.



Using Help | Contents | Index Back 105  

Help Animating Objects 

Using Help | Contents | Index Back 105  

• Hold Keyframe to create an abrupt change from one keyframe to the next. With Hold 
keyframe, there is no interpolation. For position-based transformations, the object 
holds its current position or property setting until it jumps to its new settings when the 
current-time marker reaches the next keyframe. For other transformations, the object 
property abruptly switches from one setting to the next at the next keyframe.

• Ease In to slow the transition rate approaching the keyframe. For example, you might 
use this to animate a car decelerating to a stop.

• Ease Out to slow the transition rate leaving the keyframe and gradually increase the 
transition rate. For example, you could use this to animate a car gradually speeding up.

Navigating and moving keyframes
Once an object property has been activated, the keyframe column displays a keyframe 
checkbox and previous keyframe and next keyframe arrows. These arrows move the 
current-time marker to the previous or next keyframe for that property of the selected 
object. 

The Previous Keyframe and Next Keyframe commands move the current-time marker to 
previous or next keyframe for the selected object, regardless of property. For example, 
suppose you have keyframes at one second and three seconds for position and at two 
seconds and four seconds for color. Choosing the Next Keyframe command would first 
move the current-time marker to the position property at one second, choosing it again 
would move the marker to the color property at two seconds, and so on.

To move the current-time marker to the previous or next keyframe:

Do one of the following:

• Click the left or right arrow  in the keyframe column to move to the previous or next 
keyframe for that property of the selected object

• Select the Timeline window, and choose Timeline > Previous Keyframe or Timeline > 
Next Keyframe.

To move a keyframe:

Drag the keyframe to a new position in the timeline. Multiple keyframes can be selected 
by Shift-clicking, and can then be moved as a group, maintaining their relative positions.

Reversing keyframes
You can reverse keyframes by dragging them. In addition, the duration bar enables you to 
reverse the position of all keyframes within the bar. For example, you might have made an 
object that changes from red to blue as it travels from left to right. By reversing the 
keyframes, the object will not change from blue to red and travel from right to left. 

To reverse a keyframe:

Drag the keyframe past another keyframe in the Timeline window.

To reverse keyframes with the duration bar:

1 Alt-drag (Windows) or Option-drag (Mac OS) one end of the duration bar past the 
other. The cursor changes to a double-headed arrow and stopwatch  when it is over the 
end of the duration bar.
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For example, assume the duration bar’s start point is at 2 seconds and its end point is at 6 
seconds (so that it is 4 seconds long). You can Option-drag the start point to 10 seconds, so 
that the keyframes are reversed, but the duration bar is still 4 seconds long. The duration 
bar is now in a new location in the timeline (starting at 6 seconds and ending at 10 
seconds).

2 Drag the duration bar from the middle to move it to the time you want in the timeline.

Using the previous example, you would drag (not Alt/Option-drag) the duration bar from 
the middle so that it again starts at 2 seconds and ends at 6 seconds, but with the 
keyframes now reversed.

Copying and pasting keyframes
You can copy and paste keyframes from one object to another, and even from one compo-
sition to another. The new keyframes are added to the object’s original ones. If the new 
keyframe is at the same frame as an existing one, the new keyframe’s value replaces the 
original keyframe’s value.

You can also duplicate keyframes within a property.

To copy and paste keyframes:

1 Select the keyframes you want to copy. Shift-click or shift-drag to select multiple 
keyframes, even from multiple properties of an object.

2 Choose Edit > Copy.

3 Select one or more objects to which you want to apply the keyframes. 

4 Choose Edit > Paste.

To duplicate keyframes within a property:

1 Select the keyframes you want to duplicate.

2 Alt-drag (Windows) or Option-drag (Mac OS) the keyframes to duplicate keyframes 
within that property.

Proportionally adjusting keyframes
You can use the duration bar to proportionally adjust the keyframes associated with it. For 
example, suppose you have an object that is 4 seconds in duration, with keyframes at 1 
second, 2 seconds, and 3 seconds. If you proportionally adjust the duration bar to make it 
8 seconds long, the keyframes stretch to 2 seconds, 4 seconds, and 6 seconds, respectively.

To proportionally adjust keyframes:

1 Alt-drag (Windows OS) or Option-drag (Mac OS) the start point  or the end point  of 
the duration bar. The cursor changes to a double-headed arrow and stopwatch  when it 
is over the end of the duration bar.

Deleting keyframes
You can delete any keyframe from the timeline. When you delete an interior keyframe 
(that is, neither the first nor last keyframe for a property), the value of the property at each 
of the affected regular animation frames is adjusted to create a smooth transition 
between existing keyframes.
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To delete a keyframe:

Do one of the following:

• Align the current-time marker with the keyframe that you want to delete. Click the 
checkbox in the keyframe column for that keyframe.

• Select a keyframe (Shift-click to select additional keyframe). Press Backspace (Windows) 
or Delete (Mac OS).

• To delete all keyframes for one object property, deactivate the object property by 
clicking its stopwatch icon in the object hierarchy. When you click the stopwatch icon 
to deactivate a property, keyframes for that property are removed, and the value of the 
property becomes the value at the current time. You cannot restore deleted keyframes 
by reselecting the stopwatch. 

Note: If you accidentally delete keyframes, choose Edit > Undo.

Animating object and layer properties
You can animate the Transform properties and Object Attributes properties, which apply 
to the entire object. You can also animate the Layer properties, which affect only 
individual layers of the object. For example, color is a layer property, and only applies to 
the selected layer.

Color is a Layer property, and affects only that layer

The Timeline window
A. Object property B. Layer property

The procedure for animating object properties and layer properties is basically the same.

A

B
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To animate an object or a layer of an object:

1 Create or place the object you want to animate. All objects in LiveMotion contain one 
or more layers, which you can animate.

2 Choose Timeline > Show Timeline Window to open the Timeline window.

3 Move the current-time marker to where you want the property to change.

4 Click the triangle to the left of the object’s name in the timeline to display the three 
main categories of properties you can animate: Transform, Object Attributes, and one or 
more Layer properties (depending on the number of layers in the selected object).

5 Click the triangle to the left of Transform, Object Attributes, or Layer (number) to display 
the properties you can animate.

6 Click the stopwatch button to activate the desired property.

7 Move the current-time marker to where you want to make the next change.

8 Edit or manipulate the object as necessary.

Once a property has been activated, any change to its values automatically creates a new 
keyframe where the change occurs.

9 Set the keyframe interpolation method if necessary. See “Changing keyframe interpo-
lation” on page 104.

Object properties can be animated to create special effects. For example, you can 
animate the position of an object so that it begins or ends off screen. You do this by 

either entering X and Y values in the Transform palette that exceed the dimensions of your 
composition, or by simply dragging the object off the composition (you may need to 
enlarge the Composition window to do this). You can also enter rotation values that 
exceed 360° to make an object rotate more than once, or you can animate an object’s 
anchor point while animating its rotation, creating a “tailspin” effect.

Removing all keyframes and changes from an animated 
object
The Clear Animation command removes all keyframes and changes from the selected 
object in the timeline. 

To remove the animation from a selected object:

1 Move the current-time marker to the point in the timeline where you want to freeze the 
object’s properties.

2 Choose Timeline > Clear Animation.

Working with motion paths
The motion path is a visual representation of the path an object follows during the course 
of an animation.
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Each dot on a motion path represents the object’s position at a frame of animation. 
Squares represent the object’s position at a keyframe. Because the frame rate is constant, 
the farther apart the dots or squares on a motion path are, the faster the object moves 
along the path.

The bottom arrow uses fewer frames (and thus, takes less time) to move the same distance.

You cannot edit a motion path directly. Instead, you do one of the following:

• Change the position of the object at an existing Position keyframe.

• Change the position of the object where no Position keyframe yet exists, creating a new 
Position keyframe in the process.

• Apply an interpolation method to a Position keyframe to alter the way the object moves 
into or out of that keyframe.

The motion path automatically reflects these changes.

To view or hide an object’s motion path:

1 In the Composition window, select the object whose motion path you want to view.

2 Choose View > Preview Motion Path.

To modify an object’s motion path:

1 In the Composition window, select the object whose motion path you want to modify.

2 Choose View > Preview Motion Path.

3 Do one of the following:

• To change the motion path at an existing Position keyframe, drag the current-time 
marker in the Timeline window to that keyframe. Then, in the Composition window, 
drag the object to the location you want it to be at that point in the animation. 

• To change the motion path with a new Position keyframe, drag the current-time marker 
in the Timeline window to the point in the animation where you want the object to be 
in another location. Then, in the Composition window, drag the object to the location 
you want. (See “Creating keyframes” on page 103.)

• To change the motion path with keyframe interpolation, select one or more Position 
keyframes for the object. Then choose an interpolation method from the Timeline 
menu. (See “Changing keyframe interpolation” on page 104.)
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Changing objects’ durations: explicit and implicit 
duration
The duration of an object or composition is determined by its start and end points. The 
start and end points mark the frames at which the object/composition appears and disap-
pears. When the animation reaches the object’s/composition’s start point, the object/
composition appears. When the animation reaches the object’s/composition’s end point, 
the object/composition disappears/stops.

The Implicit/Explicit button lets you switch between two types of duration for objects and 
the composition:

• An object with an explicit duration exists for the amount of time indicated by its 
duration bar in the timeline.

• An object with an implicit duration does not last a specific amount of time and so does 
not have a duration bar of a specific length. Instead, its duration is linked to the length 
of the composition, to the end handles of other objects, or to the position of its own 
keyframes. In other words, an object with an implicit duration remains visible in the 
composition for as long as necessary.

For information on making all keyframes associated with a duration bar move propor-
tionally to it, see “Proportionally adjusting keyframes” on page 106.

To set an object’s start and end points:

1 Select the object whose duration you want to change. (Shift-click to select multiple 
objects.)

2 In the timeline, drag the duration bar or the start and end handles at the ends of the 
duration bar to change the times at which the object appears and disappears from the 
animation.

• Drag the start handle  to change the object’s start time.

• Drag the end handle  to change the object’s end time.

• Drag the middle of the duration bar to change both the start and end times while 
maintaining the object’s duration.

The duration bar controls an object’s life span.

To specify whether an object’s duration is implicit or explicit:

Click the Implicit/Explicit Length button  at the bottom left of the Timeline window.

Optimizing the resolution and file size of bitmap objects
When an animation is played or saved, LiveMotion renders bitmap objects at screen 
resolution before applying transformations to them. This poses two potential problems:
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• If an animation scales up low-resolution images, results may be unacceptable. 

• If the image is much larger or at a higher resolution than you need, it is exported at that 
large file size, even though it will display at a smaller size. For example, suppose you 
had a 720-pixel by 720-pixel image (which would appear as a 10-inch by 10-inch object 
in your composition). Even if you displayed it only as a 1-inch by 1-inch object, the 
original, 10-inch by 10-inch, 720 pixel by 720-pixel image file would be exported and 
then displayed at the smaller size. 

The solution is to select the point in the animation at which you want the bitmap image to 
look its best, and then set that point as the render size for the image. LiveMotion will then 
render the object at screen resolution for this size, even if the object is smaller or larger at 
a different point in the animation. The benefit is that not only will the image still have a 
sharp image at the point you select, it will also export the image based on that size, greatly 
reducing the file size.

Result if render size is set at smaller size

Result if render size is set at larger size

To set the render size of an image:

1 In the Timeline window, set the current-time marker to the point in the animation 
where you want the object to look its best.

2 Select the image object, and choose Object > Transform > Make Actual Size.

Working with animated GIFs
The Time option in the Properties palette enables you to move from frame to frame of an 
animated GIF. This is useful if you want to animate the GIF image so that it slows down, 
speeds up, or goes backwards in time compared to how it ordinarily plays.

To work with an animated GIF:

1 Select the animated GIF.

2 In the Timeline window, move the current-time marker to a frame other than frame 0. 

3 Choose Window > Properties to display the Properties palette.
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4 In the Properties palette, enter different values for the Time option. Higher numbers 
move the GIF further forward in its animation.

Previewing animations
Except for the simplest animations, you should test your animation repeatedly, making 
adjustments as necessary. There are several ways to view an animation, but it is probably 
best to preview your animation first within the Timeline window. Once the animation 
seems to be working correctly, you can then use the Preview Mode or preview the compo-
sition in a Web browser for a final check.

For further options for previewing your animations, see “Previewing your compositions” 
on page 147.

Controlling playback
You control playback using the playback buttons. These buttons let you play the 
animation, move forward or backward a frame at a time, or move to the first or last frame 
of the animation.

Note: The Play button does not play animations inside movie clips. 

To preview the animation:

1 Move the current-time marker where you want the animation to start.

2 Click the Play button  in the Timeline window or the space bar on the keyboard to 
preview the animation.

The Play button changes to a Pause button , and the animation plays, starting at the 
position of the current-time marker.

3 To pause the animation, click the Pause button in the Timeline window or the space bar 
on the keyboard.

4 To move the current-time marker (which determines the frame you are currently 
viewing), click any of the remaining playback buttons:

• Click the First Frame button  to move the animation to the first frame in the compo-
sition time track.

• Click the Frame Backward button  to move the animation backward a single frame.

• Click the Frame Forward button  to move the animation forward a single frame.

• Click the Last Frame button  to move the animation to the last frame in the compo-
sition time track.

Previewing by scrubbing
Another way to preview your animation is with a technique called scrubbing. Scrubbing 
means dragging the current-time marker back and forth across the timeline. The faster 
you drag the current-time marker, the quicker the animation plays back. You can also stop 
at any point or drag backwards to see the animation in reverse.

To scrub the animation:

Do one of the following:

• To scrub regular objects, drag the current-time marker forwards or backwards.
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• To scrub movie clip groups as well as regular objects, Alt-drag (Windows) or Option-
drag (Mac OS) the current-time marker forwards or backwards. 

• To hear audio in the timeline while scrubbing, Ctrl-drag (Windows) or Command-drag 
(Mac OS) the current-time marker forwards or backwards.

Previewing using Preview mode or a Web browser
Because of differences between Web browsers and rendering considerations, it is a good 
idea to preview your animation outside of the Timeline window. This can be done within 
LiveMotion using the Preview mode, or in a browser using the File > Preview In command.

Using Preview mode or the Preview In command is the only way to preview interactive 
elements such as movie clips, rollovers, and scripts.

To preview your composition in LiveMotion:

1 Click the Preview Mode button  at the bottom of the toolbox or choose View > 
Preview Mode.

2 Move the cursor into the Composition window to load and run the animation.

3 Click the Edit Mode button  to exit the Preview mode.

To preview your composition in a Web browser:

1 Save your composition.

2 Choose File > Preview In and select a Web browser.

Note: It is best to preview all finished animations in both Netscape Navigator and 
Microsoft Internet Explorer, and on Windows as well as Mac OS, since different combina-
tions of browsers and platforms may display your animation differently.

3 When you are finished, exit your browser and return to LiveMotion.

Saving and placing animated objects to the Library
Once you have created an animation, you may want to save it for future use. You can save 
animated objects to the Library. Once saved to the Library, these objects can be placed 
into any composition at any time, and their animation will remain intact. See “Adding and 
deleting Library objects” on page 94.

To add an animated object to the Library:

1 Drag the object from the Composition window into the Library palette.

2 Name the object, and click OK.

To place an animated object from the Library:

Place the object in the composition by doing one of the following:

• Drag the object from the Library palette to the Composition window.

• Select the object in the Library palette, and click the Place button.
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Saving and applying animations as styles
Any animation that you add to an object is simply a set of instructions that are applied to 
the object when the composition is opened or when some trigger is applied (such as 
moving the cursor onto a rollover). Since these instructions are separate from the object 
itself, they can be stored as a style and applied to other objects at any time. In other words, 
animated styles are just like any other styles contained in the Styles palette, except that 
they contain animation instructions along with the rest of their style information. (For 
instructions, see “Using the Styles palette” on page 90.)

The position of the current-time marker is saved as part of the style. When you apply the 
style to an object, the position of the current-time marker when the style was created 
determines how the animation is applied to the new object. For example, if an animation 
changes the position of the object, and the current-time marker was at the beginning of 
the animation when the style was created, the object will start at its current location and 
move from there. If the style was created when the current-time marker was at the end of 
the animation, however, the object will end up at its current location after its animation 
plays.

Applying an animation style
A. Animation saved as a style. B. Target object. C. With current-time marker at beginning when 
style created, target object represents where animation starts from. D. With current-time marker at 
end when style created, target object represents where animation ends.

Working with sound
Except for sounds triggered by rollovers, all sounds exist solely in the timeline. If a sound is 
added to the composition using either the Place command or by adding a sound from the 
Sounds palette, the sound appears as an object in the timeline. Sounds can be added to 
movie clip timelines as well, by first opening the movie clip timeline and then dragging 
the sound into the Timeline window. In either case, the sound can be manipulated and 
animated in much the same way as you would any other object.

A B

C D
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Here are a few points to consider when working with sound:

• It’s a good idea to limit sound files to 16-bit sound, since the files are exported at no 
more than that. 

• Larger bit sizes, such as 24-bit sound, increase the size of the files and, consequently, 
take longer to download. Moreover, most sounds are compressed when used in a SWF 
environment, and sounds played as part of a Web page or Web animation are typically 
amplified by speakers that don’t replicate the quality possible in 24-bit sound.

• Event sound—that is, a sound that must be fully downloaded before it is can play—is 
useful for short sounds, small sound files, and sounds that will be played repeatedly 
(such as those attached to rollovers or that are looped for a background sound.

• Streaming sound— that is, a sound that can play while it is being downloaded—is 
useful for long sounds, large sound files, sounds that will play only once, or sound that 
needs to be synchronized to begin at a particular frame in an animation.

For more information on using sounds with rollovers, see “Attaching sounds to rollovers” 
on page 127.

Applying sounds
The Sounds palette lets you apply a sound to your composition either as part of an 
animation effect or in using a rollover. You can add your own sounds to the palette, or use 
the ones provided. For more on things to consider when using sounds with rollovers, see 
“Attaching sounds to rollovers” on page 127.

Sounds Palette
A. Play Sound button B. Apply button C. New sound button D. Trash E. Selected sound

To display the Sounds palette:

1 Choose Window > Sounds.

2 Choose a display option from the Sounds palette menu:

• Swatches View to display a scroll list of thumbnail examples of sounds.

• Preview View to display a scroll list of names of sounds with a large thumbnail for the 
currently selected sound.

• Name View to display a scroll list of names of sounds with a small thumbnail example of 
each.

To preview a sound using the Sounds palette:

1 Select a sound in the palette.

2 Play the sound:

A

E

B C D
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• Click the Play Sound button .

• Press Enter (Windows) or Return (Mac OS).

To apply a sound:

1 Select the element in the composition to which you want to apply the sound:

• To apply the sound to an animation, move the current-time indicator to a the time at 
which you want the sound to play. For more information, see “Working with sound” on 
page 114.

• To apply the sound to a rollover, select an object. Then use the Rollovers palette to 
select the object state that will trigger the sound. For more information on rollovers, 
see “About rollovers” on page 125. For information about attaching sounds not 
included with LiveMotion, see “Attaching sounds to rollovers” on page 127.)

2 Do one of the following:

• To apply sound using the Sounds palette, select the sound in the palette. (Press the Play 
Sound button  to hear the sound.

• To apply sound by dragging and dropping a sound file, open a folder or directory 
containing the sound file.

• To apply the sound by placing it, choose Edit > Place and select the sound you want to 
place.

3 Apply the sound:

• Click the Apply button  at the bottom of the Sounds palette.

• Drag the sound from the palette or folder into the Composition window or into the 
Timeline window to add it to the animation.

• Drag the sound from the palette or folder onto the rollover object in the Composition 
window.

• Click Open in the Place palette.

Adding sounds to the Sounds palette
You can add sound files created in other applications to the collection of sounds provided 
in the Sounds palette. Adobe LiveMotion supports most common sound formats, 
including AIFF and WAV.

To add a sound to the palette by dragging a sound file:

1 Open a folder or directory containing the sound file.

2 Make Adobe LiveMotion the active application.

3 Drag the sound file onto the Sounds palette.

4 Enter a name for the sound, and click OK.

A copy of the sound file is saved as a sound and placed in alphabetical order in the list of 
available sounds.

To add a sound to the palette by placing it in the Sounds folder:

1 Open a folder or directory containing the sound file.

2 Drag or copy the sound file into the Sounds folder located in the Adobe LiveMotion 
folder.
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The sound is placed in alphabetical order in the list of available sounds the next time you 
start Adobe LiveMotion.

To add a sound in the composition to the palette:

1 Choose Timeline > Show Timeline Window or Window > Timeline to display the 
Timeline window. (For more information, see “Using the Timeline window” on page 97.)

2 Select the sound in the Timeline window. If the sound is attached to a rollover, select 
the rollover state in which the sound occurs, double-click the rollover in the Timeline 
window, and then select the sound in the Timeline window. 

(For more information on rollovers, see “Creating basic rollovers” on page 125.)

3 Click the New button  on the Sounds palette.

4 Enter a name for the sound, and click OK.

The sound is placed in alphabetical order in the list of available sounds.

To replace a sound:

Add a sound, but name it the same as an existing sound.

To delete a sound from the Sounds palette:

1 In the Sounds palette, select the sound you want to delete.

2 Click the Trash button .

Setting and animating sound properties
Once you’ve attached a sound file to the timeline or a rollover, you can set its properties 
and animate it.

To set sound properties:

1 In the Timeline window, select the sound you want to work with.

2 In the Properties palette, change the Pan and Volume settings.

• Pan shifts the stereo signal between the left and right channels.

• Volume controls how loudly or softly the sound plays. Higher values result in louder 
sound.

3 In the Properties palette, select whether the sound will be an event sound or a solo 
event sound.

• Event Sound downloads the sound completely before playing it, but stores the sound in 
memory so that it can be reused.

• Solo Event Sound sets the sound as an event sound, but sets a flag to stop playing all 
other instances of this sound (not other sounds) when the sound is played. This 
prevents a chorus of beeps, for example, if a button is clicked several times in a row.

• Streaming sound downloads and plays the sound as it occurs in the animation, rather 
than waiting for the entire sound to download before it begins playing. This option is 
useful if you have large sound files that you don’t want users to wait for before playing.

To animate sound properties:

1 In the Timeline window, expand the sound you want to animate.

2 Expand the Object Attributes heading.
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3 Move the current-time marker where you want the sound property (pan or volume) to 
begin.

4 Click the Pan or Volume stopwatch to activate that sound property.

5 Move the current-time marker to another point in time.

6 In the Properties palette, change the Pan or Volume (whichever property you are 
animating) settings for the sound.

Animating groups
Grouped objects can be animated in the timeline in much the same way that individual 
objects can be. The following rules apply:

• With a group, you are limited to animating only properties that can logically be applied 
to the entire group, such as position and rotation. 

• You can animate the individual objects that comprise the group.

• If objects in the group are animated, their individual animations run along with the 
group animation. For example, letters in a title could rotate individually while the whole 
title moves around the screen.

• Instead of being listed individually as part of the composition, individual objects within 
a group are listed as “subheadings” under the grouped object. Clicking the group’s 
triangle displays the individual objects that make up the group, as well as the 
properties of the grouped object. Therefore, even if you don’t want to animate a group, 
grouping objects is an excellent way to organize the Timeline window.

To group objects in the timeline:

1 Select all objects that you want included in the group.

2 Do one of the following:

• Choose Object > Group.

• Click the Group button  in the Timeline window.

To animate a grouped object:

1 Select the grouped object in either the Composition window or in the Timeline 
window.

By default, grouped objects are named “Group of x objects”. As with objects, grouped 
objects can be renamed. 

2 Expand the grouped object to see the Transform and Object Attribute headings for the 
group, and for each object within the group.

3 Animate any group property, or expand an object heading and animate an object or 
layer property.

Animating masks
Animating a mask is a simple but dramatic effect. Any object can be used as a mask to 
reveal any other object. See “Making group masks” on page 55.
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The masking object should be a geometric object or a path shape that will export as a 
vector. For example, applying a double-burst gradient to a mask will cause it to export as a 
bitmap and will not apply correctly to the underlying object.

Tip: Use the Preview Export Compression command to verify whether the mask will be a 
vector when exported.

To animate a mask:

1 Select both the masking object and the object it will reveal, and then choose 
Object > Group.

The text will be used as a mask for the underlying bus image.

2 Choose Object > Top Object Is Mask.

3 In the Timeline window, expand the new Timeline object, “Masked group of 2 objects.”

4 Expand the mask object, and animate the mask as desired.

Animating the position of the masking object

Working with movie clips
A movie clip is an animation, or interactive object that plays or functions independently of 
the composition animation. For example, you might want a logo to rotate continuously 
even after the main animation finishes. You might also want to have an object’s animation 
play only when triggered by a user’s action, such as clicking a button. Movie clip anima-
tions are also referred to as nested animations or character animations, and were called 
time-independent animations in LiveMotion 1.0. You create them by making an object or 
group a movie clip, and then creating an animation within the movie clip’s timeline. 
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Initially, the Timeline window contains only one timeline: the composition timeline. All 
objects in the composition timeline are animated when the composition animation plays. 
However, each movie clip object or group has its own timeline. A movie clip is a single 
object, whereas as movie clip group can contain additional objects. (A regular group does 
not have its own timeline.)

To make an object a movie clip or change a movie clip back to a non-movie clip 
object:

1 Select the object in the Timeline window.

2 Do one of the following:

• Choose Object > Movie Clip.

• Click the Make Movie Clip button  in the Timeline window. 

An icon  appears next to the object name in the object hierarchy when the object is a 
movie clip.

Movie clip timeline

To open a movie clip’s timeline:

Double-click the movie clip’s name in the Timeline. Other objects in the composition are 
automatically dimmed.

To close a movie clip’s timeline:

Do one of the following:

• To move up one level in the hierarchy, click the Step Out button  next to the name of 
the current timeline.

• To move up any number of levels in the hierarchy, select the name of the current 
timeline and choose the timeline you want from the pop-up list.

Timeline pop-up menu
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Animating movie clips
Movie clips are animated by making an object a movie clip, opening the movie clip’s 
timeline, and then animating properties within the object’s timeline. The following rules 
apply:

• Object Attribute and Layer properties are contained within an object’s timeline; Trans-
formation properties are not. This means that position, rotation, scale, and other trans-
formation properties cannot be animated for the movie clip whose timeline you have 
open. 

• You can animate the movie clip’s transformation properties from the timeline of the 
animation that contains the movie clip. For example, you could create a set of movie 
clip buttons, and have the buttons fly into place as part of the composition animation.

• You can animate any properties (including transformations) of objects contained within 
the movie clip group. For example, if you have a group of text objects (letters) grouped 
together to form a title, and if you make the group a movie clip, you can animate the 
position of the group as part of the containing animation (usually the composition), but 
the group’s position cannot be animated independently. The position of individual 
letters (each of which is an object in the movie clip group) can be animated indepen-
dently. Thus, the title could slowly move up the screen (as part of the composition 
animation) while the letters scramble themselves and reform into the title over and 
over (as a looping movie clip).

Movie clip in the composition’s timeline and in its own timeline

To animate a movie clip or movie clip group:

1 Open the timeline of the movie clip or movie clip group.

2 Expand the Object Attributes or Layers properties for the movie clip or group, and 
animate as desired.

3 If you are working on a movie clip group, expand any objects in the group to access and 
animate their Transformation, Object Attribute, or Layer properties.
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Creating movie clip groups
The Make Movie Clip Group command/button groups one or more selected objects and 
makes them a movie clip with a single command/button. This is equivalent to choosing 
the Group command or Group button followed by the Movie Clip command or Movie Clip 
button.

Note: You can create a group from a single object. This allows you to make the group 
movie clip and then animate the Transformation properties of the object within the group. 
This is the only way to create transformation-based movie clip animations of single 
objects.

To create a movie clip group:

1 Select the object or objects that you want to include in the movie clip group.

2 Do one of the following:

• Choose Object > Make Movie Clip Group.

• Click the Make Movie Clip button  in the Timeline window. 

If the object is already grouped (using the Object > Group command or Group button on 
the Timeline window), you can simply choose Object > Movie Clip or click the Movie Clip 
button on the Timeline window to make it a movie clip group.

Movie clip group as listed in the Timeline window

Looping animated movie clips and movie clip groups
You can make a movie clip or movie clip group repeat over and over with the Loop 
command or Loop button.

To make an animation play continuously:

1 Select a movie clip or movie clip group.

2 Do one of the following:

• Choose Timeline >Loop.

• Click the Loop button  located at the bottom right of the Timeline window.

Working with labels
The Labels button in the timeline lets you add a label to any point in the animation. Labels 
are references that scripts point to. For example, you could create a label called “Stop” and 
place it three seconds into an animation. You could then create a script that looks for that 
label in order to stop the animation at that point. For information on scripts, see “About 
scripts” on page 136.
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When a label is added to the timeline, the label column displays previous and next arrows, 
which function the same as the ones used for keyframes (moving the current-time marker 
to the previous or next label in that timeline).

To add a label to an animation:

1 Display the composition timeline or movie clip timeline to which you want to add the 
label.

2 Move the current-time marker to the point where you want to add the label.

3 Click the Labels button  in the Timeline window.

4 Enter the name you want to give the label, and click OK.

5 The label appears in the timeline.

To duplicate a label within a timeline:

1 Select the label you want to duplicate (Shift-click to select additional labels, if desired.)

2 Alt-drag (Windows) or Option-drag (Mac OS) the label to create duplicates within the 
timeline.

To rename a label:

1 Open the label:

• Double-click the label in the timeline.

• Move the current-time marker to the label and click the Labels button .

2 Enter the new name and click OK.

To delete a label:

1 Select a label (Shift-click to select additional labels). 

2 Press Backspace (Windows) or Delete (Mac OS).

To move the current-time marker to the previous or next label:

Click the left arrow  or right arrow  in the labels column.

To move a label:

Drag the label to a new position in the timeline. (Shift-click to select multiple labels, and 
then drag to move them as a group, maintaining their relative positions.)

Working with script keyframes
The Scripts button in the keyframe lets you add a script keyframe to any point in the 
animation. For information on scripts, see “About scripts” on page 136.

To add a script keyframe to an animation:

1 Display the composition timeline or movie clip timeline to which you want to add a 
script keyframe.

2 Move the current-time marker to the point at which you want the script keyframe to 
occur.

3 Click the Scripts button  in the Timeline window to display the Script Editor window.

4 Create the script as described in the Adobe LiveMotion 2.0 Scripting Guide.
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To duplicate a script keyframe within a timeline:

1 Select the script keyframe you want to duplicate (Shift-click to select additional script 
keyframes.)

2 Alt-drag (Windows) or Option-drag (Mac OS) the script keyframe to create duplicates 
within that timeline.

To edit a script keyframe from the timeline:

1 Open the script keyframe:

• Double-click the script keyframe icon  in the timeline.

• Move the current-time marker to the script keyframe and choose Scripts > Script Editor.

2 Edit the script as described in the Adobe LiveMotion 2.0 Scripting Guide.

To delete a script keyframe:

Select a script keyframe (Shift-click to select additional script keyframes). Press Backspace 
(Windows) or Delete (Mac OS).

To move the current-time marker to the previous or next script keyframe:

Click the left arrow  or right arrow  in the script keyframes column.

To move a script keyframe in the timeline:

Drag the script keyframe icon  to its new location on the timeline.

Saving and exporting animations
As you create an animation, you should save it in LiveMotion file format (.liv) so that you 
can continue working on it. However, to use the animation in a Web page, you must 
export it to a Web animation format. 

To export the animation:

1 Do one of the following:

• If the composition has animations and no interactivity (that is, no rollovers or scripts), 
you can export it as animated GIF, QuickTime, or SWF.

• If the composition has animation and used the States palette to create animated 
rollovers, you can export it using AutoLayout or SWF.

• If the composition has animation, interactivity, and static images, it is probably best to 
export it as SWF.

For information on exporting an animation in each of these formats, see “Specifying the 
export settings for the file type” on page 154.
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Chapter 11: Making Objects 
Interactive

he best way to make a Web site more compelling is to increase the quality of inter-
action for the viewer. LiveMotion has many different ways to do this, from ready-
made styles, to animated rollover effects, to image maps, and scripting.

About rollovers
A rollover is an object that changes in response to interacting with the mouse. For 
example, a rollover could be a button that changes from red to green as the mouse moves 
over it, and then makes a sound and changes to an indented shape when clicked.

A remote rollover is an object that causes a change elsewhere in the composition in 
response to the mouse. For instance, moving the mouse pointer down a list of menu items 
on the left side of a Web page could make pictures of those items appear on the right side 
of the page. 

Although the mouse is the most common way to trigger changes in rollovers, the changes 
can also be triggered by keyframes in an animation or by scripts.

One of the key features of LiveMotion is its ability to create these interactive Web page 
elements.

Creating basic rollovers
To make an object into a rollover, you must add other states to it with the States palette. A 
state refers to the type of event that will trigger the change in the object. For example, 
adding an “over” state triggers a change in the rollover when the mouse is over it.

Here are some things to note about rollovers:

• By default, objects with more than one state are automatically turned into movie clips. 
Each state of a movie clip exists as a variation on the original (Normal) state. See 
“Working with movie clips” on page 119.

• Rollover states are triggered by basic mouse actions. The “normal” (default), “over,” 
“down,” and “out” states are all rollover states.

• Custom states are states that are not triggered by basic mouse actions. Instead, they are 
triggered by another object’s state, or by a state-change script. 

• Once you have created a rollover effect that you like, you may want to save it for future 
use. As with other types of objects, you can save rollovers to the Library, and their 
rollover effects will remain intact. (See “Adding and deleting Library objects” on 
page 94.)

To create a basic rollover:

1 Select the object.

T

bbaeck
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2 If necessary, choose Window > States, or click the States tab to display the palette.

3 Click the New State button  at the bottom of the palette. 

By default, the over, down, and out states will be assigned to new states. If these rollover 
states already exist, the new state will be a custom state.

4 Choose the type of state you want from the pop-up menu:

• Normal is the default state for the object.

• Over is triggered when the mouse pointer is over the object.

• Down is triggered when the mouse pointer is over the object and the mouse button is 
clicked or pressed.

• Out is triggered when the mouse pointer moves off of the object.

• Custom State lets you create your own custom rollover states. These are used for 
remote rollovers and other effects. If you choose this option, name the state in the 
dialog box that appears.

Note: In addition to using the New State button, you can use the Duplicate State button  
to create a new state based on the currently selected state.

5 Select the rollover state that you want to modify.

6 Apply changes to the rollover object to change its appearance. For example, you can 
apply a new texture, color, layer effect, or sound.

Changes you make to the rollover appear in a Changes list beneath the selected state in 
the States palette.

Note: You can click the triangle next to the Changes heading to display a list of the 
changes for that state.

Editing rollovers
When you modify the appearance of a rollover’s state, the changes you make are listed 
under that state in the States palette. You can expand this change list to see what changes 
have been applied to the state. You can also modify or delete any of these changes.

The normal state defines the object. Other states are defined by their differences from the 
normal state. This makes it easy to edit a rollover after you've made it a rollover—any 
changes you make to the Normal state are added to all the other states as well. On the 
other hand, any changes you make to another state are applied only to that state.

 If you need to make many changes to the Normal state but want to leave the other 
states as they are, temporarily swap the normal state with one of the other states, edit 

the state, and swap it back. 

To make and delete changes to a rollover state:

1 In the States palette, select the state that contains the change you want to edit. 

2 To view a list of changes made to the state, expand the Changes heading for that state.

3 Do one of the following:

• Edit the object.
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• To delete a change, select it from the Changes list and click the Delete button  at the 
bottom of the States palette to delete the change.

Attaching sounds to rollovers
To provide auditory as well as visual feedback, you can attach sounds to the different 
states of a rollover. Sounds can only be applied to states other than the normal state. They 
are played when that state is activated (for example, a sound that plays when a button is 
clicked). You can apply a sound from the Sounds palette, or you can attach an external 
sound file.

Note the following:

• If you apply a sound to a rollover state with the States palette, the sound only appears 
in the Changes list for that state.

• If you add a sound to the timeline of a multi-state movie clip group, it appears in the 
timeline of each state, but is only audible in the state they were added to. The Changes 
list displays whether the sound is audible.

For more information on the Sounds palette and how to use it to attach sounds to 
rollovers, see “Applying sounds” on page 115. For information on sounds in animations, 
see “Working with sound” on page 114.

To attach an external sound to a rollover’s state:

1 Select the object in the Composition window.

2 Select the state in the States palette.

3 Click the Sound button  in the States palette.

4 In the LiveMotion: Add Rollover Sound dialog box, locate and select the desired sound, 
and click Open.

Attaching behaviors and other scripts to rollovers
You can attach scripts to the different states of a rollover. (These scripts can include the 
behaviors available in LiveMotion 1.0). The scripts are played when that state is activated. 
For instance, you can attach a script to load and play a movie when one button is clicked, 
and another behavior to stop the movie when another button is clicked. 

For information on behaviors, see “Working with behaviors” on page 134 and the Adobe 
LiveMotion 2.0 Scripting Guide.

For information on scripts, see “About scripts” on page 136 and the Adobe LiveMotion 2.0 
Scripting Guide.

To attach a script to a rollover’s state:

1 Select the object in the Composition window.

2 Select the state in the States palette.

3 Click the Edit State Script button  in the States palette.

4 Use the Script Editor to create script you want, as described in the Adobe LiveMotion 2.0 
Scripting Guide.
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Saving and placing rollover objects
Once you have created a rollover effect that you like, you can save it for future use. As with 
other types of objects, you can save rollovers to the Library, and their rollover effects will 
remain intact. (See “Adding and deleting Library objects” on page 94.)

Saving and applying rollover styles
You can save an object that has a layer-based rollover effect applied to it to the Styles 
palette, if you select the Layer Animation/States checkbox in the New Style dialog box. The 
rollover effect is saved as part of the style, and can be applied to any object in your 
composition. If you have created object-based rollovers, a checkbox for that is active as 
well.

For information on how to save rollovers to, and apply them from the Styles palette, see 
“Using the Styles palette” on page 90.

Creating remote rollovers
Remote rollovers are interactions between multiple objects. They are triggered by one 
object (the trigger object), but affect one or more other objects (the target objects). The 
trigger object usually has a rollover state (over, down, or out) that is triggered by a user’s 
mouse. The target objects have custom states that are linked to rollover states on the 
trigger object. For example, moving the mouse cursor over the trigger object (such as a 
menu button) would switch the object to its over state, which would trigger all the states 
it’s linked to in the target objects (such as names of menu choices).

You must prepare your target object before using it in a secondary rollover effect. You do 
this by creating a custom state for the target object, and then modifying this custom state.

To create a remote rollover:

1 Create an object to act as the trigger for the remote effect, and a second object to act as 
the target.

Trigger object and target object

2 Select the target object.

3 Use the States palette to create a custom state for the target object. 

This state will represent what the target object will look like when the trigger object is 
triggered. For instance, you could create a custom state called “yellow” if the target object 
is to change from purple to yellow when triggered by the trigger object. For more infor-
mation on custom states see “Creating basic rollovers” on page 125.
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4 Modify the target object to how you want it to appear in the new custom state. Using 
the previous example, you could change the target object to yellow.

Target object with custom state applied

5 Create additional custom states for the target object, if desired.

6 Select the trigger object.

7 Create a new rollover state for the trigger object, such as Over or Down, to react to the 
user’s mouse action. For instance, if you wanted the target object to turn yellow when the 
mouse clicked on the trigger object, you’d choose Down for the new state of the trigger 
object.

8 With the new state of the trigger object selected, drag the targeting icon  for this state 
onto the target object. You can tell the target object is selected when its selection border 
appears.

Dragging the target icon onto the target object.
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The target object is added to the description of changes to the state of the trigger object.

9 Use the State pop-up menu to select the target object state you want activated by the 
trigger. Again, if you wanted the target object to change to the state you named “yellow,” 
choose “yellow” from the pop-up menu.

Setting the target object’s state

10 To make the target object return to its normal state after being activated by the 
trigger, select the normal state of the trigger object, drag the target icon onto the target 
object, and use the State pop-up menu to select the normal state of the target object.

Creating animated rollovers
You can create sophisticated rollover effects by animating the different states of the 
rollover. For example, you can create a rollover button that pulses with color while the 
mouse is over it, or that spins when clicked. 

You create animated rollovers by creating the animation within the rollover’s timeline, 
rather than within the composition’s timeline. Adding a state to an object automatically 
makes that object a movie clip as well as a rollover, so you can create the animation with 
the object’s timeline. However, to include a transformation (such as changing the rollover’s 
position or rotating it) in an animation, you must make the rollover a movie clip group. 

For information on movie clip timelines and movie clip groups, see “Working with movie 
clips” on page 119.

To create a basic animated rollover:

1 Choose Window > Timeline or Timeline > Show Timeline Window to display the 
Timeline window.

2 Select the object in the Composition window or in the Timeline window.
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3 In the States palette, select or create a state that for the animation.

Selecting a state for the animation

Notice that the Timeline window names both the rollover and its currently selected state.

4 Double-click the rollover’s name in the Timeline window to open up its timeline.

5 Create a short animation using the Object Attributes or the Layers properties.

Animating properties in the Timeline window

Note: If you want the animation to loop continuously while the rollover state is active, 
click the Loop button in the lower left corner of the Timeline window.

To create a transformation-based animated rollover:

1 Choose Window > Timeline or Timeline > Show Timeline Window to display the 
Timeline window.

2 Select the object you want to work with in the Composition or Timeline window.

3 Choose Object > Group.

4 In the States palette, select or create a state for the animation.

Notice that the Timeline window names both the object and its currently selected state.
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5 Double-click the rollover’s name in the Timeline window to open up its timeline.

6 In the Timeline window, expand the rollover to display the Transform, Object Attributes, 
and Layer properties.

7 Create a short animation by modifying any of these properties, including transfor-
mation properties, such as scale, or opacity.

Animating transformation-based properties in the Timeline window

Creating linked images and image maps
Any object you create in LiveMotion, including a rollover, can be linked to a Web page 
address, called a Uniform Resource Locator (URL), transforming the object into a button 
that links the user to another Web page. An image map is an image on a Web page that 
contains multiple links. Areas of an image map, called hotspots, link to various URLs. 

For example, you could create an image map of an office floor plan. Clicking any office in 
that image could take users to a Web page about the person in that office.

It’s worth noting the following:

• You create image maps in LiveMotion by first attaching links to individual objects. Then, 
using the Make Page option, you export the objects as a single image. LiveMotion 
generates the HTML code for the image map. You can then open the HTML page and 
copy and paste the HTML code into the source of your Web-page design application. 
(See “Inserting HTML into compositions” on page 161.)

• LiveMotion creates client-side image maps, in which the links are interpreted by the 
browser itself. Unlike server-side image maps, client-side image maps don’t need to 
contact the server to function, and thus are significantly faster to navigate.

• You can open the resulting pages in Adobe GoLive and edit them there.

To link an object to a URL and create an image map when exporting as autosliced 
HTML: 

1 Select the object to which you want to assign a URL. 

2 Choose Window > Web to display the Web palette.
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3 Enter a URL in the URL text box.

Entering a URL

4 Repeat steps 1 through 3 for additional objects you want to use as an image map.

5 Select AutoSliced from the Export palette Format menu.

6 Export the composition with Make Page selected <<TBD>>. 

LiveMotion exports the image files and creates an HTML page with the client-side image 
map. 

Note: If you overlap objects in creating an image map, the topmost object is the active 
hotspot in the overlapping area.

To link a rollover to a URL when exporting as autosliced HTML: 

1 Select the rollover to which you want to assign a URL. 

2 Choose Window > Web to display the Web palette.

3 Enter a URL in the URL text box.

4 Repeat steps 1 through 3 for additional rollovers to which you want to assign URLs.

5 Select AutoSliced from the Export palette Format menu.

6 Export the composition with Make Page selected. 

LiveMotion exports the image files and creates an HTML page with JavaScript rollover 
actions. 

Note: Avoid applying URLs to overlapping rollovers. This can result in errors when you 
export the files.

To link an object or rollover to a URL when exporting as SWF: 

1 Select the object or rollover to which you want to assign a URL. 

2 Choose Window > Web to display the Web palette.

3 Enter a URL in the URL text box.

4 Repeat steps 1 through 3 for additional objects you want to link to a URL.

5 Select SWF from the Export palette Format menu.

6 Export the composition with Make Page selected if you want to view the object or 
rollover at the same resolution at which you made it. 

LiveMotion exports the SWF file. If Make Page was selected, LiveMotion makes an HTML 
page with the SWF file imbedded in it. 

Note: If you overlap objects in creating an image map, the topmost object is the active 
hotspot in the overlapping area.
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Working with behaviors
Behaviors are specific commands that are executed when an animation reaches a certain 
point in time, when the user interacts with a rollover (such as clicking a button), or when 
they are called in a script. Behaviors can do anything from playing or stopping an 
animation, to downloading a movie, to calling a JavaScript function.

Note the following:

• In LiveMotion 2.0, behaviors are created with scripts and are listed in the Script Editor. 
(In LiveMotion 1.0, behaviors were created in the Behavior palette.) For information on 
how to create behaviors with scripts, see the Adobe LiveMotion 2.0 Scripting Guide.

• For information on attaching behaviors and other scripts to an animation, see“Working 
with script keyframes” on page 123.

• For information on attaching behaviors and other scripts to a rollover, see “Attaching 
behaviors and other scripts to rollovers” on page 127.

The following behaviors are available:

Control behaviors. Play and Stop are the simplest behaviors; they simply play or stop a 
specified animation. For example, a set of Stop behaviors added to the first frame of the 
composition timeline could stop all independent animations from playing when the main 
(composition) animation plays. Separate Play behaviors could then be added to timelines 
or to object states to run individual independent animations as needed.

Navigation behaviors. Behaviors can also be used to add navigational control to an 
animation or to objects. This navigation can be internal (moving forward or backward in 
an animation) or external (moving to a different Web site or Web page, perhaps to run 
additional animations). The internal animation control behaviors add flow control to what 
would otherwise be a sequential animation. The behaviors that can be used as navigation 
controls are the Go to Label, Go to Relative Time, and Go to URL behaviors:

• Go to Label moves the animation to a specific labeled behavior event in any timeline.

• Go to Relative Time moves the animation forward or backward a specified number of 
keyframes.

• Go to URL opens a specified URL in the user’s browser window.

Other behaviors. In addition to control and navigation behaviors, LiveMotion also offers 
several behaviors that perform very specific functions, and one multi-purpose behavior. 
The special-purpose behaviors are Load Movie, Unload Movie, Wait for Download, Stop All 
Sounds, and Change State. The multi-purpose behavior is Run JavaScript:

• Load Movie loads and plays a Flash format (.swf ) file that can either replace the existing 
animation or play on top of the existing animation.

• Unload Movie removes an already-loaded .swf file from the screen.

• Wait for Download creates a looping animation that repeats until the specified object 
has been downloaded. This prevents poor performance for animations that include 
large objects, or for lengthy and complex animations. This behavior is used to 
download animation files for playing; it is not used for downloading files in the broader 
sense of saving files to disk.

• Stop All Sounds stops all sounds in the composition, including event sounds.

• Change State changes the state of a rollover.
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• Run JavaScript executes JavaScript code, which you have entered in the Edit Behaviors 
dialog box.
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Chapter 12: Scripting
ripts enable you to efficiently create or change the behavior of LiveMotion. 

About scripts
Scripts are a powerful way to create or change the behavior of a LiveMotion file. A script is 
a programmatic way of controlling objects in a composition by using loops, mathematical 
functions, and other conditional logic such as “if/then” statements. Scripting for 
LiveMotion is object-oriented and uses JavaScript as the programming language.

There are two types of scripts that you can use:

• A player script is a set of instructions embedded in a LiveMotion composition. When the 
composition is exported as an SWF file, any player scripts in the composition are 
included. (Player scripts are not included in any other export format.) A player script 
tells the file and the Macromedia Flash Player what to do. It is interactive and differs 
from an automation script in that it represents actions that generally cannot be done 
through LiveMotion’s user interface. For example, you could use a player script to create 
a ping-pong game in which the user’s interaction could not be predicted. You could not 
do this with an automation script, because you couldn’t predict the direction of the ball 
ahead of time and so couldn’t create keyframes for every possible position of the ball 
and the player’s paddle.

• Automation scripts and Live Tabs affect the active composition. An automation script 
lets you do repetitive or complex tasks in an active composition. Although you can do 
these actions through the LiveMotion user interface, application scripts let you perform 
numerous instructions automatically and add conditional logic for how the instructions 
are performed. A Live Tab is simply an automation script that has a user interface 
attached to it. Live Tabs appear as a palette or dialog box. For example, a Live Tab could 
be an automation script with a palette that lets you draw a 12-point star shape or 
perform a batch of commands on selected objects. 

Creating scripts
To create a script, you use the Script Editor. For information on creating scripts, see the 
LiveMotion 2.0 Scripting Guide. For information on creating automation scripts and Live 
Tabs, see <<Name of document TBD>>.

Using pre-made automation scripts and Live Tabs
Adobe LiveMotion comes with a set of pre-made automation scripts and Live Tabs that 
you can use with your LiveMotion compositions.

<<TBD: Whether Dialogs will be included, too.>>

S

bbaeck
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To use a pre-made automation script:

Choose Automation > Scripts, followed by the name of the automation script you want to 
apply.

To use a Live Tab:

1 Choose Automation > Live Tab, followed by the name of the Live Tab you want to use.

2 Use the options in the Live Tab to modify your composition.

To add an automation script or Live Tab to the menu:

1 Open the folder or directory containing the automation script file or Live Tab file.

2 Drag or copy the file into the Scripts folder or Live Tabs folder located in the Automation 
folder within the Adobe LiveMotion folder.

3 Do one of the following: 

• Choose Automation > Refresh.

• Restart LiveMotion.

The automation script or Live Tab appears in alphabetical order in the Scripts menu or Live 
Tabs menu as appropriate.

To temporarily load a Live Tab for use:

1 Choose Automation > Load Live Tab.

2 Locate the Live Tab and click Open.

You can use the Live Tab, but it is not added to the Live Tabs menu.

To temporarily load an automation script for use:

1 Choose Automation > Run Automation Script.

2 Locate the automation script and click Open.

You can use the automation script, but it is not added to the Scripts menu.

To reapply the most recent automation script you’ve used:

Choose Automation > Run Last Automation Script.
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Chapter 13: Exporting 
Compositions

he final step in creating an Adobe LiveMotion composition is saving and exporting it 
for use on the Web. You can choose from an array of exporting options, which let you 
export to all common Web formats including the Flash (SWF) file format. You can 

adjust LiveMotion export options to optimize your compositions and create high-quality 
output that loads quickly.

About exporting
LiveMotion lets you preview your composition and interactively adjust it to achieve the 
best results in a Web browser. For example, you can see how changing an export setting 
affects the image quality and file size. (See “Previewing compositions” on page 133.)

You choose most export options in the Export palette, which gives you a convenient 
interface for experimenting with the effects of different settings. 

Export palette

The Export palette, lets you do the following:

• Export an entire composition or just selected objects. 

• Apply export settings at the document level and at the object level.

• Create an HTML page that references your image files. 

• Slice a composition and have LiveMotion generate an HTML table that reassembles the 
parts on a Web page.

• Attach URLs to objects and create image maps, such as a set of buttons in an HTML 
page.

• Export the background of a composition as an HTML background.

Before exporting a composition, you should save it as a LiveMotion file so that you can 
reedit the composition if needed (see “Saving compositions” on page 19).

bbaeck
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About export formats
To use a LiveMotion composition in a Web page, you export the composition in one of 
these Web file formats: SWF, JPEG, GIF, PNG-Indexed, PNG-Truecolor, and QuickTime, and 
Adobe Photoshop. The format you choose depends on the characteristics of the compo-
sition. 

Macromedia Flash (SWF) Exports animated compositions in the Flash (SWF) file format. 
The SWF format can be read by most browsers with the Flash player plug-in. Because the 
SWF format saves animations as vector images, it is a good choice for animations with 
solid areas of color and sharp object definitions. Vector animations usually have small file 
sizes as well. For more information on optimizing your compositions, see “Specifying 
export settings for different file types” on page 140.

Note the following when exporting as Flash:

• Some objects—for example, objects with more than one layer—cannot be exported as 
vector objects. In these cases, the SWF format will reference a raster file for the objects. 
This means that when you choose the SWF format for your exporting, you also choose a 
bitmap compression format such as JPEG, Indexed, and TrueColor or PNG-Indexed.

• The SWF format supports solid-color backgrounds only. Gradients or textures applied to 
the background of a composition are exported as a backdrop object—a bitmap object 
that appears behind all the other objects in the composition.

• The SWF format is a streaming format, and will play as soon as a certain amount of the 
file has downloaded.

AutoLayout When you export an HTML composition in AutoLayout format, LiveMotion 
slices the composition into its components and makes a separate image file for each 
object or group of objects in the composition. You can specify a filename and alternate 
text for each image file.

Consider the following when using AutoLayout format:

• The Make HTML Page option in the Export palette creates an HTML page that refer-
ences the exported images. With this option selected, LiveMotion creates a table in the 
HTML page and places the objects in the table cells to approximate the composition, 
preserving its layout.

• Any background color or texture you have applied to the HTML composition is 
preserved in the individual images. The background is also exported as an image file.

• For the GIF, JPEG, and PNG-Indexed or PNG-Truecolor formats used with the AutoLayout 
export option, the topmost object in a slice determines the slice’s composition settings. 

• LiveMotion determines how to slice an HTML composition by finding any objects that 
are grouped, or any objects that touch or overlap (including their bounding boxes). and 
placing them in the same image file. The entire overlapped objects are exported.

Selection and exported object
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• AutoLayout places images in the HTML file, starting from the top left of the composition 
in order to the bottom right. 

Live Tab This format lets you save a composition as a Live Tab. You can then use the Load 
Live Tab command to add file to the list of available Live Tabs. For information on how to 
create Live Tabs, see <<TBD: Name of document not defined yet>> .

GIF The GIF format is a good choice for compressing solid areas of color while preserving 
sharp detail, such as that in line art, logos, or illustrations with type. The GIF format is also 
good for rendering small-scale animations, such as spinning or pulsing buttons.

Note the following when exporting as GIF:

• GIF supports 8-bit indexed color for a display of up to 256 colors. 

• You can choose a selective indexed color table that contains the colors most commonly 
used in the image. You can also choose Web to ensure that your colors are Web-safe.

• The GIF format uses a lossless compression method in which no data is discarded during 
compression. However, since GIF images have a maximum of 256 colors and 
LiveMotion can use millions of colors, an image in the GIF format may be degraded.

• You can choose to create an interlaced GIF image, in which a low-resolution version of 
the image appears in a Web browser while the full image is downloading.

Animated GIF This format is the same as GIF, but rather than exporting only the current 
frame in a composition, it exports all of the frames as an animated sequence.

You can select any of the regular frame rates, or use keyframes only, which animates only 
the keyframes in the Timeline without interpolation. This creates animations in which the 
image changes at specific points, rather than smooth transitions between keyframes.

QuickTime Video This is Apple's multimedia software format. You can use it for movies as 
well as for synchronized graphics, sound, video, text, and music on the Web. QuickTime 
Video is free as either a download over the Web from Apple's site (www.apple.com), or as a 
pre-installed plug-in on your computer. It is supported by Windows and Macintosh 
operating systems. Note the following:

• Movies can be delivered by either progressive download via HTTP at a pre-determined 
level of quality or by “True Streaming,” which needs a dedicated server to deliver 
output in real time. 

• Only top-level linear animation in the Composition can export to QuickTime.

• Animation contained in movie clips does not export (only the first frame of the movie 
clip appear in the exported movie)

JPEG Designed for use with raster images, and other continuous-tone graphics. JPEG 
uses 24-bit color, and preserves the broad range and subtle variations in brightness and 
hue found in photographs. 

Note the following when exporting as JPEG:

• The JPEG format uses a lossy compression method, in which data is discarded during 
compression, which may degrade sharp detail in some images. 

• You can use the Reduce Chroma option to create a slightly smaller JPEG file by reducing 
the color information in the exported image. Reduce Chroma discards every other pixel 
in the chroma information without affecting the luminance, and typically without 
visibly changing the image quality.
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• For faster image loading, you can create a progressive JPEG. The image downloads 
progressively, so viewers can see a low-resolution version of the image before the final 
image downloads completely.

Note: Data is discarded from a JPEG image each time you export a file to JPEG format. You
should always save JPEG files from the original composition if possible, rather than re-
importing and exporting the image multiple times.

Photoshop Exports a flattened image to the Adobe Photoshop format. Photoshop, 
Adobe ImageReady™, and Adobe Illustrator can open your LiveMotion composition. 

PNG-Indexed Also known as PNG-8, PNG-Indexed color supports 8-bit indexed color. The 
PNG-Indexed format uses a lossless compression method. PNG-Indexed compresses solid 
areas of color while preserving sharp detail, such as that in line art, logos, or illustrations 
with type. 

LiveMotion uses the composition’s alpha channel or active matte information to export 
PNG-Indexed files with a single level of transparency.

PNG-Indexed is supported directly by Internet Explorer 4.0 and later. Internet Explorer 
before 4.0, and Netscape Navigator 2.0 or later need a plug-in.

PNG-Truecolor Also called PNG-24, PNG-Truecolor supports 24-bit color. PNG-Truecolor 
uses a lossless compression method. PNG-Truecolor preserves the broad color and tonal 
range of photographic images. 

Small bitmaps compress very efficiently using Truecolor; large bitmaps (over 100 x 100 
pixels) compress best using JPEG.

LiveMotion exports PNG-Truecolor files with a single level of transparency.

PNG-Truecolor is supported directly by Internet Explorer 4.0 and later. Internet Explorer 
before 4.0, and Netscape Navigator 2.0 or later need a plug-in.

A note about sounds When selecting compression settings for sound, make sure a 
sound object is selected. Selecting sound settings while any other type of object is 
selected will not apply the settings to the composition’s sounds.

Optimizing your compositions
To create animation files that load quickly and play smoothly, you need to consider the 
type of art to include in an animation and what the export format will be. You should also 
consider the visual effects you want and how you will use sound.

Frame rate, properties, and size. It’s important to be aware of the relationship between 
frame rate, animated properties, and file size. When you export a composition in SWF 
format, the file stores all changing values for an object on every frame on which a property 
changes. Although this is only about 6 bytes per frame for each changing property, the 
total can become large, especially at higher frame rates. 
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Suppose you have an object that changes position during a one-second long animation 
set to 10 frames per second (fps). The tweening would require approximately 60 bytes (6 
bytes times 10 frames) when you exported the animation. If you tripled the frame rate to 
30fps for smoother animation, three times as much tweening information would be 
created—about 180 bytes—when you exported the animation. Animating a second 
property, such as object opacity, would double that size to 360 bytes. Animating more 
properties, adding more keyframes, and applying changes to multiple objects would 
increase the exported file size proportionally. 

It’s important, therefore, to consider the costs of animating even Flash-native properties. 
Fortunately, you can vary your frame rate without adjusting the duration of your anima-
tions, letting you find the balance between a smooth animation and a small file size. 

Regular groups vs. movie clip groups. Macromedia Flash (the authoring tool and SWF 
format) doesn't have the LiveMotion concept of groups as containers that can be 
animated and transformed like other objects. Therefore, LiveMotion breaks apart any 
groups in your animations when it exports them, writing transformation information for 
each item in the group. One exception to this is movie clip groups, which LiveMotion 
exports as Macromedia Flash movie clips. << CAN WE REFER TO FLASH AND THEIR 
MOVIE CLIPS?>> By giving each member of a group only the transformations unique to 
it, and by applying the shared transformations at the time-independent group level, you 
can avoid significantly increasing the file size. The more frames, objects, and attributes you 
use, the more the file-size-savings increases. 

You can greatly reduce the file size by duplicating groups and making them movie clip 
groups. When exporting such groups, LiveMotion wraps their contents in a Macromedia 
Flash movie clip. If the contents and transformations are identical, the Flash player recog-
nizes that they’re the same and re-uses the contents. 

Using movie clip groups is recommended if you're making a linear animation. Remember, 
though, that if you stop the main timeline, time-independent groups will continue to play 
unless you add a behavior that targets and stops them. 

Pre-transform vs. post-transform. Pre-transforms affect the artwork itself, whereas 
post-transforms are applied just to particular instances of the artwork. This has implica-
tions for how LiveMotion optimizes SWF files by storing single objects and re-using them 
in the SWF, as well as for how it stores each object. 

When you first import a piece of artwork and scale it, you're applying a pre-transform; that 
is, you're changing the native size of that artwork and therefore (if it exports as a bitmap) 
the number of pixels it contains. However, when you set a stopwatch for the scale 
attribute in an animation, you begin to apply post-transforms; that is, you're just scaling 
that particular copy of the artwork. It’s a good idea, therefore, to find the point at which 
your artwork appears the largest, then use the Make Actual Size command. This makes the 
native artwork only as big as it needs to be in that situation, and at other points it will be 
scaled down and the effects of the scaling won't be so visible. The actual size determines 
the size required in the SWF. 
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As another example, suppose you used the 3D palette to apply a 5-pixel bevel to an 
object. If you pre-transformed the object (such as by enlarging it), the bevel would remain 
5 pixels wide because you’re changing the source artwork. But if you applied a post-
transform to the object (such as enlarging it over several seconds in an animation), the 
bevel would increase in size proportionally with the rest of the object because you're 
transforming that copy of the object, not the source object. However, again, you could 
redefine its native size with the Make Actual Size command. 

Understanding pre- and post-transforms is essential when you want to duplicate anima-
tions without greatly increasing the size of your exported SWF file. You can reduce its size 
by wrapping animated elements in a movie clip group, then applying transformations at 
the group level. Be aware that if you apply pre-transforms at the group level to a duplicate 
movie clip group, that group will export separately from the original (the artwork it 
contains are stored once, but the animations applied to it are exported twice). Instead, you 
can make an alias of the movie clip group, and then apply a post-transform such as Scale 
to it later. This will export a singe movie clip group and a reference to it for the alias. 

Modify Transform properties. You can create more efficient animations by modifying 
Transform properties and avoiding Layer and Object Attribute properties. For example, 
using the Transform Scale property to change an object’s width results in a smaller file size 
than using the Width property in the Layer palette. Transform attributes are located on the 
Transform palette, Object Opacity on the Opacity palette, as the Horizontal Flip and 
Vertical Flip commands, and within an object’s Transform properties in the composition’s 
Timeline window. 

Aliases. Aliases make it easy to edit multiple objects simultaneously in LiveMotion and 
export them as single entities to Flash (that is, as an animated time-independent group 
with several aliases export to SWF just once). For example, when you rotate or skew an 
alias of an object, you're usually applying a post-transform (that is, you're changing just 
the copy you've selected). But when you scale it, by default you're applying a pre-
transform (that's why each copy scales). You can apply post-transform scaling to an alias 
by first setting a scale stopwatch on the timeline, then scaling the alias. Color and object 
properties (shape type, points, etc.) are pre-transforms. 

In this example, making an alias to the original time-independent group animation, then 
setting a stopwatch and scaling the time-independent group ensures that LiveMotion 
exports just one copy and uses it twice in the SWF.

Imported artwork versus native versions. Certain kinds of imported artwork are 
difficult to export efficiently. In particular, Illustrator files can contain objects that are 
rasterized when exported to SWF and imported gradients can be particularly difficult. So 
while you may be able to import them, you obtain the best results by recreating native 
versions in LiveMotion and deleting the imported originals. The LiveMotion versions 
export natively to SWF and help prevent your editing environment from slowing down.
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Animating color versus animation tint. If you're familiar with Macromedia Flash, you 
might expect LiveMotion to vary the shade of objects in the same way that Macromedia 
Flash does. <<Can we mention Macromedia Flash?>> But instead of varying tint (a 
native transformation), LiveMotion varies the actual color of the object or layer. While this 
approach can yield more accurate results and allows you to apply color changes on just 
certain layers (Macromedia Flash tint applies the effect to the entire object), it requires 
LiveMotion to generate new artwork on every frame the color changes. As a result, you 
should be judicious in animating color transformations, especially on artwork that will 
generate a bitmap when exported to SWF. 

If file size is a concern, consider making your shape a mask and then animate the color of a 
rectangle beneath the mask. A new rectangle will be created on every frame, but it will be 
about 35 bytes (almost definitely smaller than a new copy of your shape). However, you 
can’t use vector artwork as a mask if you import it. But you can usually use the shape as a 
mask if you paste it instead. Converting the shape to a single color without a stroke before 
pasting may help as well. 

Clipping and re-using sounds. LiveMotion clips off extra sound data you don't need. For 
instance, suppose you want only the first second's worth of a three-second-long sound, so 
you slide the end point of the sound's lifetime back to 1 second. LiveMotion will export 
only 1 second's worth of the sound. However, if you use the sound again later, but this 
time you use all three seconds, LiveMotion stores a second copy of the sound, meaning 
you now have a total of four seconds’ worth of audio data in your SWF. 

To avoid the extra file size, you can place your sounds in time-independent groups, then 
set the end point of the time-independent groups so that the sound is clipped where you 
want, but the entire sound is stored just once. Note, however, that because the Flash 
player doesn’t synchronize event sounds and animation, setting the end points in this way 
might not clip the sounds exactly where you specified. Because this depends heavily on 
processor speed, frame rate, and other factors, you should test your SWF on various 
computers. 

Per-object settings and performance. Use per-object export settings wisely. Per-object 
settings let you fine-tune an exported SWF file by letting you specify the best format for 
objects that will be converted to bitmaps when exported, reduce colors, experiment with 
different levels of quality, and so on to find the best balance between output quality and 
file size. Unfortunately, LiveMotion has to store and track each setting, which can increase 
memory use and decrease performance. It’s a good idea, therefore, to pick the setting that 
works best for most objects and store it at the document setting (this is what you’re doing 
when you specify settings without selecting Object in the Export palette and making a 
new setting). Also, use Preview Export Compression to check whether an object will 
become a bitmap when exported. If it doesn’t, there’s no reason to add a per-object 
setting to it. 

Multi-layer objects. Objects with multiple layers, even if those layers are simple shapes, 
become bitmaps when exported to SWF. If you're using basic shapes in object layers, 
consider using multiple objects on the timeline so that they can export as vectors. You can 
still group the objects and animate characteristics at the group level so that you can edit 
them as a single object. Note that this doesn't mean you should never use multi-layer 
objects. Sometimes those objects can export and animate more efficiently than a large 
group of single-layer objects that would be required to achieve the same appearance. 
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Object layer opacity. Try to avoid animating object layer opacity and animate object 
opacity instead. Object layer opacity controls how each layer of a multi-layer object blends 
with other layers, whereas object opacity applies to an entire object. LiveMotion has to 
generate new artwork when you animate the object layer opacity. When you change 
object opacity, however, it’s handled natively in the Flash player.

You can change the object layer opacity to make artwork appear and disappear in 
different custom states (this is useful for creating remote rollovers, for example). However, 
it’s more efficient to group the artwork and create the custom states at the group level, 
since this lets you vary the object opacity of the grouped artwork, and LiveMotion would 
export just a single copy. As an alternative to grouping, you could turn off all object layers 
in rollover states where you want the artwork hidden. When all layers are hidden, 
LiveMotion export just a blank placeholder. 

Animating text size. Whenever possible, don’t animate the text size., since it makes 
LiveMotion generate new font information on every frame. Instead, animate the scale of a 
text object, instead. 

Animating text tracking and leading. Animating the tracking and leading of a text 
object lets you keep a single, editable word or phrase on the timeline while distributing its 
characters vertically and horizontally. But when LiveMotion exports such an animation, it 
generates a new text object on every frame, resulting in a SWF file that is much larger and 
plays back more slowly than if you had animated each letter separately. In this case, 
consider using the Break Apart Text command and animating the individual letters. You 
can still group the animated letters to get the effect of working with a single text object. 

Gradients. Because Flash can’t animate gradient characteristics natively, LiveMotion 
must generate a new gradient on each frame where the gradient changes. You can 
achieve a similar effect by placing a gradient under a mask, then spinning or stretching it 
<<THE GRADIENT OR THE MASK?>> as necessary. In addition, applying a double-burst 
gradient to an object will convert that object to a bitmap when exported.

DIstortion lenses. Distortion lens can provide very interesting effects, but animating 
them can quickly increase the file size of your exported SWF. Using a lower frame rate will 
cause LiveMotion to generate fewer bitmaps, and using a very low per-object export 
setting with a distortion lens can reduce the file size without compromising the visual 
quality (after all, each image will be visible for only a fraction of a second). You can also use 
hold keyframes on the distortion characteristics in conjunction with regular keyframes on 
opacity keyframes to fade between versions of the lens. In this case, LiveMotion only 
generates bitmaps where the distortion characteristics change. 

Previewing compositions
LiveMotion provides a variety of features that enable you to preview how your finished 
composition will look:

• The Preview Export Compression command displays an approximation of how your 
composition will look given the current export settings and file size. This lets you edit 
the composition or change compression settings to further reduce the file size and 
preview the result for image quality. All commands and tools function in Preview 
Export Compression mode. For information on changing export settings, see “Under-
standing the export report” on page 136.



Using Help  | Contents  | Index Back 134  

Help Exporting Compositions 

Using Help  | Contents  | Index Back 134  

The two sections along the bottom left of the active composition window display the 
composition’s size and the size of any selected object. If you have selected individual 
objects, an icon indicates whether they will be exported as bitmap objects, vector 
objects, or a combination of both. Selected objects in the composition display a red 
border when Preview Export Compression is on. If the AutoSlice or AutoLayout option 
is selected, the size is the sum of all of the files that will be exported.

Note:  Performance slows when you work in Active Preview mode, so it’s a good idea to 
use this mode only for proofing your work.

• There are several ways to preview animations. For general information, see “Previewing 
animations” on page 100. For information on using Preview Mode to preview an 
animation, see “Previewing using Preview mode or a Web browser” on page 101.

• The Preview In commands let you preview the composition in a Web browser. 
Previewing your work in a Web browser is the best way to see how your composition 
will actually appear in that browser. In addition, when you preview in a Web browser, 
LiveMotion provides an export report that gives additional details about your compo-
sition, enabling you to see how the composition is exporting, how large each object in 
an animation is at each frame, and the like. (See “Understanding the export report” on 
page 136.)

• Real-Time Preview skips frames if necessary to preview animations at a constant speed. 
For example, at the beginning of an animation, only one object might be moving, 
whereas later in the animation numerous objects might be moving. A preview of the 
animation might slow down when it encounters the more complex part of the 
animation. Real-Time Preview would maintain the speed of the preview by skipping 
some of the frames of the animation.

• Simulate Slow Download simulates a slower connection. For example, suppose you 
were creating a pre-loader animation designed to run while the main animation 
downloads from a Web site. Because both of these animations would typically on your 
system, LiveMotion could download the main animation so quickly in Preview mode 
that you would not have time to see how the pre-loader would run. Simulate Slow 
Download would simulate the download time needed for the main animation, allowing 
the pre-loader to run.

• AutoSlice Area shows where LiveMotion will divide objects into separate pieces if you 
export the composition as AutoSlice. (See “Using batch replace HTML” on page 144.)

• Object Edges lets you see how objects look with or without their selection handles and 
borders. You can work with objects in this mode as well as simply view them.

• Objects Off Canvas lets you see outlines of objects that are past the edge of the canvas 
(the viewable/exportable area). This is useful, for example, when you are animating an 
object that begins out of view.

• Preview Mac Gamma (Windows) and Preview Windows Gamma (Mac OS) lets you see 
how a composition will look when viewed on a different platform. The gamma is a 
measure of the brightness of midtone values in graphics. On Windows systems, the 
gamma is 2.2, whereas on Mac OS the gamma is 1.8. The result is that the same image 
appears slightly darker on a Windows system than on a Mac OS system. 
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To preview the image quality and the current frame size based on the current Export 
palette settings:

1 Make the Composition window active.

2 Choose View > Preview Export Compression. 

3 In the status bar (Windows) or the lower left of the Composition window (Mac OS), view 
the object and current frame size that results from changing Export palette settings. 

4 If needed, change Export palette settings, or edit your composition until you reach an 
optimal balance between file size and image quality.

5 Choose View > Preview Export Compression to turn off Preview Export Compression.

To add a Web browser to the Preview In menu:

1 Create a shortcut or an alias for the Web browser.

2 Drag the icon for the shortcut or alias into the Helpers/Preview In folder within the 
LiveMotion program folder.

3 Restart LiveMotion.

To preview a composition in a Web browser:

1 Choose File > Preview In and choose a Web browser from the list. LiveMotion launches 
the application and displays the composition in the browser window. 

Note: If Entire Composition or Trimmed Composition is selected in the Composition
Settings dialog box, Make HTML must be selected to preview the composition in a Web
browser.

To maintain an animation’s speed while in Preview mode:

1 Click the Preview Mode button  at the bottom of the toolbox or choose View > 
Preview Mode.

2 Choose View > Real-Time Preview.

3 Click the Edit Mode button  to exit the Preview mode.

To preview how an animation will run over a slow internet connection:

Choose View > Simulate Slow Download.

To preview how LiveMotion will divide objects if you export as AutoSlice:

Choose View > AutoSlice Area.

To view or hide the selection handles and borders of an object:

Choose View > Object Edges.

To view or hide the selection handles and borders of an object that is beyond the 
canvas:

Choose View > Objects Off Canvas.

To preview how colors will look on a different platform:

Choose one of the following, depending on which platform you are using:

• For Windows, choose View > Mac Gamma to preview how colors will look in Mac OS.
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• For Mac OS, choose View > Windows Gamma to preview how colors will look in 
Windows.

Understanding the export report
The Export palette lets you create an export report that appears when you preview a 
composition in a Web browser using the Preview In command. This report provides details 
on the composition, including estimated download times, number of keyframes, file size, 
and the like.

The following information is provided in the export report:

• Overview displays the file size, the number of frames in the SWF, and the number of 
frames per second (fps).

• Total Download Times displays an estimation of how long it takes to download the file 
on 14.4K, 28.8K, and 56K modems

• Download Streaming displays a table that shows the following for each frame (called a 
time code): the frame size in bytes and the number of preloaded frames for 14.4K, 
28.8K, and 56K modems. Preloaded frames refer to how many frames stream in per 
frame. A negative number indicates how many frames are required for that particular 
frame to be loaded.

• Resources displays the time code and whatever objects (bitmap or vector) are present 
on each frame. This information includes the file format, file quality settings, opacity 
settings, file size, references (instances), and names.

To view the export report:

1 When you specify your export settings, click the box next to the Create HTML Export 
Report button <<ICON >> on the Export palette.

2 Choose File > Preview In, followed by the name of a Web browser.

3 Click the link “Export Report” on the preview of your composition that appears in the 
Web browser.

Exporting compositions and objects
When you export entire compositions or selected objects, per-object settings are saved 
with the document, as well as document export settings. To export a composition or 
object, you choose an export format, set options for that format, and then choose an 
export command.

Setting basic export options
The Export palette contains the export options you need to set for your compositions. 
Each file format has specific choices, but the basic steps for using the Export palette are 
the same whatever format you choose. For information on specific format options, see 
“Specifying export settings for different file types” on page 140.

To use the Export palette:

1 Turn on the Preview Export Compression feature so that you can see how your export 
choices will affect file size:



Using Help  | Contents  | Index Back 137  

Help Exporting Compositions 

Using Help  | Contents  | Index Back 137  

• Choose View > Preview Export Compression. 

• Click the Preview Export Compression button <<ICON >> in the Export palette.

2 Display the Export palette:

• Choose Window > Export.

• Choose File > Export Settings.

3 Choose an export format from the menu at the top of the Export palette. (For a 
description of the various formats, see “About export formats” on page 127.)

4 If you are exporting in Macromedia Flash (SWF) format, you can specify a target window 
or frame for a page that a sliced image links to. If you are exporting in AutoLayout format, 
you can specify a filename and alternate text in addition to a target for a sliced image. See 
“Specifying a filename, alternate text, and a target for a sliced image” on page 143.

5 Select general export options (depending on the format you choose, not all options are 
available):

• Click the box next to the Make HTML Page button <<ICON >> to embed the exported 
file in an HTML page. (If you export in AutoLayout format, the HTML page contains 
references to the exported images.)

• Click the box next to the Export HTML Report button <<ICON >> to create an export 
report detailing the elements in the file. (See “Understanding the export report” on 
page 136.)

• Click the box next to the Trim Composition on Export button <<ICON >> to export the 
smallest area enclosing all of the objects in the composition. Leave this option 
unselected to export the entire composition (that is, all of the canvas, including any 
areas that don’t have objects on them). 

6 Click the Document Export Settings button <<ICON >> at the bottom of the Export 
palette to set export options for the overall document.

7 Choose document-level options for the selected export format as described in “Speci-
fying export settings for different file types” on page 140.

8 If you are exporting in Macromedia Flash (SWF) format or AutoLayout format, you can 
specify different export settings for one or more individual objects in the composition. See 
“Specifying Per-Object Settings” on page 142.

9 Export the file:

• Choose File > Export to export the entire composition as a single or multiple files. 

• Choose File > Export As to change the name, location, or format of an exported file for a 
previously exported composition.

• Choose File > Export Selection to export only the currently selected objects. LiveMotion 
exports the smallest rectangle that completely encloses the bounding boxes of the 
selected objects. 

10 Name the file, select a location for it, and click Save.

Note: You will overwrite a previously exported file the next time you choose File > Export.
Choose Export As and type a new filename to export multiple versions of a file.

bbaeck
Please note that final icons will be added to this document in place of the current <<ICON>> indicators.
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Setting specific export options for different export formats
Once you’ve decided on an export format as described in “About export formats” on 
page 127 and have chosen the high-level export options as described in “Setting basic 
export options” on page 136, you can specify document-level settings for that particular 
export format. 

It’s a good idea to watch the Composition window and the file size indicators to see how 
your choices affect the size and visual quality of your composition.

To specify export options for Flash (SWF) format:

1 Choose the general options for exporting as described in “Setting basic export options” 
on page 136.

2 To specify a target window or frame for a page that an image links to, see “Specifying a 
filename, alternate text, and a target for a sliced image” on page 143.

3 Verify that you chose Macromedia Flash (SWF) from the format menu at the top of the 
Format palette.

4 Click the image format tab <<ICON >> and select an image format option:

• JPEG if you are exporting JPEG images, specify the image quality by dragging the 
Quality slider or entering a value (0–100) in the text box. Specify the Opacity Resolution 
by dragging the Opacity Resolution slider or entering a value (0–8) in the text box. 
Higher values increase the quality of colored areas and the file size; smaller values 
decrease the file size but can cause banding, an unintended variation in the opacity of 
colored areas.

• Indexed if you are exporting Indexed images, select compression settings as described 
for exporting a file in PNG-Indexed format.

• Truecolor if you are exporting Truecolor images, specify the color resolution by 
dragging the Color Resolution slider or entering a value (1–8) in the text box. Higher 
values increase the available colors for the palettes and the file size. A value of 8 will 
make millions of colors available; a value of 1 will create a black-and-white palette. 
Specify the Opacity Resolution by dragging the Opacity Resolution slider or entering a 
value (0–8) in the text box. Higher values increase the quality of colored areas and the 
file size; smaller values decrease the file size but can cause banding, an unintended 
variation in the opacity of colored areas.

5 Click the Rasterize button <<ICON >> to export selected vector objects as bitmaps.

6 Click the sound tab <<ICON >> and set the rate for sounds in the MP3 menu. If you’re 
unsure what bit rate to use, choose Auto bit rate to let LiveMotion use it’s built-in 
algorithm to choose the rate it considers best. In this case, it will compress some sounds 
more than other to retain the sound quality while minimizing the file size. 

7 Unless you need stereo output, click the Convert Stereo Sounds to Mono button , 
which significantly decreases your file size. 

8 Click the text tab <<ICON >> and specify which fonts you want to embed in the 
exported file. This is useful if you want to make sure the fonts you used in your compo-
sition appear in on users’ Web browsers:

• From the Embed Fonts menu, choose whether you want to embed no fonts (None), the 
entire font set (Full Set), or just the ones you mark (Partial Set).
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• Click the buttons representing the types of characters you want to embed: Embed All 
Uppercase Fonts <<ICON >>, Embed All Lowercase Fonts <<ICON >>, Embed All 
Numbers <<ICON >>, and Embed All Punctuation <<ICON >>.

• In the Extra text box, enter any specific characters you want to embed from the font.

Note: If the composition contains text-entry fields and you embed partial sets of fonts,
users can enter only those characters in the fields.

9 Click the animation tab <<ICON >>. Then specify a frame rate and whether you want to 
attach or reference movie clips and sounds:

• To export the composition at a different frame rate than you worked with in 
LiveMotion, choose a frame rate from the Frame Rate menu.

• If you are using scripting, you can attach movie clips and sounds with the remaining 
option in the animation tab. See the Adobe LiveMotion 2.0 Scripting Guide for details.

10 To choose separate export options for individual objects within the composition, see 
“Specifying Per-Object Settings” on page 142.

To specify export options for AutoLayout format:

1 Choose the general options for exporting as described in “Setting basic export options” 
on page 136.

2 To specify filenames, alternate text, and targets for the sliced images, see “Specifying a 
filename, alternate text, and a target for a sliced image” on page 143.

3 To preview how LiveMotion will slice the objects, choose View > Autoslice Area.

4 Verify that you chose AutoLayout from the format menu at the top of the Export 
palette.

5 Choose a file format for the objects in the composition.

6 Choose options, depending on that format. For a description of the options, see the 
instructions for exporting a file in that format.

7 Enter the name of the folder in which you want to save the images. If you leave this 
blank, LiveMotion places the exported image files in a folder called “images” located in the 
same folder as the HTML file. You can specify a subfolder by placing a “/” in the path name. 
For instance, entering “Myfolder/Artwork” creates the folder “Myfolder” and the subfolder 
“Artwork,” which in turn contains the images.

8 To choose separate export options for individual objects within the composition, see 
“Specifying Per-Object Settings” on page 142.

Note: If an HTML composition is not slicing as expected, make sure that the bounding
boxes of objects you want on different slices are not touching.

To specify export options for Live Tab format:

1 Choose the general options for exporting as described in “Setting basic export options” 
on page 136.

2 Verify that you chose Live Tab from the format menu at the top of the Export palette.

To specify export options for QuickTime Video format:

1 Choose the general options for exporting as described in “Setting basic export options” 
on page 136.
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2 Verify that you chose QuickTime Video from the format menu at the top of the Export 
palette.

3 Click the Video Options button <<ICON >> and select any of these options:

• From the Compressor area, select the video format (codec) you want. Some of these 
have further options, accessible by clicking the Options button.

• From the Compressor area, select the number of colors to include.

• Enter the quality, frame rate, key frame rate, and data limit rate for the exported video.

The settings and available codecs are determined by QuickTime. For detailed information 
about the QuickTime options, open the Apple QuickTime application and choose Help > 
On-line QuickTime Player Help.

4 Click the Audio Options button <<ICON >> and select any of these options:

• From the Compressor area, select the audio format you want. Some of these have 
further options, accessible by clicking the Options button.

• Choose a sampling rate.

• Select whether to save it in 8-bit or 16-bit format (which provides higher quality, but 
increases the file size). 

• Select whether to save it in mono or stereo. Saving in stereo increases the file size.

The settings are determined by QuickTime. For detailed information about the QuickTime 
options, open the Apple QuickTime application and choose Help > On-line QuickTime 
Player Help.

To specify export options for GIF, animated GIF or PNG-Indexed format:

1 Choose the general options for exporting as described in “Setting basic export options” 
on page 136.

2 Verify that you chose GIF, Animated GIF, or PNG-Indexed from the format pop-up menu 
at the top of the Export palette.

3 Specify the number of colors for the exported image by dragging the Colors slider or 
entering a value (2–256) in the text box. Shift-drag constrains the value to common color 
depths.

4 Select a color palette to set how colors are displayed in an operating system or a Web 
browser:

• Perceptual creates a custom palette by giving priority to colors for which the human 
eye has greater sensitivity. This palette usually produces images with the greatest color 
integrity.

• Selective creates a custom palette by sampling colors from the spectrum appearing 
most often in the image. For example, an image with only the colors green and blue 
produces a palette made primarily of greens and blues. Most images concentrate colors 
in particular areas of the spectrum. 

• Web Adaptive creates a custom palette by shifting colors toward Web-safe colors, and 
preserves Web-safe colors on export.

• Web uses the standard 216-color palette common to the Windows and Mac OS Web-
safe color palettes.
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• Mac OS uses the default 8-bit color palette of the Mac OS system, which is based on a 
uniform sampling of RGB colors.

• Windows uses the default 8-bit color palette of the Windows system, which is based on 
a uniform sampling of RGB colors.

5 Click the display options you want:

• Click the Include Transparency Information button  to export the image with the 
object’s alpha channel or active matte. (See “Using alpha channels” on page 54.)

• Click the Dither button  to mix the available colors to simulate unavailable colors. 
Dithering often improves the gradation after you have reduced the number of colors—
but increases the exported image’s file size. You can see dithering with Preview Export 
Compression on.

• Click the Compress for Progressive Downloads button  to let browsers display a lower 
resolution image while the final image loads.

6 If you are exporting an animated GIF, choose a frame rate from the Frame Rate menu. 
Then choose how many times, if at all, you want the animation to loop, or repeat.

To specify export options for JPEG format:

1 Choose the general options for exporting as described in “Setting basic export options” 
on page 136.

2 Verify that you chose JPEG from the format menu at the top of the Export palette.

3 Specify the quality for the exported image by dragging the Quality slider or by entering 
a value (0–100) in the text box. Higher values increase the quality and the file size of the 
exported image.

4 Choose any of the following:

• Select Progressive to export the images as a progressive JPEG.

• Select Reduce Chroma to create a slightly smaller JPEG file. If the image quality visibly 
degrades, increase the Quality setting.

• Select Optimized to create a custom compression table for the image. Optimized JPEGs 
have a slightly smaller file size and a longer compression time.

To specify export options for Photoshop format:

1 Choose the general options for exporting as described in “Setting basic export options” 
on page 136.

2 Verify that you chose Photoshop from the format menu at the top of the Export palette.

To specify export options for PNG-Truecolor format:

1 Choose the general options for exporting as described in “Setting basic export options” 
on page 136.

2 Verify that you chose PNG-Truecolor from the format menu at the top of the Format 
palette.

3 Click the Transparency button  to export the image with the object’s alpha channel or 
active matte. (See “Using alpha channels” on page 54.)

4 Click the Compress for Progressive Downloads button  to export the image at a lower 
resolution and increase the image quality as the image loads. 
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Specifying Per-Object Settings
If you are exporting in SWF or AutoLayout format, the Export palette lets you set export 
options for individual selected objects within the composition. Applying separate optimi-
zation settings for each object lets you determine the export format, quality, and size of 
individual objects or groups of objects. 

For example, if you are exporting in SWF format and the composition consists of several 
photographs and two solid-color graphics, you might save the document in JPEG and 
then select the solid-color graphics and save them as Indexed. 

For another example, suppose the document your are exporting in AutoLayout format 
contains several smaller images that can be lower quality, but one large image that needs 
to be higher quality. In this case, you could first specify the document-level settings to be 
JPEG with a lower quality setting. You could then select the large image, specify that its 
setting be JPEG with a higher quality setting.

Note the following when specify per-object export settings:

• You can only apply per-object settings to compositions being exported in SWF or 
AutoLayout format.

• Settings for an individual object are saved even if the document-level export settings 
change.

• The per-object options on the Export palette change depending on whether you are 
exporting the document in SWF format or AutoLayout format.

• You can only choose per-object settings within the overall document-level format you 
chose. For example, you can’t set the document to export as SWF and an object to 
export as AutoLayout.

• You can select and specify per-object settings for multiple objects at once.

• You cannot specify per-object settings for groups or movie clip groups. <<TBD: Will 
Move Clip Groups be able to have per-object settings?>>

To specify or modify an export setting for an individual object:

1 Set overall document settings as described in “Setting basic export options” on 
page 136 and “Setting specific export options for different export formats” on page 138, 
making sure to select either Macromedia Flash (SWF) or AutoLayout for the export format.

2 Select the object.

3 Do one of the following:

• If no settings have yet been specified for the object, click the Create a New Object 
Setting button <<ICON >> at the bottom of the palette. The Object Export Settings 
button <<ICON >> is then automatically selected and the Document Export Settings 
button <<ICON >> is deselected.

• If settings have previously been specified for the object, the Object Export Settings 
button is automatically selected and the Document Export Settings button is 
deselected.

4 Choose from options listed in the bottom half of the palette. 

For a list of formats, see “About export formats” on page 127. For a description of available 
settings, see the instructions for setting document-level export settings for that format in 
“Setting specific export options for different export formats” on page 138.
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To remove individual settings for an object:

1 Select the object.

2 Click the Delete Current Object Settings button <<ICON >> at the bottom of the 
palette.

Specifying a filename, alternate text, and a target for a sliced 
image
Before you slice an HTML composition that you are exporting in AutoLayout format, you 
can specify a filename and alternate text for the image. If you don’t specify a filename, 
LiveMotion creates the name. Alternate text is used in a Web browser when an image is 
not found or when the image is downloading slowly. It is also used on Web browsers that 
don't support images or are configured to not download images.

If you are exporting in Macromedia Flash (SWF) format or AutoLayout format, you can also 
specify a target window or frame for a page that an image links to. For example, if you 
create a button that opens a Web page, you can specify whether you want the page to 
open in a new browser window. Or, you can specify that the page opens in a specific frame 
if you are using the button in a frameset.

For more information on using these fields, consult an HTML reference guide.

To specify a filename, alternate text, or target:

1 Select any object that will become part of an exported image.

2 Choose Window > Web.

3 Choose Detail View from the pop-up menu in the Web palette to expand the palette.

4 (AutoLayout format only) Type the name in the File Name text box to specify a filename 
for the exported image.

5 (AutoLayout format only) Type the text in the ALT text box to specify alternate text for 
the exported image.

6 (SWF format and AutoLayout format) To target an exported button’s linked page to a 
new window or a specific frame in a frameset, make sure that you have entered a URL for 
the image, and then enter one of the following in the Window text box (make sure you 
include the underscore): 

• _blank to load the linked page into a new browser window.

• _parent to load the linked page into the containing frame of the frameset.

• _self to load the linked page into the frame that contains the button. This is the default 
if no target is specified.

• _top to load the linked page into the top frame (include the underscore).

• The name of any frame in the frameset (do not include an underscore at the beginning).

For information on adding a URL to an exported image, see “Creating linked images and 
image maps” on page 120.

Making objects variables for use with Adobe GoLive
Adobe GoLive can detect replacement tags (variables) in LiveMotion files and control 
LiveMotion variable objects for automated graphics production, animation building, and 
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file updates via Smart LiveMotion objects. You can swap the text, assign or modify an 
embedded link, and apply a new style or texture using controls within GoLive. GoLive then 
launches LiveMotion, which applies the settings to the variables and generates a new SWF 
target file. See the Adobe GoLive 6.0 User Guide for details.

To make an object a variable for use with Adobe GoLive:

1 In LiveMotion, select the object. 

2 Choose Window > Web to display the Web palette.

3 Choose Detail View from the pop-up menu in the Web palette to expand the palette.

4 In the Replace text box, enter a name for the variable, such as something that repre-
sents the type of object you want to replace in Adobe GoLive. For example, you could 
select an image object that represents a company logo and enter the name “logo” here.

5 Save the composition.

Tip:  Adobe GoLive ‘s Convert Text to Banner command lets you take static text and 
transform it into an image or dynamic SWF-based animation to add an attractive looking 
navigation element to your Web page. This gives you functionality similar to the Batch 
Replace command in LiveMotion 1.0. In GoLive, you can select HTML text, choose the 
Convert Text to Banner command, and select a LiveMotion (LIV) source file with variables. 
The selected HTML text is assigned to the first text variable. You then use the Smart Object 
variables workflow to create the target file. See the Adobe GoLive 6.0 User Guide for details.

Using LiveMotion HTML code
As you build your Web pages, you can open and edit the HTML files that LiveMotion 
generates in a Web-page design application such as Adobe GoLive. You can also copy and 
paste the HTML code generated by LiveMotion into pages you create in another appli-
cation. For example, if you create an image map in LiveMotion, you can do either of the 
following:

• Use the HTML page that LiveMotion generated in your Web site. The image reference 
and image map code are included in the source code of the page.

• Open the HTML page that LiveMotion generated in your Web-page design application 
or HTML editor. Then view the page’s source, copy the image map code, and paste it 
into the source view of another page.

If you’ve used the Replace field in the Web palette and want to edit the original text, you 
can edit the datamap code in the Web page’s source code. <<Does this still apply, since 
we don’t do batch replace the old way as in LM 1.0?>>

For more information, see the documentation that came with your Web-page design 
application or an HTML reference guide.

To copy JavaScript code into a Web page using Adobe GoLive:

1 In GoLive, open the HTML page that LiveMotion created and click the Layout tab to 
show the Layout Editor. 

2 Click the little blue triangle under the Layout tab to display the head section.

3 Drag the HeadScript icon from the Head section of the HTML page into the Head 
section of the page to which you are adding it.
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4 Drag any images or other elements from the body section of the LiveMotion page into 
the body section of the page into which you want to copy it. 

To copy JavaScript code into a Web page if you don’t have Adobe GoLive:

1 In your HTML editor, open the HTML page that LiveMotion created. If you are using a 
Web-page design application such as Adobe GoLive, open the HTML page and select 
Source Mode. 

Tip: In GoLive, you can also drag the script icon from the Basic tab of the Objects palette 
and place it on your page. Then double-click the icon on the page to open a text window 
to copy the JavaScript into.

2 Copy the JavaScript code from the Head section of the HTML page into the Head 
section of the page to which you are adding it. Copy all the text between the beginning 
tag <Script> and the closing tag </Script>.

3 Copy the anchor elements for the images from the Body section of the page and paste 
them to the appropriate location where you want them to appear in the body of the other 
page. The anchor element begins with the tag <a HREF= “nnn”> and ends with the </a> 
tag. The anchor element will also contain the reference to the image files.

To copy image map code into a Web page using Adobe GoLive:

1 In GoLive, open the HTML page that LiveMotion created and click the Layout tab to 
show the Layout Editor. 

2 Select the image you want to copy, then drag it by the image border into the Layout 
Editor of the document you want to copy it to.

To copy image map code into a Web page if you don’t have Adobe GoLive:

1 In your HTML editor, open the HTML page that LiveMotion created. If you are using a 
Web-page design application such as Adobe GoLive, open the HTML page and switch to 
Source Mode.

2 Copy and paste the reference code for the exported image and the image map into the 
source code of your new page. The image reference begins with the tag <img SRC= and 
ends with the symbol >. The image map code immediately follows and is enclosed by the 
tags <MAP name= “nnn”> and </MAP>.

To use Adobe GoLive to edit the original text in a Web page after batch replacing 
with images:

1 In GoLive, open the HTML page that LiveMotion created and click the Layout tab to 
show the Layout Editor. 

2 Select the image in the Layout Editor.

3 In the Image Inspector, click the More Tab to display the More panel.

The Name Attribute text field shows the name of the image.

4 Scroll to the bottom of the document.

5 Select the DataMap comment tag to display the comments text in the Inspector 
palette. 

6 Find the ObjId that matches the Name attribute. 
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7 Edit the text in the FPOrigText attribute associated with the ObjId, for example, <?FPPI 
ObjId="object10" FpOrigTag="H1" FpOrigText="My Heading" ?>.

To edit the original text in a Web page after batch replacing with images if you don’t 
have Adobe GoLive:

1 In your HTML editor, open the Web page. If you are using a Web-page design appli-
cation such as GoLive, open the Web page and switch to Source Mode.

2 Find the reference for the image you want to change (it starts with <img SRC=). Note 
the Name attribute for the image reference, for example, Name=“object10”.

3 At the end of the source code, before the </Body> tag, you’ll find the DataMap 
comment that LiveMotion created. Find the ObjId that matches the Name attribute. Edit 
the text in the FPOrigText attribute associated with the ObjId, for example, <?FPPI 
ObjId="object10" FpOrigTag="H1" FpOrigText="My Heading" ?>.


	Contents
	Chapter 1
	LiveMotion Basics

	Chapter 2
	Drawing Objects

	Chapter 3
	Creating Text Objects

	Chapter 4
	Working with Objects

	Chapter 5
	Transforming and Combining Objects

	Chapter 6
	Placing Images and Other Objects

	Chapter 7
	Object Layers

	Chapter 8
	Color, Gradients, and Opacity

	Chapter 9
	Styles and the Library

	Chapter 10
	Animating Objects

	Chapter 11
	Making Objects Interactive

	Chapter 12
	Scripting


	Introduction
	LiveMotion Basics
	Understanding Adobe LiveMotion terminology
	Looking at the work area
	Working with compositions
	Setting Preferences
	Using Web resources
	Customer Support

	Drawing Objects
	About LiveMotion objects
	Drawing shapes
	Using the pen tool
	Adjusting path segments

	Creating Text Objects
	Using text in compositions
	Using text fields
	Formatting text
	Converting text objects
	Setting options for Chinese, Japanese, and Korean (CJK) fonts

	Working with Objects
	Editing objects
	Stacking objects
	Moving objects
	Duplicating objects
	Creating object aliases
	Cutting, copying, and pasting objects
	Copying and pasting object attributes
	Undoing and redoing changes
	Using rulers
	Using guides and grids
	Aligning and distributing objects
	Grouping objects
	Maintaining grouped text formatting
	Converting into objects, sequences, and paths

	Transforming and Combining Objects
	Transforming objects
	Modifying the properties of geometric shapes
	Cropping objects
	Applying mattes
	Using alpha channels
	Making group masks
	Combining objects

	Placing Images and Other Objects
	About placing images
	Opening LiveMotion 1.0 Files
	Placing image files
	Placing image files as an animated sequence
	Replacing objects
	Using plug-ins to place artwork
	Copying and pasting images and other selections
	Dragging and dropping to copy between applications
	Copying and pasting keyframes between AfterEffects and LiveMotion
	Placing layered objects
	Opening After Effects/AMX format files
	Editing placed objects
	Editing converted placed objects
	Moving objects and layers in a converted placed file up or down a level
	Managing files with WebDAV
	Adding metadata to documents

	Object Layers
	About object layers
	Using the Object Layers palette
	Creating a layered composition
	Using the Layer palette
	Applying textures to layers
	Applying color adjustments to layers
	Applying 3-D effects to layers
	Applying distortion effects to layers

	Color, Gradients, and Opacity
	About color management
	Using the Color Scheme palette
	Using the Opacity palette
	About foreground, background, and layer colors
	Copying colors and styles
	Creating gradients

	Styles and the Library
	Using the Styles palette
	About the Library palette

	Animating Objects
	Understanding animation terminology
	Creating simple animations
	Optimizing exported animations
	Using the Timeline window
	Working with keyframes
	Animating object and layer properties
	Removing all keyframes and changes from an animated object
	Working with motion paths
	Changing objects’ durations: explicit and implicit duration
	Optimizing the resolution and file size of bitmap objects
	Working with animated GIFs
	Previewing animations
	Saving and placing animated objects to the Library
	Saving and applying animations as styles
	Working with sound
	Animating groups
	Animating masks
	Working with movie clips
	Working with labels
	Working with script keyframes
	Saving and exporting animations

	Making Objects Interactive
	Scripting
	About scripts
	Creating scripts
	Using pre-made automation scripts and Live Tabs

	Exporting Compositions



