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(cn)Chapter 23

(ct)Using Other Programs With LiveMotion

Adobe originally marketed LiveMotion as an application for animating Photoshop and Illustrator artwork. While that definitely understates LiveMotion’s many capabilities as a standalone application, it has always had good integration with Photoshop and Illustrator, and in LiveMotion 2.0, that integration has been improved and extended to Adobe’s other flagship products, including GoLive and After Effects.

(1)Integrating Photoshop and LiveMotion

If you’re familiar with Adobe Photoshop, you already know that it defines the industry standard for bitmap image editors. Due to the tight integration between Photoshop and LiveMotion, all of Photoshop’s powerful features are available for use with your LiveMotion compositions, and LiveMotion compositions can be exported in Photoshop’s native .psd format. The integration is true two-way communication that not only opens up endless design possibilities, but also increases the speed of your workflow greatly. You can use LiveMotion’s quick drawing tools to create shapes, add effects, and export to Photoshop, then open the file in Photoshop, apply filters, add layers and artwork, and place the Photoshop file back into LiveMotion to animate the layers individually. You can then continue to edit in both applications without making any destructive changes to the placed Photoshop file.

(2)A Few Pitfalls to Avoid

In order for non-destructive editing of bitmap images to occur, a valid shortcut (Windows) or alias (Macintosh) to Photoshop must be present in LiveMotion’s Helpers / Graphics Editors folder. When you install LiveMotion, the install program searches your system’s hard drive for Photoshop and should automatically add the shortcut or alias. If Photoshop was not installed on your system at the time you installed LiveMotion, you installed a different version of Photoshop, or moved Photoshop on your hard drive, you must copy a new shortcut or alias to that folder manually. If Edit Original is not available in LiveMotion’s Edit menu with a bitmap image selected, the first thing to do is check that a current shortcut or alias is correctly installed.

Note that bitmap images are not the same thing as LiveMotion vector objects that will, for whatever reason, export as bitmap objects to Flash. Two-way integration with Photoshop is only possible when using true images.

Image size matters. Because LiveMotion compositions are targeted strictly for viewing on computer monitors, all measurements are in pixels, and the resolution of bitmaps is 72 dpi. If you work at higher resolutions in Photoshop with measurement units set to inches or centimeters, it’s easy to unintentionally create artwork that exceeds the pixel dimensions of your LiveMotion composition. This presents an unnecessary drain on your system’s resources, and leads to extra work on your part. You are free to work at whatever resolution you prefer in Photoshop, but it’s best to resample the image to an easily-handled size before placing it in LiveMotion.

LiveMotion supports only one Alpha channel, so if you have saved selections in your Photoshop file, save it as a copy and discard the Alpha channels in the process. If actual pixels of artwork placed into LiveMotion are not visible on canvas, having multiple Alpha channels is a likely culprit.

LiveMotion supports only one blending mode, which is Normal. If you used other blending modes in Photoshop, be prepared for some unexpected appearance changes when the file is placed in LiveMotion.

(2)Getting the Best Quality From Your Images

LiveMotion uses the RGB color space internally, so it’s best to work with RGB images in Photoshop as well. Images created in CMYK or other color gamuts will place or paste into LiveMotion successfully, but some color shifting will occur.

If you wish to preserve your Photoshop layers for use in LiveMotion, it’s a given that you must place your artwork in Photoshop’s .psd format. But what if you know you’ll be exporting your LiveMotion composition, or the images in it, to a different Web format such as .gif or .jpg? Is it better to use the optimization tools in Photoshop’s Save For Web function and place a .gif or .jpg right from the start, or process the image through ImageReady, or what?

The answer is simply to place the .psd and use LiveMotion’s Export palette to set image formats and per-object compression levels. There is no advantage whatsoever in pre-optimizing your images, other than to reduce the file size of your LiveMotion .liv file. If you’re sure won’t need to work with Photoshop layers in LiveMotion, by all means flatten the image before placing it, but the best export quality will result from leaving it in Photoshop format.

Let’s illustrate this point by examining what happens if we place a pre-compressed .jpg image which has been compressed to a quality of 40 in Photoshop. The .jpg compression algorithm is “lossy,” meaning that image data is discarded in the compression process. The image will never look better than quality 40, no matter how LiveMotion exports it, because the discarded data cannot magically be reclaimed. Now suppose we export it using LiveMotion’s default quality setting of 50: the result is an image with quality 40 appearance and quality 50 file size.

Conversely, if we placed a quality 60 .jpg and exported it at quality 50, we’d have both the appearance and file size of a quality 50 image. It’s only when we match the compression setting exactly that both looks and size are preserved. Why not just place the .psd and compress it as needed once, right in LiveMotion? You can readily see that pre-compressing images adds an unnecessary step to the process, and actually increases the chances of exporting a degraded image or adding to the file size.

(2)Starting a Photoshop Image in LiveMotion

One of the great things about the integration features between Adobe applications is that you can use each application’s strongest points to speed workflow, and easily create artwork that would be tedious, or nearly impossible, to do using any single application. Let’s try it out. We’ll use the Linear Spiral Automation Script, so if you don’t have that one, download it from the LiveMotion section of AdobeXchange.

1. Open a new LiveMotion composition, 400 pixels square. We won’t be doing any animation, so the frame rate doesn’t matter.

2. From the Automation menu, select Scripts and invoke the Linear Spiral script. This automatically generates an outlined spiral path on the canvas.

3. Select the path object, and change from Outline to Fill in the Properties palette. You now have a fine piece of “retro” Op-Art in front of you.
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4. Change the color of the spiral and background to whatever suits your fancy. We used a golden orange for the background and magenta for the spiral, in keeping with the Op-Art theme.

5. In the Transform palette, skew the spiral 30 degrees, and rotate it –30 degrees.

6. Stretch the spiral with the Select tool so it fills the canvas vertically, and extends beyond it horizontally.

7. Give the spiral a nice embossed effect using the 3D palette.

8. Set the Export palette to Photoshop, and export.

9. Open the exported .psd file in Photoshop.

10. Add the text of your choice, and give the text some wild and crazy layer effects.
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That’s all there is to it, for our example. In five minutes or less, you’ve created a startling piece of artwork by using a few of the strong points of both LiveMotion (Automation Scripts, its excellent tools for manipulating geometric objects, and its 3D effects) and Photoshop (its extremely flexible layer effects). It would have taken hours of hard work to produce an identical graphic using only one or the other application.

(2)Photoshop Layers to LiveMotion Rollovers

Many interesting and attractive effects can be created by using Photoshop layers as buttons or remote rollovers in LiveMotion. The possibilities for making unique interfaces are practically open-ended, and it’s very simple to do. In this exercise, we’ll open a photo in Photoshop, give it a second layer with a different look, and then use the image as a button in LiveMotion. Let’s begin!

1. Open the color photo of your choice in Photoshop.

2. Crop and change the image size of the photo until it’s whatever size you want the button to be. Remember, what’s important are the dimensions of the button in pixels, regardless of resolution.

3. Copy the background layer to a second, new layer.

4. Desaturate the new layer. You now have a black and white version of the photo on the second layer, and the original color photo underneath.

5. Posterize the black and white layer, or apply whatever filters look right to you. You can preview what the button will look like by toggling the visibility of the second layer on and off.

6. Save the file in .psd format.

7. In LiveMotion, open a new composition at least as large as the button.

8. Place the .psd file in the composition, and position it wherever you like.

9. With the placed button-to-be selected, pull down the Object menu, select Convert Into, and click Objects.

10. Open the timeline window (if it isn’t already), and you’ll see that there are two objects in it, named by the layer names of the Photoshop file. If you did not rename the layers, you’ll have Background copy on top and Background underneath.

11. Select the top layer and give it an Over state in the States palette.

12. With the Over state selected, change the Object Layer Opacity to 0%. You must use Object Layer Opacity for state changes; Object Opacity applies globally to all states of an object, which is not what you want.

13. Select the Normal state, and set Object Layer Opacity to 99% instead of 100%. There’s a peculiarity in the Flash 5 player that causes bitmaps to shift when faded all the way from 0% to 100%. The 1% difference will not be noticeable.

14. Preview what you’ve done. When the mouse cursor passes over the button the image should spring from black and white into full color.

In this particular example, it may advantageous to give the black and white image a different export setting from the color image. A posterized image will almost certainly export at a smaller file size when changed to indexed color. Be sure to leave transparency enabled, or upon export to Flash, it will be a black object instead of an invisible object at 0% Object Layer Opacity.

(2)Turning Photographs Into a LiveMotion Movie

Bitmap images work well in animations if handled with proper respect, and with a view to what the end product will be. The Flash player was developed primarily for animating vector objects, and asking it to redraw the position of thousands of pixels once per frame is very demanding of the viewer’s system. Even quite powerful computers have been known to “chug” on overly-demanding bitmap animations exported to Flash. Also, the exported file will tend to be relatively large.

Bitmap images do not rotate, skew, or scale up attractively. The Flash player does not anti-alias bitmaps, so rotating or skewing them will result in visibly jagged edges. Scaling up produces a visible loss of resolution, as a fixed number of pixels is required to fill more screen area.

We are certainly not advising you to steer clear of animating bitmaps for export to Flash, only to be aware of certain constraints. If you plan on exporting to QuickTime video, only the scaling resolution problem applies.

In the example that follows, we animated layers of a Photoshop file that we prepared specifically for this purpose, and then added a second photograph. It’s a tracking shot of a car driving through a wooded landscape. The car itself does not change position—it’s as if the movie was shot with a camera that traveled at the same speed as the car. Distant mountains and sky also remain stationary, but the forest between the car and mountains animates slowly from left to right. We also have four trees that cross the screen quite quickly (although at slightly different speeds), as if they were between the car and our virtual camera. The result is a very simple movie, but one with a convincing sense of motion and perspective.

Much of the “heavy lifting” was in preparing the landscape image in Photoshop, and the details will vary greatly from photo to photo. Here’s how it worked in our specific example.

1. We opened a high-resolution stock photo in Photoshop, and reduced the resolution so the image would be 1000 pixels wide, twice the width of our LiveMotion movie.

2. We carefully selected out the four foreground trees, and cut and pasted each on its own layer. Of course, this left transparent holes in the original background layer.

3. We selected out patches for the holes from the remaining background forest, copied and pasted, moved them around, merged the forest down into a single layer, and touched up with the Clone tool until we had a convincing forest with no holes in it. You can see this is actually easier if you build a composite image from selections taken from several photos.

4. We selected out the whole forest, and cut and pasted it onto a new layer.

5. We patched the holes in the background mountains just like we did the forest.

6. We made a marquee selection on the remaining background the same pixel size as our final movie, and pasted it on a new layer. This is to avoid loading up our movie with pixels that will never appear on canvas.

7. We turned off the visibility of the background layer, made sure we had, and saved the file in .psd format for possible future use.

8. Because we’d saved our selections, we saved the file as a copy without preserving the Alpha channels.

9. We opened a new LiveMotion composition and placed the copy of the .psd file. It came in as a single object with all the layers embedded.

10. In order to separate out the layers so we could animate them individually, we went to the Object menu and chose Convert Into, Objects. Each of our Photoshop layers now became a separate object in the timeline.

11. We discarded the original background layer, and all those off-canvas pixels along with it.

12. After stretching the composition timeline to five seconds, we set position keyframes for the background forest in the first and last frames of the timeline to move it all the way across the screen in five seconds.

13. We adjusted the duration bars of the four foreground trees so each would only exist in the movie when needed, and set position keyframes to move each from just off the left edge of the canvas to just off the right edge at a faster rate than the forest, the largest tree taking the least time.

14. As it turned out, the tree we chose to be the fastest mover wasn’t at the top of the stacking order, so we moved it there in the timeline window.

15. Left over from another project, we already had a .psd file of a car with everything but the car transparent. We resized it in Photoshop to suit the scale of our current project, and placed the file.

16. We positioned the car where we wanted it on canvas, and dragged its layer down the stacking order so it was above the forest and below all four foreground trees.

17. Following a few previews in a Web browser and a few tweaks to the timing of the animation, we thought the car itself needed a little more work to fit into the movie without looking artificial. We selected the car object in LiveMotion, and invoked Edit Original from the Edit menu. This kicked us back into Photoshop and automatically opened a new copy of the car’s .psd file. We could now do whatever changes were necessary to the copy without any effect on the file we’d placed.

18. A little work with the Blur Tool on the wheels later, we saved the file in Photoshop and switched back to LiveMotion. The revised image had updated automatically. The car object in the timeline still had its original filename, now followed by a plus sign so we’d know it was an edited copy. Our movie was now complete, ready for export to Flash or QuickTime.
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Now that’s integration! We took a single-layer photograph and manipulated it onto multiple layers in Photoshop, place it into LiveMotion as a single object, converted its latent layers into individual objects, changed the stacking order of the layers, placed a new photograph in between those layers in LiveMotion, performed further editing of the second photograph in Photoshop without disturbing the original, and automatically reaped the rewards of that editing in LiveMotion. It all worked seamlessly.

In this particular case, we didn’t have to return the multi-layer landscape photograph to Photoshop for further work, but there would have been no problem doing so, even after converting its layers into separate LiveMotion objects. We’d simply have selected any of those objects, invoked Edit Original, and a copy of the entire image would have opened in Photoshop ready to edit, LiveMotion stacking order changes intact.

(1)Integrating Illustrator and LiveMotion

LiveMotion has its own set of excellent vector drawing tools, so there is little reason to use Illustrator for creating basic shapes and paths for use in LiveMotion. Illustrator, however, has capabilities for working with more complex shapes, with type, and with blends to create effects that would be tedious to execute in LiveMotion alone. In this section, we’ll focus on those powerful features.

(2)Illustrator and LiveMotion Paths

Illustrator shapes can be edited with LiveMotion’s Pen Tool only if they are simple, non-compound paths with no stroke and a solid color fill. Because the Illustrator 9 and 10 file format is based on the Adobe .pdf format, they will come into LiveMotion with a .pdf “wrapper” that must first be removed by converting them to LiveMotion paths using the Edit menu.

By default, Illustrator also uses the .pdf format for items copied or cut to the clipboard. You can change this in Illustrator’s preferences by opening the Edit menu, selecting Preferences, Files & Clipboard, and checking AICB instead of PDF.

LiveMotion shapes may be pasted into Illustrator; however, they will come in as bitmap images.

(2)Illustrator Vectors and the Flash Player

Vector objects are strictly defined in the Flash (.swf) format, and Illustrator’s definition of vectors is somewhat different. Consequently, many Illustrator objects cannot be rendered as vectors in the Flash player. In that case, LiveMotion will export them as bitmap objects, with consequences similar to using any other bitmaps in Flash. A partial list of the most frequently encountered bitmap-causing content in Illustrator files includes:

· Strokes. The Flash player does not interpret Illustrator strokes as outlines.

· Linear gradients. The workaround is to convert Illustrator linear gradients to blends with a set number of steps.

· Gradient mesh.

· Most layer effects.

· Drop shadows.

· Certain mask combinations.

· Any raster content.

· Applied styles that include any of the above.

Naturally, we’re not suggesting that you never use any of these if you plan on exporting to Flash. Just be aware of what causes bitmapping in the Flash player, and use the workarounds if they will produce the appearance you need. If you have any doubts about your Illustrator artwork exporting as vectors, check it after placing it in LiveMotion using Preview Export Compression.

(2)Illustrator Type on a Path

Arranging letters in along a curved shape in LiveMotion requires several steps that must each be done by hand. You must first create the text, then break it apart, and finally position each letter where you want it. While that’s a fine start to animating individual letters, it’s a lot of unnecessary work if you don’t plan on animating the text, or if you want to animate it as a group. You end up with multiple objects that are hard to handle. Using Illustrator is just the thing for making such a task simple. Here’s an example.

1. Open a new file in Illustrator. Be sure you’re working in the RGB color space, and have measurements set to pixels. You may wish to size the artboard to match your LiveMotion composition, but that’s optional.

2. Use the Ellipse Tool to draw a stroked, unfilled circle.

3. Pick the Path Type Tool, and select whatever font and size you like from the Character palette.

4. Click on the stroked part of the circle, and key in the text of your choice. Change the text color, if you like.

5. Save the file in Illustrator (.ai) format. There’s no need to embed the font.

6. Open your LiveMotion composition, or create a new one as needed.

7. Place the Illustrator file you just made.

8. Reposition it and scale it however you like.

That’s all there is to it. You now have type on a path that’s a single vector object, ready for animation or export (note that if you’ll be scripting the animation, you should rename the object first—the dot in the filename will cause problems). The type will remain vector in the Flash player. If you need to adjust the color, invoke Edit Original, make the change in Illustrator, and save the file. Your original Illustrator file will not be affected.
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(2)Wrapping Text Around an Object

LiveMotion’s Type Tool let you create point or paragraph text very easily, but there is no provision for wrapping text around a shape. You can simulate text wrapping by manipulating text justification, adding line returns, and entering multiple spaces. But wouldn’t it be nice to wrap text automatically around a curved or angled shape? Fortunately, Illustrator excels at doing just that.

While you cannot use an actual object from your LiveMotion composition as a path in Illustrator, you can certainly paste one in and use it as a guide for creating a path of the correct size and shape in Illustrator.

1. If you want the text to wrap along a shape you’ve already created in LiveMotion, copy that shape to the clipboard and paste it into a new Illustrator composition.

2. Use Illustrator’s Pen Tool to draw a path duplicating the shape (perfect accuracy is probably not required). If there’s much of a curve or slant to the shape, it’s best to close the path. Open paths may slice words out of text you’ll be wrapping.

3. Delete the LiveMotion object.

4. Draw a text box using the Type Tool, and key in your text in whatever font and color you prefer.

5. Position the path so it overlaps the edge of the text box you wish to wrap.

6. Select both path and text box, open the Type menu, and invoke Wrap, Make. The text should wrap along the path.

7. Save the file in Illustrator .ai format. There is no need to embed the font.

8. Place the file into your LiveMotion composition, and position as needed.

That’s it!
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(2)Filling a Shape With Text

In this, our final example of working with Illustrator type and LiveMotion, we’ll take you several steps further. As we pointed out previously, LiveMotion paragraph text is limited to occupying a rectangular shape. What if we wanted to fill a non-rectangular object with text? The answer is to use Illustrator’s Area Type Tool.

The basic technique is similar to our previous examples, but with an important difference. Illustrator type placed in LiveMotion exports to Flash as paths, which is fine for small amounts of text, but runs up the file size of the exported file alarmingly when dealing with more than a few words. Type paths are relatively complex shapes defined by many control points, and each control point represents data that must be exported.

Native Flash text is much “lighter” than type paths, so what we’ll do is export the text to Flash directly from Illustrator, and then load it on top of our LiveMotion composition when viewed in the Flash player.

1. Begin by creating the shape you want to fill in LiveMotion. We used an elongated ellipse which we rotated to slant across the canvas.

2. Use guides to determine the position of the ellipse on the canvas so you’ll be able to position it identically in Illustrator.

3. Copy the ellipse to the clipboard.

4. In Illustrator, open a new file with an artboard the same pixel size as your LiveMotion composition.

5. Paste the ellipse onto the artboard, and use guides to position it.

6. Use Illustrator’s Ellipse and Rotate Tools to draw a path that just covers the pasted ellipse.

7. Delete the pasted ellipse.

8. Click on the elliptical path near the top with the Area Type Tool, and key in your text in whatever font and size suits you. We used center justification, but that’s entirely optional.

9. Make the text whatever color you want it to be when superimposed over your LiveMotion object.

10. Export directly to Flash from Illustrator.

11. Return to LiveMotion, and script the loadMovieNum() method to load the movie you just exported from Illustrator. This can be in the composition’s onLoad event handler, or in a script keyframe on the timeline. Because we made both compositions the same size, there’s no need to load it into a placeholder movie clip, or otherwise manipulate its position with scripting.

12. Export your LiveMotion movie to Flash with the Export palette set to automatically generate an HTML page. Even if you’re later going to embed your .swf in a Web page using GoLive, having LiveMotion produce HTML for test purposes is handy.

13. Open the HTML page you just made from the File menu of the browser of your choice, and see what you just created. Note: you cannot view loaded movies with LiveMotion’s Preview tool or by using Preview in Browser.
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Illustrator Blend to LiveMotion Sequence

LiveMotion does not support “shape tweens.” For instance, there is no way in LiveMotion to animate the control points of vector shapes to have a triangle gradually change into a square. You can replace objects with other objects, but that’s a sudden change from one shape to the next in a single frame. To simulate a gradual change of shape, you would have to draw all the intervening objects, which is a tough job! What does an object that’s half way between a triangle and a square look like, anyway?

Once again, LiveMotion’s integration with Illustrator makes the job easy. In this exercise, you’ll create a blend in Illustrator, give the blend path a new shape, and automatically animate the resulting objects in LiveMotion as a sequence. Begin by opening new compositions in both Illustrator and LiveMotion, making them both 400 pixels wide and 300 pixels high.

1. In Illustrator, draw a small, blue triangle near the top left of the artboard, around 20 pixels high. Use fill color only, with no stroke.

2. Draw a much larger red square, around 100 pixels high, in the lower right corner.

3. Double-click the Blend Tool to bring up the Blend Options dialog box. Set it for 12 Specified Steps (the orientation doesn’t really matter). Click OK.

4. Using the Blend Tool, click first the blue triangle, and then the red square to create the blend. Wow! Note that the blend happens along a straight path from upper left to lower right, known as the spine.

5. Let’s replace the straight spine with a custom curved one. Deselect the blend, and use the Pen Tool to draw a nice curve. Click once near the upper left corner, click and drag down near the middle of the right edge of the artboard, and finally click towards the bottom right. Swap the fill for a stroke if you like to make the path easier to see. Next, select both the blend and the path you just drew, and from the Object menu, select Blend, Replace Spine. Wow again! If any part of the blend went outside the bounds of the artboard, you can modify the shape of the spine using the Direct Selection Tool.

6. Now let’s change the blend into a group of objects. Select the blend, and from the Object menu, choose Blend, Expand. You now have a group of 12 objects instead of a blend, as you can see in the Layers palette, and the spine no longer exists.

7. From the Object menu, invoke Ungroup. You now have 12 paths in the Layers palette.

8. Save the file in Illustrator .ai format. You’re done with Illustrator for now.

Figure 1: The Illustrator artboard and Layers palette.

9. Return to LiveMotion, and place the Illustrator file you just saved. It will come in as a single object.

10. The Illustrator 9/10 file format is .pdf based, which means there’s a hidden “wrapper” that must be stripped away before you can work with its paths or layers in LiveMotion. Do this by selecting the placed object, and choosing Convert Into, Objects in the Object menu. You’ll see the name in the timeline window change from the name of the placed file to Layer 1. The wrapper is gone.

11. Now go back to the Object menu, and choose Convert Into, Sequence. You’ll see the timeline expand to accommodate 12 frames-worth of sequence.

12. Preview what you’ve accomplished. Nice, isn’t it.

If this is the first time you’ve converted objects into a LiveMotion sequence, please don’t confuse it with File, Place Sequence. That’s for placing a set of separate files, not for converting a single object.

Many, many things can be done with blends and sequences, as we’re sure you realize by now. But what was the point of this exercise? It might be a fancy way of introducing a menu or a block of descriptive text, for one thing. Enclose the blend in stopped a movie clip group with an invisible trigger button in the first frame over the triangle, and more buttons or text in the last frame over the square. Click the button, and zoom!

(2)Illustrator Blend to Morphing Button

LiveMotion sequences are very useful entities, but they don’t give you very much control. Essentially, the sequence plays, and that’s it. While it’s simple enough to trigger them at will, the Element Index keyframes that define a sequence do not respond well to being played in reverse, being sent to labels, or anything of that sort. If you want to do that using Illustrator blends, you’ll need to convert them into objects, not into a sequence. That’s what we’ll show you how to do in this exercise. You will create a button that morphs when the mouse cursor rolls over it, and morphs back when the mouse rolls out. As before, begin by opening new compositions in both LiveMotion and Illustrator.

1. In Illustrator, draw a button shape as you see fit (we made a traditional rounded rectangle). Be sure not to apply strokes to any Illustrator objects if you want them to export to Flash as vectors.

2. Draw the shape you want your morph to end with somewhere else on the artboard. We made a nine-pointed star with a tight inner radius, and gave it a different fill color from the button shape.

3. Create a blend with a specified number of steps. You probably don’t want more than ten or so for a morphing button, or the resulting animation will be too slow.

4. Expand the blend, and ungroup the objects.

5. Select all the objects, and align them in the Align palette so their centers are all stacked on top of one another (you could also do this later in LiveMotion, if you choose).

6. Save the file in Illustrator .ai format.

7. Place the file in LiveMotion, and position the object where you want the button to be. Right now, it looks pretty weird with all the blend objects superimposed, but you’ll soon fix that.

8. Convert into objects twice; once to remove the .pdf wrapper, and a second time to distill out the separate objects.

9. Turn all the objects into a movie clip group.

10. Dive down into the movie clip group’s independent timeline, and stretch it out to the same number of frames as you have objects.

11. Manipulate the individual duration bars so they each occupy a single frame of the timeline; button in the first frame, and the object from the opposite end of the blend in the last frame. Pull the Current Time Marker back and forth to see how the morph will look.

12. Duplicate the button object, drag its duration bar out so it exists for the entire length of the movie clip group’s timeline, set its opacity to zero, and make it a movie clip. Name it something along the lines of “trigger.”

If you’ve worked through this book to this point, we’re sure you can readily see what the next steps are. There are a variety of ways to implement the button, and we’ll let you choose whichever techniques you’re most comfortable with. The overall plan, of course, is to stop the morph until the mouse cursor rolls over the invisible trigger object, and then play the animation in reverse when the cursor rolls out from the trigger.

Illustration 7
Illustration 8
Illustration 9
Production Editor: Illos 7, 8, and 9 are intended to go side-by-side to show the button in the beginning, intermediat, and end stages of the morph.
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